summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2007-12-29 03:16:05 +0000
committerRichard Freeman <rich0@gentoo.org>2007-12-29 03:16:05 +0000
commitd31ba866de2c4702c4f2a5998bba31221a5a0904 (patch)
treec060436c785428a67b5c18c6d27d064d5c090603 /games-rpg/eternal-lands
parentVersion bump - #201161 (diff)
downloadgentoo-2-d31ba866de2c4702c4f2a5998bba31221a5a0904.tar.gz
gentoo-2-d31ba866de2c4702c4f2a5998bba31221a5a0904.tar.bz2
gentoo-2-d31ba866de2c4702c4f2a5998bba31221a5a0904.zip
Version bump - #201161
(Portage version: 2.1.3.19)
Diffstat (limited to 'games-rpg/eternal-lands')
-rw-r--r--games-rpg/eternal-lands/ChangeLog8
-rw-r--r--games-rpg/eternal-lands/eternal-lands-1.5.0.ebuild139
-rw-r--r--games-rpg/eternal-lands/files/digest-eternal-lands-1.5.06
-rw-r--r--games-rpg/eternal-lands/metadata.xml4
4 files changed, 156 insertions, 1 deletions
diff --git a/games-rpg/eternal-lands/ChangeLog b/games-rpg/eternal-lands/ChangeLog
index 879fbae28084..bd918319da74 100644
--- a/games-rpg/eternal-lands/ChangeLog
+++ b/games-rpg/eternal-lands/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-rpg/eternal-lands
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/ChangeLog,v 1.34 2007/05/13 20:26:01 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/ChangeLog,v 1.35 2007/12/29 03:16:04 rich0 Exp $
+
+*eternal-lands-1.5.0 (29 Dec 2007)
+
+ 29 Dec 2007; Richard Freeman <rich0@gentoo.org> metadata.xml,
+ +eternal-lands-1.5.0.ebuild:
+ Version bump - #201161
13 May 2007; Roy Marples <uberlord@gentoo.org> eternal-lands-1.3.3.ebuild:
We only work if cal3d isn't built with 16bit-indicies, #177858 thanks to
diff --git a/games-rpg/eternal-lands/eternal-lands-1.5.0.ebuild b/games-rpg/eternal-lands/eternal-lands-1.5.0.ebuild
new file mode 100644
index 000000000000..b0d17ca17acc
--- /dev/null
+++ b/games-rpg/eternal-lands/eternal-lands-1.5.0.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/eternal-lands-1.5.0.ebuild,v 1.1 2007/12/29 03:16:04 rich0 Exp $
+
+inherit eutils flag-o-matic games
+
+MY_PV="${PV//_/}"
+MY_PV="${MY_PV//./}"
+S="${WORKDIR}/elc"
+DESCRIPTION="An online MMORPG written in C and SDL"
+HOMEPAGE="http://www.eternal-lands.com"
+SRC_URI="mirror://gentoo/elc_${MY_PV}.tar.bz2
+ mirror://gentoo/eternal-lands.png"
+
+# NOTE: Sometimes you'll have to roll your own elc tarball from their CVS
+# tree as they don't always release one.
+# If they do then use this in SRC_URI instead
+# ftp://ftp.berlios.de/pub/elc/elc_${MY_PV}.tgz
+
+LICENSE="eternal_lands"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="debug doc kernel_linux"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ virtual/opengl
+ >=media-libs/libsdl-1.2.5
+ >=media-libs/sdl-net-1.2.5
+ media-libs/openal
+ media-libs/freealut
+ media-libs/libvorbis
+ >=dev-libs/libxml2-2.6.7
+ media-libs/cal3d
+ !=media-libs/cal3d-0.11.0_pre20050823
+ >=media-libs/libpng-1.2.8
+ media-libs/sdl-image
+ media-libs/mesa
+ ~games-rpg/${PN}-data-${PV}"
+
+DEPEND="${RDEPEND}
+ >=app-admin/eselect-opengl-1.0.6-r1
+ app-arch/unzip
+ doc? ( >=app-doc/doxygen-1.3.8
+ >=media-gfx/graphviz-1.10 )"
+
+pkg_setup() {
+ if built_with_use media-libs/cal3d 16bit-indices ; then
+ eerror "${PN} won't work if media-libs/cal3d has been built with 16bit-indices"
+ die "re-emerge media-libs/cal3d without the 16bit-indices USE flag"
+ fi
+}
+
+src_unpack() {
+ OPTIONS="-DDATA_DIR="\\\\\"${GAMES_DATADIR}/${PN}/\\\\\"""
+ S_CLIENT="${WORKDIR}/elc"
+ BROWSER="firefox"
+
+ unpack ${A}
+ cd "${S}"
+
+ # Create updated files with correct perms and allow dir creation
+ #epatch "${FILESDIR}/${PN}-1.3.0-update-createdir.patch"
+
+ # Build for amd64
+ use amd64 && OPTIONS="${OPTIONS} -DX86_64"
+
+ # This should be default in the next version
+ OPTIONS="${OPTIONS} -DUSE_ACTOR_DEFAULTS -DGL_EXTENSION_CHECK"
+
+ # Add debugging options
+ if use debug ; then
+ OPTIONS="${OPTIONS} -DMEMORY_DEBUG"
+ append-flags -ggdb
+ fi
+
+ sed \
+ -e "s@CFLAGS=\$(PLATFORM) \$(CWARN) -O0 -ggdb -pipe@CFLAGS=${CFLAGS} ${OPTIONS} @g"\
+ -e "s@CXXFLAGS=\$(PLATFORM) \$(CXXWARN) -O0 -ggdb -pipe@CXXFLAGS=${CXXFLAGS} ${OPTIONS} @g"\
+ -e 's/lopenal/lopenal -l alut/' \
+ Makefile.linux > Makefile \
+ || die "sed failed"
+ sed -i \
+ -e 's/#browser/browser/g' \
+ -e "s/browser = mozilla/#browser = ${BROWSER}/g" \
+ -e "s@#data_dir = /usr/local/games/el/@#data_dir = ${GAMES_DATADIR}/${PN}/@g" \
+ el.ini || die "sed failed"
+
+ # Support BSD in the Linux makefile - it's easier
+ use kernel_linux || sed -i -e 's/^CFLAGS=.*/& -DBSD/' Makefile || die "sed failed"
+
+ # Gah
+ sed -i -e 's/CXX=g++/CXX=gcc/' Makefile || die "sed failed"
+
+ # Finally, update the server
+ sed -i -e '/#server_address =/ s/.*/#server_address = game.eternal-lands.com/' \
+ el.ini || die "sed failed"
+}
+
+src_compile() {
+ emake || die "make failed"
+ if use doc; then
+ emake docs || die "Failed to create documentation, try with USE=-doc"
+ mv ./docs/html/ ../client || die "Failed to move documentation directory"
+ fi
+}
+
+src_install() {
+ newgamesbin el.x86.linux.bin el || die "newgamesbin failed"
+ doicon "${DISTDIR}/eternal-lands.png"
+ make_desktop_entry el "Eternal Lands"
+
+ insopts -m 0660
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r *.ini *.txt commands.lst || die "doins failed"
+
+ if use doc ; then
+ dohtml -r client/*
+ fi
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "Auto Update is now enabled in Eternal Lands"
+ elog "If an update occurs then the client will suddenly exit"
+ elog "Updates only happen when the game first loads"
+ elog "Please don't report this behaviour as a bug"
+
+ # Ensure that the files are writable by the game group for auto
+ # updating.
+ chmod -R g+rw "${ROOT}/${GAMES_DATADIR}/${PN}"
+
+ # Make sure new files stay in games group
+ find "${ROOT}/${GAMES_DATADIR}/${PN}" -type d -exec chmod g+sx {} \;
+}
diff --git a/games-rpg/eternal-lands/files/digest-eternal-lands-1.5.0 b/games-rpg/eternal-lands/files/digest-eternal-lands-1.5.0
new file mode 100644
index 000000000000..c23464263959
--- /dev/null
+++ b/games-rpg/eternal-lands/files/digest-eternal-lands-1.5.0
@@ -0,0 +1,6 @@
+MD5 8109d42317f3d50f198b8649b339e169 elc_150.tar.bz2 1718210
+RMD160 d651456e18662cb635c31270f1430fb64f731f17 elc_150.tar.bz2 1718210
+SHA256 880ee5397b74e9dc4e2ed1f0a004b189b90607da4e7a349660079f2a99851f8a elc_150.tar.bz2 1718210
+MD5 059df8128b11b19a76b54e9907072f00 eternal-lands.png 9955
+RMD160 2f9c8acd96214577cf8b8027f0d20fb1fe7574ff eternal-lands.png 9955
+SHA256 dd7d45cd9948fe7875ebd0bfcd1925d9b34e7606a223faf61d37a6dd2cd433fb eternal-lands.png 9955
diff --git a/games-rpg/eternal-lands/metadata.xml b/games-rpg/eternal-lands/metadata.xml
index 6b2043697099..858d2d50857b 100644
--- a/games-rpg/eternal-lands/metadata.xml
+++ b/games-rpg/eternal-lands/metadata.xml
@@ -2,6 +2,10 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>games</herd>
+<maintainer>
+ <email>rich0@gentoo.org</email>
+ <name>Richard Freeman</name>
+</maintainer>
<longdescription>Eternal Lands is a FREE MMORPG (massively multiplayer online
role playing game)</longdescription>
</pkgmetadata>