summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-10-15 10:01:31 +0000
committerPacho Ramos <pacho@gentoo.org>2014-10-15 10:01:31 +0000
commit8249fb1607116843288df6f972a86965093780d4 (patch)
tree8fc67c5002b715048d47a0feffb21e187396d9e3 /games-rpg/nwmouse
parentbump; patch by Arfever to correct obligatory doc builds and incorrect install... (diff)
downloadgentoo-2-8249fb1607116843288df6f972a86965093780d4.tar.gz
gentoo-2-8249fb1607116843288df6f972a86965093780d4.tar.bz2
gentoo-2-8249fb1607116843288df6f972a86965093780d4.zip
Support multilib providers for deps. Bump to EAPI=5.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'games-rpg/nwmouse')
-rw-r--r--games-rpg/nwmouse/ChangeLog6
-rw-r--r--games-rpg/nwmouse/nwmouse-20090906.183839.ebuild40
2 files changed, 29 insertions, 17 deletions
diff --git a/games-rpg/nwmouse/ChangeLog b/games-rpg/nwmouse/ChangeLog
index e72a9e5ba2c9..1f29765ef9ac 100644
--- a/games-rpg/nwmouse/ChangeLog
+++ b/games-rpg/nwmouse/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-rpg/nwmouse
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwmouse/ChangeLog,v 1.14 2014/05/25 11:21:56 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwmouse/ChangeLog,v 1.15 2014/10/15 10:01:31 pacho Exp $
+
+ 15 Oct 2014; Pacho Ramos <pacho@gentoo.org> nwmouse-20090906.183839.ebuild:
+ Support multilib providers for deps. Bump to EAPI=5.
25 May 2014; Ulrich Müller <ulm@gentoo.org> nwmouse-20090906.183839.ebuild:
Fix LICENSE, bug 505732.
@@ -55,4 +58,3 @@
26 Jul 2006; Chris Gianelloni <wolf31o2@gentoo.org> +metadata.xml,
+nwmouse-0.1.ebuild:
Initial import. Ebuild by me. Closing bug #109619.
-
diff --git a/games-rpg/nwmouse/nwmouse-20090906.183839.ebuild b/games-rpg/nwmouse/nwmouse-20090906.183839.ebuild
index 2b96655d56e7..d36a2115d1fa 100644
--- a/games-rpg/nwmouse/nwmouse-20090906.183839.ebuild
+++ b/games-rpg/nwmouse/nwmouse-20090906.183839.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwmouse/nwmouse-20090906.183839.ebuild,v 1.5 2014/05/25 11:21:56 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwmouse/nwmouse-20090906.183839.ebuild,v 1.6 2014/10/15 10:01:31 pacho Exp $
+
+EAPI=5
inherit games
@@ -15,18 +17,26 @@ KEYWORDS="amd64 x86"
IUSE=""
RESTRICT="strip"
-RDEPEND="sys-libs/glibc
- dev-libs/elfutils
- games-rpg/nwn-data
- amd64? (
- app-emulation/emul-linux-x86-xlibs
- app-emulation/emul-linux-x86-sdl )
+RDEPEND="
>=games-rpg/nwn-1.68-r4
- x86? (
- x11-libs/libXcursor
- x11-libs/libXext
- x11-libs/libX11
- media-libs/libsdl )"
+ games-rpg/nwn-data
+ sys-libs/glibc
+ || (
+ (
+ >=dev-libs/elfutils-0.155-r1[abi_x86_32(-)]
+ >=media-libs/libsdl-1.2.15-r5[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXcursor[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ )
+ amd64? (
+ app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ app-emulation/emul-linux-x86-sdl[-abi_x86_32(-)]
+ app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
+ )
+ )
+"
+DEPEND=""
# I've looked at this stuff, and I can't find the problem myself, so I'm just
# removing the warnings. If someone feels like finding the patch, that would be
@@ -43,11 +53,11 @@ pkg_setup() {
src_install() {
# libelf moved to games-rpg/nwn, see bug #210562
exeinto "${dir}"
- doexe "${PN}.so" || die "Installation failed"
+ doexe "${PN}.so"
exeinto "${dir}/${PN}/libdis"
- doexe "libdisasm.so" || die "Installation failed"
+ doexe "libdisasm.so"
insinto "${dir}/${PN}/cursors"
- doins -r cursors/* || die "Installation failed"
+ doins -r cursors/*
prepgamesdirs
}