summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-09-05 18:02:37 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-09-05 18:02:37 +0000
commit3f5e01f8c460a3a2b3b6480ddc18c60234f7a80d (patch)
tree913e54307392794161b0e118724d6c7dca6a0e48 /games-rpg
parentVersion bump (diff)
downloadgentoo-2-3f5e01f8c460a3a2b3b6480ddc18c60234f7a80d.tar.gz
gentoo-2-3f5e01f8c460a3a2b3b6480ddc18c60234f7a80d.tar.bz2
gentoo-2-3f5e01f8c460a3a2b3b6480ddc18c60234f7a80d.zip
Fails to build without opengl (bug #378191)
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/tmw/ChangeLog5
-rw-r--r--games-rpg/tmw/tmw-0.5.2.ebuild12
2 files changed, 10 insertions, 7 deletions
diff --git a/games-rpg/tmw/ChangeLog b/games-rpg/tmw/ChangeLog
index 1b575b924e07..df97c7fb1e9b 100644
--- a/games-rpg/tmw/ChangeLog
+++ b/games-rpg/tmw/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-rpg/tmw
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/ChangeLog,v 1.39 2011/08/02 11:56:25 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/ChangeLog,v 1.40 2011/09/05 18:02:37 mr_bones_ Exp $
+
+ 05 Sep 2011; Michael Sterrett <mr_bones_@gentoo.org> tmw-0.5.2.ebuild:
+ Fails to build without opengl (bug #378191)
*tmw-0.5.2 (02 Aug 2011)
diff --git a/games-rpg/tmw/tmw-0.5.2.ebuild b/games-rpg/tmw/tmw-0.5.2.ebuild
index f6f3baf08582..92dc39961fa9 100644
--- a/games-rpg/tmw/tmw-0.5.2.ebuild
+++ b/games-rpg/tmw/tmw-0.5.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/tmw-0.5.2.ebuild,v 1.1 2011/08/02 11:56:25 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/tmw-0.5.2.ebuild,v 1.2 2011/09/05 18:02:37 mr_bones_ Exp $
EAPI=2
-inherit eutils games cmake-utils
+inherit eutils cmake-utils games
MUSIC=tmwmusic-0.3
@@ -15,7 +15,7 @@ SRC_URI="mirror://sourceforge/themanaworld/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="nls opengl"
+IUSE="nls"
RDEPEND=">=dev-games/physfs-1.0.0
dev-libs/libxml2
@@ -28,11 +28,11 @@ RDEPEND=">=dev-games/physfs-1.0.0
media-libs/libpng
media-fonts/dejavu
>=dev-games/guichan-0.8.1[sdl]
- media-libs/libsdl
+ media-libs/libsdl[opengl,video]
media-libs/sdl-gfx
x11-libs/libX11
nls? ( virtual/libintl )
- opengl? ( virtual/opengl )"
+ virtual/opengl"
DEPEND="${RDEPEND}
dev-util/pkgconfig
nls? ( sys-devel/gettext )"
@@ -57,7 +57,7 @@ src_prepare() {
src_configure() {
mycmakeargs=(
- $(cmake-utils_use_with opengl)
+ -DWITH_OPENGL=ON
$(cmake-utils_use_enable nls)
)
cmake-utils_src_configure