summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-01-05 20:37:51 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-01-05 20:37:51 +0000
commit48d16a79bcf8574530fccec4532a065a8f5f35f4 (patch)
tree2168a9d0355625e3ff366933af13ea3aa46d7172 /games-rpg
parentUse QA_PREBUILT, wrt bug #448420 (diff)
downloadgentoo-2-48d16a79bcf8574530fccec4532a065a8f5f35f4.tar.gz
gentoo-2-48d16a79bcf8574530fccec4532a065a8f5f35f4.tar.bz2
gentoo-2-48d16a79bcf8574530fccec4532a065a8f5f35f4.zip
Revision bump: EAPI 5, add ~x86 keyword
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/coe2/ChangeLog7
-rw-r--r--games-rpg/coe2/coe2-2007-r1.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/games-rpg/coe2/ChangeLog b/games-rpg/coe2/ChangeLog
index 9089df03e95f..95c4e8606a8c 100644
--- a/games-rpg/coe2/ChangeLog
+++ b/games-rpg/coe2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-rpg/coe2
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/coe2/ChangeLog,v 1.3 2013/01/05 20:13:14 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/coe2/ChangeLog,v 1.4 2013/01/05 20:37:51 pinkbyte Exp $
+
+*coe2-2007-r1 (05 Jan 2013)
+
+ 05 Jan 2013; Sergey Popov <pinkbyte@gentoo.org> +coe2-2007-r1.ebuild:
+ Revision bump: EAPI 5, add ~x86 keyword
05 Jan 2013; Sergey Popov <pinkbyte@gentoo.org> coe2-2007.ebuild:
Use QA_PREBUILT, fix minor QA issues, wrt bug #430026
diff --git a/games-rpg/coe2/coe2-2007-r1.ebuild b/games-rpg/coe2/coe2-2007-r1.ebuild
new file mode 100644
index 000000000000..f8e7f24c3280
--- /dev/null
+++ b/games-rpg/coe2/coe2-2007-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/coe2/coe2-2007-r1.ebuild,v 1.1 2013/01/05 20:37:51 pinkbyte Exp $
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Precursor to the Dominions series"
+HOMEPAGE="http://www.shrapnelgames.com/Illwinter/CoE2/"
+SRC_URI="http://download.shrapnelgames.com/downloads/${PN}_${PV}.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/coe"
+
+# bug #430026
+QA_PREBUILT="/opt/coe2/coe_linux"
+
+src_prepare() {
+ rm *.{dll,exe} || die 'rm failed'
+ rm -r old || die 'rm failed'
+ if use amd64 ; then
+ mv -f coe_linux64bit coe_linux || die "mv amd64 image failed"
+ fi
+}
+
+src_install() {
+ insinto "${GAMES_PREFIX_OPT}/${PN}"
+ doins *.{bgm,smp,trp,trs,wrl}
+ dodoc history.txt manual.txt readme.txt
+ exeinto "${GAMES_PREFIX_OPT}/${PN}"
+ doexe coe_linux
+
+ games_make_wrapper ${PN} "./coe_linux" "${GAMES_PREFIX_OPT}/${PN}"
+ make_desktop_entry ${PN} "Conquest of Elysium 2"
+
+ # Slots for saved games.
+ # The game shows e.g. "EMPTY SLOT 0?", but it works.
+ local f slot state_dir=${GAMES_STATEDIR}/${PN}
+ dodir "${state_dir}"
+ for slot in {0..4} ; do
+ f=save${slot}
+ dosym "${state_dir}/save${slot}" "${dir}/${f}"
+ echo "empty slot ${slot}" > "${D}${state_dir}/${f}" || die "echo"
+ fperms 660 "${state_dir}/${f}"
+ done
+
+ prepgamesdirs
+}