summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-12-01 20:26:27 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-12-01 20:26:27 +0000
commitd693450728f494b1183e24ad76a720746fd19f54 (patch)
tree18b0fc2d3c84606f09995c6fc69ea88c1337cca9 /games-rpg
parentamd64 stable - 347327 (diff)
downloadgentoo-2-d693450728f494b1183e24ad76a720746fd19f54.tar.gz
gentoo-2-d693450728f494b1183e24ad76a720746fd19f54.tar.bz2
gentoo-2-d693450728f494b1183e24ad76a720746fd19f54.zip
version bump - ebuild submitted by Simon in bug #338055
(Portage version: 2.1.9.24/cvs/Linux i686)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/daimonin-client/ChangeLog10
-rw-r--r--games-rpg/daimonin-client/daimonin-client-0.10.5.ebuild67
-rw-r--r--games-rpg/daimonin-client/files/daimonin-client-0.10.5-datadir.patch28
-rw-r--r--games-rpg/daimonin-client/files/daimonin-client-0.10.5-nozlib.patch40
-rw-r--r--games-rpg/daimonin-client/metadata.xml3
5 files changed, 147 insertions, 1 deletions
diff --git a/games-rpg/daimonin-client/ChangeLog b/games-rpg/daimonin-client/ChangeLog
index 0e5c25c8e354..775ad2c48726 100644
--- a/games-rpg/daimonin-client/ChangeLog
+++ b/games-rpg/daimonin-client/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for games-rpg/daimonin-client
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/daimonin-client/ChangeLog,v 1.26 2010/10/15 12:46:03 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/daimonin-client/ChangeLog,v 1.27 2010/12/01 20:26:27 mr_bones_ Exp $
+
+*daimonin-client-0.10.5 (01 Dec 2010)
+
+ 01 Dec 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +daimonin-client-0.10.5.ebuild,
+ +files/daimonin-client-0.10.5-datadir.patch,
+ +files/daimonin-client-0.10.5-nozlib.patch, metadata.xml:
+ version bump - ebuild submitted by Simon in bug #338055
15 Oct 2010; Brent Baude <ranger@gentoo.org>
daimonin-client-0.9.7.1-r1.ebuild:
diff --git a/games-rpg/daimonin-client/daimonin-client-0.10.5.ebuild b/games-rpg/daimonin-client/daimonin-client-0.10.5.ebuild
new file mode 100644
index 000000000000..a37eb104f802
--- /dev/null
+++ b/games-rpg/daimonin-client/daimonin-client-0.10.5.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/daimonin-client/daimonin-client-0.10.5.ebuild,v 1.1 2010/12/01 20:26:27 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils autotools games
+
+MY_P=${PN}-${PV}
+DESCRIPTION="a graphical 2D tile-based MMORPG"
+HOMEPAGE="http://daimonin.sourceforge.net/"
+SRC_URI="http://daimonin.svn.sourceforge.net/viewvc/daimonin/main/client/?view=tar&pathrev=6021
+ -> daimonin-client-0.10.5.tar.gz
+ music? ( mirror://sourceforge/daimonin/Addon%20packs/Music/AllMusic.zip
+ -> daimonin-client-AllMusic-20100827.zip )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="music debug"
+
+RDEPEND="media-libs/libsdl[audio,video]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-image[png]
+ dev-games/physfs
+ net-misc/curl"
+DEPEND="${RDEPEND}
+ music? ( app-arch/unzip )"
+
+S=${WORKDIR}/client/make/linux
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ if use music ; then
+ cd client/media
+ rm -f *
+ unpack ${PN}-AllMusic-20100827.zip
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-nozlib.patch
+ rm ../../src/include/z{lib,conf}.h
+ sed -i \
+ -e 's:$(d_datadir):$(DESTDIR)$(d_datadir):' \
+ -e '/PROGRAMS/s:daimonin-updater::' \
+ Makefile.am \
+ || die "sed failed"
+ eautoreconf
+ cd ../../src
+ epatch "${FILESDIR}"/${P}-datadir.patch
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --disable-simplelayout \
+ $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ cd ../..
+ dodoc README*
+ newicon bitmaps/pentagram.png ${PN}.png || die "newicon failed"
+ make_desktop_entry daimonin Daimonin
+ prepgamesdirs
+}
diff --git a/games-rpg/daimonin-client/files/daimonin-client-0.10.5-datadir.patch b/games-rpg/daimonin-client/files/daimonin-client-0.10.5-datadir.patch
new file mode 100644
index 000000000000..ea79f7595910
--- /dev/null
+++ b/games-rpg/daimonin-client/files/daimonin-client-0.10.5-datadir.patch
@@ -0,0 +1,28 @@
+--- main.c.old 2010-08-24 19:32:55.000000000 +0200
++++ main.c 2010-09-19 18:49:54.000000000 +0200
+@@ -2386,7 +2386,7 @@
+
+ /* Add the base dir to the search path. The base dir is where all the
+ * defaults are (or should be). */
+- if (!PHYSFS_addToSearchPath(PHYSFS_getBaseDir(), 1))
++ if (!PHYSFS_addToSearchPath(SYSPATH, 1))
+ {
+ LOG(LOG_MSG, "%s\n", PHYSFS_getLastError());
+ }
+@@ -2545,13 +2545,13 @@
+
+ /* Prepend the user dir to the search path. This means files are read from
+ * this location in preference to the defaults. */
+- if (strcmp(PHYSFS_getBaseDir(), home))
+- {
++ /*if (strcmp(PHYSFS_getBaseDir(), home))
++ {*/
+ if (!PHYSFS_addToSearchPath(home, 0))
+ {
+ LOG(LOG_ERROR, "%s\n", PHYSFS_getLastError());
+ }
+- }
++ //}
+
+ /* Prepend any add-on packs to the search path. This means files are read
+ * from these locations in preference to the defaults and the user dir. */
diff --git a/games-rpg/daimonin-client/files/daimonin-client-0.10.5-nozlib.patch b/games-rpg/daimonin-client/files/daimonin-client-0.10.5-nozlib.patch
new file mode 100644
index 000000000000..c342cc3c3850
--- /dev/null
+++ b/games-rpg/daimonin-client/files/daimonin-client-0.10.5-nozlib.patch
@@ -0,0 +1,40 @@
+--- Makefile.am.old 2010-12-01 14:39:11.605648458 -0500
++++ Makefile.am 2010-12-01 14:41:59.875915880 -0500
+@@ -2,23 +2,18 @@
+ daimonin_PROGRAMS = daimonin daimonin-updater
+
+ daimonin_SOURCES = \
+- ../../src/adler32.c \
+ ../../src/anim.c \
+ ../../src/book.c \
+ ../../src/buddy.c \
+ ../../src/chatfilter.c \
+ ../../src/client.c \
+ ../../src/commands.c \
+- ../../src/crc32.c \
+ ../../src/dialog.c \
+ ../../src/event.c \
+ ../../src/filewrap.c \
+ ../../src/font.c \
+ ../../src/group.c \
+ ../../src/ignore.c \
+- ../../src/inffast.c \
+- ../../src/inflate.c \
+- ../../src/inftrees.c \
+ ../../src/interface.c \
+ ../../src/inventory.c \
+ ../../src/item.c \
+@@ -35,11 +30,9 @@
+ ../../src/sprite.c \
+ ../../src/textwin.c \
+ ../../src/tile_stretcher.c \
+- ../../src/uncompr.c \
+ ../../src/wrapper.c \
+- ../../src/widget.c \
+- ../../src/zutil.c
+-daimonin_LDADD = -lSDL_mixer -lSDL_image @SDL_LIBS@ @EXTRA_LIBS@ @PHYSFS_LIBS@
++ ../../src/widget.c
++daimonin_LDADD = -lSDL_mixer -lSDL_image @SDL_LIBS@ @EXTRA_LIBS@ @PHYSFS_LIBS@ -lz
+ daimonin_OBJDIR = objs
+
+ daimonin_updater_SOURCES = \
diff --git a/games-rpg/daimonin-client/metadata.xml b/games-rpg/daimonin-client/metadata.xml
index d3c2cc926f0b..768443e782d2 100644
--- a/games-rpg/daimonin-client/metadata.xml
+++ b/games-rpg/daimonin-client/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>games</herd>
+ <use>
+ <flag name="music">Install extra music</flag>
+ </use>
</pkgmetadata>