summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-01-26 22:32:55 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-01-26 22:32:55 +0000
commit0a2efd61d0671709daa67020028c0cb1c4515cff (patch)
tree09431ad97e9672976bbed2ffafe1107ca9ad574a /games-server
parentold (diff)
downloadgentoo-2-0a2efd61d0671709daa67020028c0cb1c4515cff.tar.gz
gentoo-2-0a2efd61d0671709daa67020028c0cb1c4515cff.tar.bz2
gentoo-2-0a2efd61d0671709daa67020028c0cb1c4515cff.zip
old
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-server')
-rw-r--r--games-server/monopd/ChangeLog7
-rw-r--r--games-server/monopd/files/monopd20
-rw-r--r--games-server/monopd/files/monopd-0.9.3-dosfix.patch36
-rw-r--r--games-server/monopd/files/monopd-0.9.3-gcc43.patch68
-rw-r--r--games-server/monopd/monopd-0.9.3-r1.ebuild36
5 files changed, 6 insertions, 161 deletions
diff --git a/games-server/monopd/ChangeLog b/games-server/monopd/ChangeLog
index 08dc574715c6..85d5718fe412 100644
--- a/games-server/monopd/ChangeLog
+++ b/games-server/monopd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-server/monopd
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/monopd/ChangeLog,v 1.26 2015/01/26 09:51:06 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-server/monopd/ChangeLog,v 1.27 2015/01/26 22:32:55 mr_bones_ Exp $
+
+ 26 Jan 2015; Michael Sterrett <mr_bones_@gentoo.org> -files/monopd,
+ -files/monopd-0.9.3-dosfix.patch, -files/monopd-0.9.3-gcc43.patch,
+ -monopd-0.9.3-r1.ebuild:
+ old
26 Jan 2015; Agostino Sarubbo <ago@gentoo.org> monopd-0.9.7.ebuild:
Stable for x86, wrt bug #534574
diff --git a/games-server/monopd/files/monopd b/games-server/monopd/files/monopd
deleted file mode 100644
index c963f9999690..000000000000
--- a/games-server/monopd/files/monopd
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/monopd/files/monopd,v 1.3 2004/07/14 22:23:06 agriffis Exp $
-
-depend() {
- use net
-}
-
-start() {
- ebegin "Starting monopd server"
- start-stop-daemon --start -q -b --exec /usr/games/bin/monopd
- eend $?
-}
-
-stop() {
- ebegin "Stopping monopd server"
- start-stop-daemon --stop -q --exec /usr/games/bin/monopd
- eend $?
-}
diff --git a/games-server/monopd/files/monopd-0.9.3-dosfix.patch b/games-server/monopd/files/monopd-0.9.3-dosfix.patch
deleted file mode 100644
index 6b5c9e67a500..000000000000
--- a/games-server/monopd/files/monopd-0.9.3-dosfix.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- monopd-0.9.3/src/server.cpp Sat Jul 17 14:45:47 2004
-+++ server.cpp Fri Mar 17 14:19:06 2006
-@@ -791,7 +791,7 @@
- switch(data[1])
- {
- case 'n':
-- pNew = newPlayer(socket, data.substr(2));
-+ pNew = newPlayer(socket, data.substr(2, 16));
- sendXMLUpdates();
- sendXMLUpdate(pNew, true, true); // give new player a full update (excluding self) so it knows who's in the lounge
- return;
-@@ -832,13 +832,13 @@
- switch(data[0])
- {
- case 'n':
-- setPlayerName(pInput, std::string(data+1));
-+ setPlayerName(pInput, data2.substr(1, 16));
- return;
- case 'p':
- switch(data[1])
- {
- case 'i':
-- pInput->setProperty("image", data+2, this);
-+ pInput->setProperty("image", data2.substr(2, 32), this);
- return;
- }
- break;
-@@ -1132,7 +1132,7 @@
- switch(data[1])
- {
- case 'd':
-- setGameDescription(pInput, data2.substr(2));
-+ setGameDescription(pInput, data2.substr(2, 64));
- return;
- case 'c':
- game->editConfiguration( pInput, data+2 );
diff --git a/games-server/monopd/files/monopd-0.9.3-gcc43.patch b/games-server/monopd/files/monopd-0.9.3-gcc43.patch
deleted file mode 100644
index 553e17c81870..000000000000
--- a/games-server/monopd/files/monopd-0.9.3-gcc43.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-http://bugs.gentoo.org/218833
-
-fix building with gcc-4.3
-
---- monopd-0.9.3/src/cardgroup.cpp
-+++ monopd-0.9.3/src/cardgroup.cpp
-@@ -14,7 +14,7 @@
- // the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
- // Boston, MA 02111-1307, USA.
-
--#include <algo.h>
-+#include <algorithm>
-
- #include "card.h"
- #include "cardgroup.h"
---- monopd-0.9.3/src/estategroup.cpp
-+++ monopd-0.9.3/src/estategroup.cpp
-@@ -14,6 +14,7 @@
- // the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
- // Boston, MA 02111-1307, USA.
-
-+#include <stdlib.h>
- #include <iostream>
-
- #include <math++/nodes.h>
---- monopd-0.9.3/src/game.cpp
-+++ monopd-0.9.3/src/game.cpp
-@@ -20,7 +20,8 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <syslog.h>
--#include <algo.h> // libstdc++ from the gcc 2.95 has no #include <algo> yet :(
-+#include <string.h>
-+#include <algorithm> // libstdc++ from the gcc 2.95 has no #include <algo> yet :(
-
- #include <map>
- #include <string>
---- monopd-0.9.3/src/main.cpp
-+++ monopd-0.9.3/src/main.cpp
-@@ -18,6 +18,7 @@
- #include <signal.h>
- #include <syslog.h>
- #include <unistd.h>
-+#include <stdlib.h>
-
- #include <iostream>
- #include <string>
---- monopd-0.9.3/src/player.cpp
-+++ monopd-0.9.3/src/player.cpp
-@@ -18,6 +18,7 @@
- #include <stdarg.h>
- #include <stdio.h>
- #include <stdlib.h>
-+#include <string.h>
-
- #include <string>
-
---- monopd-0.9.3/src/server.cpp
-+++ monopd-0.9.3/src/server.cpp
-@@ -25,6 +25,8 @@
- #include <netinet/in.h>
- #include <syslog.h>
- #include <unistd.h>
-+#include <stdlib.h>
-+#include <string.h>
-
- #include <string>
-
diff --git a/games-server/monopd/monopd-0.9.3-r1.ebuild b/games-server/monopd/monopd-0.9.3-r1.ebuild
deleted file mode 100644
index 6a8624803c22..000000000000
--- a/games-server/monopd/monopd-0.9.3-r1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/monopd/monopd-0.9.3-r1.ebuild,v 1.5 2011/12/15 17:53:14 mr_bones_ Exp $
-
-EAPI=2
-inherit eutils games
-
-DESCRIPTION="server for atlantik games"
-HOMEPAGE="http://unixcode.org/monopd/"
-SRC_URI="http://unixcode.org/downloads/monopd/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc x86"
-IUSE=""
-
-RDEPEND=">=net-libs/libcapsinetwork-0.3.0"
-DEPEND="${RDEPEND}
- >=sys-libs/libmath++-0.0.3"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc43.patch #218833
- epatch "${FILESDIR}"/${P}-dosfix.patch
- # make the example config better (bug #206740)
- sed -i \
- -e '/gatorhost/s/=.*/=monopd-gator.kde.org/' \
- conf/monopd.conf-dist \
- || die "sed failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc doc/api/gameboard API AUTHORS ChangeLog NEWS README* TODO
- doinitd "${FILESDIR}"/monopd || die
- prepgamesdirs
-}