summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-01-03 22:29:18 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-01-03 22:29:18 +0000
commit6e7ad3a77e9c994a7f390d6827ccd0706aa014fd (patch)
tree0fc2f41cfb13243a51e6373224bdb3010a536cbb /games-server
parentLet it depend on poppler-bindings instead of poppler (diff)
downloadgentoo-2-6e7ad3a77e9c994a7f390d6827ccd0706aa014fd.tar.gz
gentoo-2-6e7ad3a77e9c994a7f390d6827ccd0706aa014fd.tar.bz2
gentoo-2-6e7ad3a77e9c994a7f390d6827ccd0706aa014fd.zip
Version bumped to 3369.2 for all you dedicated server monkeys out there in Unreal Tournament land.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'games-server')
-rw-r--r--games-server/ut2004-ded/ChangeLog11
-rw-r--r--games-server/ut2004-ded/files/digest-ut2004-ded-33692
-rw-r--r--games-server/ut2004-ded/ut2004-ded-3369.ebuild74
3 files changed, 85 insertions, 2 deletions
diff --git a/games-server/ut2004-ded/ChangeLog b/games-server/ut2004-ded/ChangeLog
index 7a5c0366e41e..640e181281d3 100644
--- a/games-server/ut2004-ded/ChangeLog
+++ b/games-server/ut2004-ded/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-server/ut2004-ded
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/ut2004-ded/ChangeLog,v 1.7 2005/09/21 20:52:37 wolf31o2 Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/ut2004-ded/ChangeLog,v 1.8 2006/01/03 22:29:18 wolf31o2 Exp $
+
+*ut2004-ded-3369 (03 Jan 2006)
+
+ 03 Jan 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ +ut2004-ded-3369.ebuild:
+ Version bumped to 3369.2 for all you dedicated server monkeys out there in
+ Unreal Tournament land.
21 Sep 2005; Chris Gianelloni <wolf31o2@gentoo.org>
ut2004-ded-3355.ebuild:
diff --git a/games-server/ut2004-ded/files/digest-ut2004-ded-3369 b/games-server/ut2004-ded/files/digest-ut2004-ded-3369
new file mode 100644
index 000000000000..dc3d32625cbb
--- /dev/null
+++ b/games-server/ut2004-ded/files/digest-ut2004-ded-3369
@@ -0,0 +1,2 @@
+MD5 d3f28c5245c4c02802d48e4f0ffd3e34 dedicatedserver3339-bonuspack.zip 914213907
+MD5 0fa447e05fe5a38e0e32adf171be405e ut2004-lnxpatch3369-2.tar.bz2 22465217
diff --git a/games-server/ut2004-ded/ut2004-ded-3369.ebuild b/games-server/ut2004-ded/ut2004-ded-3369.ebuild
new file mode 100644
index 000000000000..d0c167f95301
--- /dev/null
+++ b/games-server/ut2004-ded/ut2004-ded-3369.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/ut2004-ded/ut2004-ded-3369.ebuild,v 1.1 2006/01/03 22:29:18 wolf31o2 Exp $
+
+inherit games
+
+DESCRIPTION="Unreal Tournament 2004 Linux Dedicated Server"
+HOMEPAGE="http://www.unrealtournament.com/"
+
+MY_P="dedicatedserver3339-bonuspack.zip"
+MY_P2="ut2004-lnxpatch${PV}-2.tar.bz2"
+SRC_URI="mirror://3dgamers/unrealtourn2k4/${MY_P}
+ mirror://3dgamers/unrealtourn2k4/${MY_P2}"
+
+LICENSE="ut2003"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="nostrip nomirror"
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}
+
+GAMES_CHECK_LICENSE="yes"
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+src_install() {
+ einfo "This will take a while ... go get a pizza or something"
+
+ dodir ${dir}
+ cp -r ${S}/UT2004-Patch/* ${S}
+ rm -rf ${S}/UT2004-Patch
+ cp -r ${S}/* ${Ddir}
+
+ if use amd64 ; then
+ rm ${Ddir}/System/{ucc-bi{n,n-macosx}} \
+ || die "removing unused binaries"
+ mv ${Ddir}/System/ucc-bin-linux-amd64 ${Ddir}/System/ucc-bin \
+ || die "renaming ucc-bin-amd64 => ucc-bin"
+ else
+ rm ${Ddir}/System/{ucc-bin-{linux-amd64,macosx}} \
+ || die "removing unused binaries"
+ fi
+
+ fperms 0770 ${dir}/System/ucc-bin || die "fixing permissions on ucc-bin"
+ rm -f ${Ddir}/System/*.dll || die "removing windows dlls"
+ rm -f ${Ddir}/System/*.exe || die "removing windows exes"
+
+ prepgamesdirs
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/ut2004-ded.rc ut2004-ded
+}
+
+pkg_postinst() {
+ echo
+ einfo "The server can be started with the /etc/init.d/ut2004-ded init script."
+ echo
+ ewarn "You should take the time to edit the default server INI."
+ ewarn "Consult the INI Reference at http://unrealadmin.org/"
+ ewarn "for assistance in adjusting the following file:"
+ ewarn " /opt/ut2004-ded/System/Default.ini"
+ echo
+ ewarn "NOTE: To have your server authenticate properly to the"
+ ewarn " central server, you MUST visit the following site"
+ ewarn " and request a key. This is not required if you"
+ ewarn " want an unfindable private server. [DoUplink=False]"
+ echo
+ ewarn " http://unreal.epicgames.com/ut2004server/cdkey.php"
+ echo
+ games_pkg_postinst
+}