summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-11-12 00:01:24 +0000
committerMichael Weber <xmw@gentoo.org>2011-11-12 00:01:24 +0000
commit9b8add14287df39ec53b9143423bdeb91e07dd6b (patch)
treed3fd2127733025e14352e726ac1723ac227f4c7b /games-simulation
parentEnsure enigmail connects to gpg agent, bug #373733 (diff)
downloadgentoo-2-9b8add14287df39ec53b9143423bdeb91e07dd6b.tar.gz
gentoo-2-9b8add14287df39ec53b9143423bdeb91e07dd6b.tar.bz2
gentoo-2-9b8add14287df39ec53b9143423bdeb91e07dd6b.zip
Initial import
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/crrcsim/ChangeLog11
-rw-r--r--games-simulation/crrcsim/crrcsim-0.9.11.ebuild39
-rw-r--r--games-simulation/crrcsim/files/crrcsim-buildsystem.patch38
-rw-r--r--games-simulation/crrcsim/metadata.xml10
4 files changed, 98 insertions, 0 deletions
diff --git a/games-simulation/crrcsim/ChangeLog b/games-simulation/crrcsim/ChangeLog
new file mode 100644
index 000000000000..bf90971c5dd7
--- /dev/null
+++ b/games-simulation/crrcsim/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for games-simulation/crrcsim
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/crrcsim/ChangeLog,v 1.1 2011/11/12 00:01:24 xmw Exp $
+
+*crrcsim-0.9.11 (11 Nov 2011)
+
+ 11 Nov 2011; Michael Weber <xmw@gentoo.org> +crrcsim-0.9.11.ebuild,
+ +files/crrcsim-buildsystem.patch, +metadata.xml:
+ Initial import (thanks to Piotr Szymaniak and Krzysztof Synowiec for the
+ report, bug 227273)
+
diff --git a/games-simulation/crrcsim/crrcsim-0.9.11.ebuild b/games-simulation/crrcsim/crrcsim-0.9.11.ebuild
new file mode 100644
index 000000000000..46c548747bf3
--- /dev/null
+++ b/games-simulation/crrcsim/crrcsim-0.9.11.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/crrcsim/crrcsim-0.9.11.ebuild,v 1.1 2011/11/12 00:01:24 xmw Exp $
+
+EAPI=3
+
+inherit autotools eutils games
+
+DESCRIPTION="model-airplane flight simulation program"
+HOMEPAGE="http://crrcsim.berlios.de/"
+SRC_URI="http://download.berlios.de/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="portaudio"
+
+RDEPEND="media-libs/plib
+ media-libs/libsdl[X,audio,joystick,opengl,video]
+ portaudio? ( media-libs/portaudio )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-buildsystem.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with poraudio) $(use_with sdl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS HISTORY NEWS README || die
+
+ prepgamesdirs
+}
diff --git a/games-simulation/crrcsim/files/crrcsim-buildsystem.patch b/games-simulation/crrcsim/files/crrcsim-buildsystem.patch
new file mode 100644
index 000000000000..824add723a53
--- /dev/null
+++ b/games-simulation/crrcsim/files/crrcsim-buildsystem.patch
@@ -0,0 +1,38 @@
+--- crrcsim-0.9.11/configure.ac
++++ crrcsim-0.9.11/configure.ac
+@@ -79,8 +79,12 @@
+ dnl Default is: no portaudio present
+ portaudio=0
+
++AC_ARG_WITH([portaudio], AS_HELP_STRING([--without-portaudio], [Build without portaudio library (default: test)]))
++
++AS_IF([test "x$with_portaudio" != "xno"], [
+ dnl Check for the Portaudio header file
+ AC_CHECK_HEADER([portaudio.h])
++])
+
+ if (test "x$ac_cv_header_portaudio_h" = "xyes"); then
+ dnl Check for Portaudio 18
+@@ -116,9 +120,11 @@
+ fi
+ AC_SUBST(PA_LIBS)
+
++AC_ARG_WITH([sdl], AS_HELP_STRING([--without-sdl], [Build without sdl library (default: test)]))
+ dnl Search for SDL 1.2.5 or newer
+ SDL_VERSION=1.2.5
+ sdl_mousewheel="yes (SDL >= 1.2.5)"
++AS_IF([test "x$with_foo" != "xno"], [
+ AM_PATH_SDL($SDL_VERSION,:,AC_MSG_NOTICE([*** SDL version $SDL_VERSION or newer not found! See if at least 1.2.0 is present...]))
+ if test "x$no_sdl" = "xyes"
+ then
+@@ -129,6 +135,10 @@
+ AC_DEFINE([SDL_WITHOUT_MOUSEWHEEL], [1], [SDL < 1.2.5 did not feature mousewheel button macros])
+ sdl_mousewheel="no (SDL < 1.2.5)"
+ fi
++])
++AS_IF([test "x$with_foo" != "xyes"], [
++ AC_DEFINE([SDL_WITHOUT_MOUSEWHEEL], [1], [SDL disabled])
++])
+ AC_SUBST(SDL_LIBS)
+ AC_SUBST(SDL_CFLAGS)
+
diff --git a/games-simulation/crrcsim/metadata.xml b/games-simulation/crrcsim/metadata.xml
new file mode 100644
index 000000000000..a562c4775bb2
--- /dev/null
+++ b/games-simulation/crrcsim/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
+