summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-10-31 06:51:59 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-10-31 06:51:59 +0000
commitd2f1fe940c96c20738afec6180878a515aa76595 (patch)
treedce6dc9b929810f606679dc1683064e3471d7404 /games-simulation
parentRemove older version and add pkgconfig to DEPEND. (bug #150668) (diff)
downloadgentoo-2-d2f1fe940c96c20738afec6180878a515aa76595.tar.gz
gentoo-2-d2f1fe940c96c20738afec6180878a515aa76595.tar.bz2
gentoo-2-d2f1fe940c96c20738afec6180878a515aa76595.zip
kfreeflight respects USE. Bug #153508
(Portage version: 2.1.1-r1)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/kfreeflight/ChangeLog5
-rw-r--r--games-simulation/kfreeflight/kfreeflight-0.2.1_rc1.ebuild9
2 files changed, 12 insertions, 2 deletions
diff --git a/games-simulation/kfreeflight/ChangeLog b/games-simulation/kfreeflight/ChangeLog
index 0f1e3e20d553..18c5dbc5b959 100644
--- a/games-simulation/kfreeflight/ChangeLog
+++ b/games-simulation/kfreeflight/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-simulation/kfreeflight
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/kfreeflight/ChangeLog,v 1.1 2006/10/29 20:23:13 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/kfreeflight/ChangeLog,v 1.2 2006/10/31 06:51:59 tupone Exp $
+
+ 31 Oct 2006; <tupone@gentoo.org> kfreeflight-0.2.1_rc1.ebuild:
+ kfreeflight respects USE. Bug #153508 by Dan
*kfreeflight-0.2.1_rc1 (29 Oct 2006)
diff --git a/games-simulation/kfreeflight/kfreeflight-0.2.1_rc1.ebuild b/games-simulation/kfreeflight/kfreeflight-0.2.1_rc1.ebuild
index 345c4aa05fbc..bc1e0894524d 100644
--- a/games-simulation/kfreeflight/kfreeflight-0.2.1_rc1.ebuild
+++ b/games-simulation/kfreeflight/kfreeflight-0.2.1_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/kfreeflight/kfreeflight-0.2.1_rc1.ebuild,v 1.1 2006/10/29 20:23:13 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/kfreeflight/kfreeflight-0.2.1_rc1.ebuild,v 1.2 2006/10/31 06:51:59 tupone Exp $
inherit eutils kde games
@@ -21,6 +21,13 @@ S=${WORKDIR}/${PN}-${PV%_*}
need-kde 3.5.2
+src_compile() {
+ local myconf
+ kde_src_compile myconf
+ egamesconf $myconf || die "egamesconf failed"
+ emake || die "emake failed"
+}
+
src_install() {
make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS NEWS TODO