summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2014-08-13 00:23:06 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2014-08-13 00:23:06 +0000
commitefa1633032be46a45f6e7fa19d9ac07979706c28 (patch)
tree5d46ceb91d9d59638c0ad67a9ecae4b727ec1cdb /games-simulation
parentbump; add pypy support, fix fix to qa build issue, thanks to Arfrever for the... (diff)
downloadgentoo-2-efa1633032be46a45f6e7fa19d9ac07979706c28.tar.gz
gentoo-2-efa1633032be46a45f6e7fa19d9ac07979706c28.tar.bz2
gentoo-2-efa1633032be46a45f6e7fa19d9ac07979706c28.zip
Version bump, remove old, exported from git tag 3.0.0-final. Fixes bug 436600.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key B1E955DB)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/fgrun/ChangeLog11
-rw-r--r--games-simulation/fgrun/fgrun-1.6.0.ebuild39
-rw-r--r--games-simulation/fgrun/fgrun-3.0.0.ebuild53
-rw-r--r--games-simulation/fgrun/files/fgrun-1.5.2-fltk.patch13
4 files changed, 61 insertions, 55 deletions
diff --git a/games-simulation/fgrun/ChangeLog b/games-simulation/fgrun/ChangeLog
index 55499825ffca..71ebcf0fd87a 100644
--- a/games-simulation/fgrun/ChangeLog
+++ b/games-simulation/fgrun/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-simulation/fgrun
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/fgrun/ChangeLog,v 1.12 2012/01/21 15:57:35 reavertm Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/fgrun/ChangeLog,v 1.13 2014/08/13 00:23:06 reavertm Exp $
+
+*fgrun-3.0.0 (13 Aug 2014)
+
+ 13 Aug 2014; Maciej Mrozowski <reavertm@gentoo.org> +fgrun-3.0.0.ebuild,
+ -fgrun-1.6.0.ebuild, -files/fgrun-1.5.2-fltk.patch:
+ Version bump, remove old, exported from git tag 3.0.0-final. Fixes bug 436600.
*fgrun-1.6.0 (21 Jan 2012)
@@ -53,4 +59,3 @@
26 Apr 2007; Tupone Alfredo <tupone@gentoo.org>
+files/fgrun-0.4.8-fltk.patch, +metadata.xml, +fgrun-0.4.8.ebuild:
New package. Bug #130115 by Lawrence Shafer
-
diff --git a/games-simulation/fgrun/fgrun-1.6.0.ebuild b/games-simulation/fgrun/fgrun-1.6.0.ebuild
deleted file mode 100644
index 48ac430cd940..000000000000
--- a/games-simulation/fgrun/fgrun-1.6.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/fgrun/fgrun-1.6.0.ebuild,v 1.1 2012/01/21 15:57:35 reavertm Exp $
-
-EAPI=3
-inherit autotools eutils multilib games
-
-DESCRIPTION="A graphical frontend for the FlightGear Flight Simulator"
-HOMEPAGE="http://sourceforge.net/projects/fgrun"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-COMMON_DEPEND="
- >=dev-games/openscenegraph-3.0.1
- sys-libs/zlib
- x11-libs/fltk:1[opengl,threads]
-"
-DEPEND="${COMMON_DEPEND}
- >=dev-games/simgear-2
- >=dev-libs/boost-1.34
-"
-RDEPEND="${COMMON_DEPEND}
- >=games-simulation/flightgear-2
-"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-1.5.2-fltk.patch"
- AT_M4DIR=. eautoreconf
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS NEWS
- prepgamesdirs
-}
diff --git a/games-simulation/fgrun/fgrun-3.0.0.ebuild b/games-simulation/fgrun/fgrun-3.0.0.ebuild
new file mode 100644
index 000000000000..6e80f7b7c669
--- /dev/null
+++ b/games-simulation/fgrun/fgrun-3.0.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/fgrun/fgrun-3.0.0.ebuild,v 1.1 2014/08/13 00:23:06 reavertm Exp $
+
+EAPI=5
+
+inherit games cmake-utils
+
+# Exported from git tag 3.0.0-final
+MY_PN=fg-fgrun
+MY_PV=e13e42811239008fded7685d8f2311bb571f6a58
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="A graphical frontend for the FlightGear Flight Simulator"
+HOMEPAGE="http://sourceforge.net/projects/fgrun"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug nls"
+
+COMMON_DEPEND="
+ >=dev-games/openscenegraph-3.0.1
+ sys-libs/zlib
+ x11-libs/fltk:1[opengl,threads]
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-games/simgear-${PV}
+ >=dev-libs/boost-1.34
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=games-simulation/flightgear-${PV}
+"
+
+S=${WORKDIR}/${MY_PN}
+DOCS=(AUTHORS NEWS)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}
+ $(cmake-utils_use_enable nls)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ prepgamesdirs
+}
diff --git a/games-simulation/fgrun/files/fgrun-1.5.2-fltk.patch b/games-simulation/fgrun/files/fgrun-1.5.2-fltk.patch
deleted file mode 100644
index b473bdff9b98..000000000000
--- a/games-simulation/fgrun/files/fgrun-1.5.2-fltk.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- configure.ac.old 2007-04-25 22:26:19.000000000 +0200
-+++ configure.ac 2007-04-25 22:27:41.000000000 +0200
-***************
-*** 138,143 ****
---- 138,146 ----
- FLUID="$with_fltk/bin/fluid"
- CPPFLAGS="-I$with_fltk/include $CPPFLAGS"
- EXTRA_DIRS="${EXTRA_DIRS} $with_fltk"
-+ else
-+ CPPFLAGS="$(fltk-config --cxxflags) $CPPFLAGS"
-+ LIBS="$(fltk-config --use-gl --ldflags) $LIBS"
- fi
- AC_SUBST(FLUID)