summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-04-08 04:10:26 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-04-08 04:10:26 +0000
commitf3594d9e54cb14e1cba02952e0dfbbe24dfb6948 (patch)
tree58bf90e2607b5f97928cac7c93ce04fc19c12438 /games-sports
parentStable for HPPA (bug #216099). (diff)
downloadgentoo-2-f3594d9e54cb14e1cba02952e0dfbbe24dfb6948.tar.gz
gentoo-2-f3594d9e54cb14e1cba02952e0dfbbe24dfb6948.tar.bz2
gentoo-2-f3594d9e54cb14e1cba02952e0dfbbe24dfb6948.zip
add patch for compiling with gcc-4.3 from Bert Karwatzki via bug #216622
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/torcs/ChangeLog6
-rw-r--r--games-sports/torcs/files/torcs-1.3.0-gcc43.patch74
-rw-r--r--games-sports/torcs/torcs-1.3.0.ebuild8
3 files changed, 86 insertions, 2 deletions
diff --git a/games-sports/torcs/ChangeLog b/games-sports/torcs/ChangeLog
index 9c46f2d4015a..9b6df2003359 100644
--- a/games-sports/torcs/ChangeLog
+++ b/games-sports/torcs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-sports/torcs
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/torcs/ChangeLog,v 1.23 2008/01/25 14:12:49 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/torcs/ChangeLog,v 1.24 2008/04/08 04:10:26 mr_bones_ Exp $
+
+ 08 Apr 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/torcs-1.3.0-gcc43.patch, torcs-1.3.0.ebuild:
+ add patch for compiling with gcc-4.3 from Bert Karwatzki via bug #216622
25 Jan 2008; Tristan Heaven <nyhm@gentoo.org> torcs-1.3.0.ebuild:
Add xf86vidmodeproto dep, bug #206416
diff --git a/games-sports/torcs/files/torcs-1.3.0-gcc43.patch b/games-sports/torcs/files/torcs-1.3.0-gcc43.patch
new file mode 100644
index 000000000000..fcc5604e79cc
--- /dev/null
+++ b/games-sports/torcs/files/torcs-1.3.0-gcc43.patch
@@ -0,0 +1,74 @@
+diff -aur src.old/drivers/olethros/Trajectory.cpp src/drivers/olethros/Trajectory.cpp
+--- src.old/drivers/olethros/Trajectory.cpp 2008-04-06 22:21:31.000000000 +0200
++++ src/drivers/olethros/Trajectory.cpp 2008-04-06 22:28:52.000000000 +0200
+@@ -10,8 +10,10 @@
+ ***************************************************************************/
+ #include <cstdio>
+ #include <cstdlib>
++#include <cstring>
+ #include <cmath>
+ #include <cassert>
++#include <ctime>
+ #include <list>
+ #include <vector>
+ #include "Trajectory.h"
+diff -aur src.old/modules/simu/simuv2/SOLID-2.0/src/BBoxTree.cpp src/modules/simu/simuv2/SOLID-2.0/src/BBoxTree.cpp
+--- src.old/modules/simu/simuv2/SOLID-2.0/src/BBoxTree.cpp 2008-04-06 22:21:31.000000000 +0200
++++ src/modules/simu/simuv2/SOLID-2.0/src/BBoxTree.cpp 2008-04-06 22:22:57.000000000 +0200
+@@ -32,7 +32,7 @@
+ #include "Transform.h"
+
+ #include <algorithm>
+-#include <new.h>
++#include <new>
+
+ class BBoxCompAxis {
+ public:
+diff -aur src.old/modules/simu/simuv2/SOLID-2.0/src/Complex.cpp src/modules/simu/simuv2/SOLID-2.0/src/Complex.cpp
+--- src.old/modules/simu/simuv2/SOLID-2.0/src/Complex.cpp 2008-04-06 22:21:31.000000000 +0200
++++ src/modules/simu/simuv2/SOLID-2.0/src/Complex.cpp 2008-04-06 22:23:11.000000000 +0200
+@@ -32,7 +32,7 @@
+ #include "Transform.h"
+ #include "BBoxTree.h"
+
+-#include <new.h>
++#include <new>
+
+ BBoxInternal *free_node;
+
+diff -aur src.old/modules/simu/simuv2/SOLID-2.0/src/Endpoint.cpp src/modules/simu/simuv2/SOLID-2.0/src/Endpoint.cpp
+--- src.old/modules/simu/simuv2/SOLID-2.0/src/Endpoint.cpp 2008-04-06 22:21:31.000000000 +0200
++++ src/modules/simu/simuv2/SOLID-2.0/src/Endpoint.cpp 2008-04-06 22:22:29.000000000 +0200
+@@ -32,7 +32,7 @@
+ #include "Object.h"
+ #include "Encounter.h"
+
+-#include <new.h>
++#include <new>
+
+ void addPair(ObjectPtr object1, ObjectPtr object2);
+ void removePair(ObjectPtr object1, ObjectPtr object2);
+diff -aur src.old/modules/simu/simuv2/SOLID-2.0/src/Object.cpp src/modules/simu/simuv2/SOLID-2.0/src/Object.cpp
+--- src.old/modules/simu/simuv2/SOLID-2.0/src/Object.cpp 2008-04-06 22:21:31.000000000 +0200
++++ src/modules/simu/simuv2/SOLID-2.0/src/Object.cpp 2008-04-06 22:22:40.000000000 +0200
+@@ -33,7 +33,7 @@
+ #include "Convex.h"
+ #include "Complex.h"
+
+-#include <new.h>
++#include <new>
+
+ Object::Object(DtObjectRef obj, ShapePtr shape) :
+ ref(obj),
+diff -aur src.old/modules/simu/simuv2/SOLID-2.0/src/Polyhedron.cpp src/modules/simu/simuv2/SOLID-2.0/src/Polyhedron.cpp
+--- src.old/modules/simu/simuv2/SOLID-2.0/src/Polyhedron.cpp 2008-04-06 22:21:31.000000000 +0200
++++ src/modules/simu/simuv2/SOLID-2.0/src/Polyhedron.cpp 2008-04-06 22:22:12.000000000 +0200
+@@ -37,7 +37,7 @@
+ }
+
+ #include <vector>
+-#include <new.h>
++#include <new>
+
+ typedef vector<unsigned int> IndexBuf;
+
diff --git a/games-sports/torcs/torcs-1.3.0.ebuild b/games-sports/torcs/torcs-1.3.0.ebuild
index 17bf50a14cd0..36b569dfd8cd 100644
--- a/games-sports/torcs/torcs-1.3.0.ebuild
+++ b/games-sports/torcs/torcs-1.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/torcs/torcs-1.3.0.ebuild,v 1.5 2008/01/25 14:12:49 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/torcs/torcs-1.3.0.ebuild,v 1.6 2008/04/08 04:10:26 mr_bones_ Exp $
inherit eutils multilib games
@@ -25,6 +25,12 @@ RDEPEND=">=media-libs/plib-1.8.4
DEPEND="${RDEPEND}
x11-proto/xf86vidmodeproto"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+}
+
src_compile() {
egamesconf \
--disable-dependency-tracking \