summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-11-08 00:00:37 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-11-08 00:00:37 +0000
commit6b25de0630788320edb422111bc2a86c7d08cb9e (patch)
tree7a1a53a02498ecfb9a872bc1ec3ee63e9ea7ddc1 /games-strategy/asc
parentsecurity fix for libxpdf, bug #196735 (diff)
downloadgentoo-2-6b25de0630788320edb422111bc2a86c7d08cb9e.tar.gz
gentoo-2-6b25de0630788320edb422111bc2a86c7d08cb9e.tar.bz2
gentoo-2-6b25de0630788320edb422111bc2a86c7d08cb9e.zip
version bump
(Portage version: 2.1.3.16)
Diffstat (limited to 'games-strategy/asc')
-rw-r--r--games-strategy/asc/ChangeLog9
-rw-r--r--games-strategy/asc/asc-2.0.1.0.ebuild65
-rw-r--r--games-strategy/asc/files/digest-asc-2.0.1.012
3 files changed, 84 insertions, 2 deletions
diff --git a/games-strategy/asc/ChangeLog b/games-strategy/asc/ChangeLog
index 896a4ed87ae6..3d0ede2dbdae 100644
--- a/games-strategy/asc/ChangeLog
+++ b/games-strategy/asc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/asc
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/asc/ChangeLog,v 1.21 2006/11/06 08:36:24 mr_bones_ Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/asc/ChangeLog,v 1.22 2007/11/08 00:00:37 mr_bones_ Exp $
+
+*asc-2.0.1.0 (07 Nov 2007)
+
+ 07 Nov 2007; Michael Sterrett <mr_bones_@gentoo.org> +asc-2.0.1.0.ebuild:
+ version bump
*asc-1.16.4.0 (06 Nov 2006)
diff --git a/games-strategy/asc/asc-2.0.1.0.ebuild b/games-strategy/asc/asc-2.0.1.0.ebuild
new file mode 100644
index 000000000000..3c53e1c1e23f
--- /dev/null
+++ b/games-strategy/asc/asc-2.0.1.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/asc/asc-2.0.1.0.ebuild,v 1.1 2007/11/08 00:00:37 mr_bones_ Exp $
+
+inherit toolchain-funcs flag-o-matic games
+
+DESCRIPTION="turn based strategy game designed in the tradition of the Battle Isle series"
+HOMEPAGE="http://www.asc-hq.org/"
+SRC_URI="mirror://sourceforge/asc-hq/${P}.tar.bz2
+ http://www.asc-hq.org/music/frontiers.ogg
+ http://www.asc-hq.org/music/time_to_strike.ogg
+ http://www.asc-hq.org/music/machine_wars.ogg"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-arch/bzip2
+ media-libs/jpeg
+ >=media-libs/libsdl-1.2.2
+ media-libs/sdl-image
+ >=media-libs/sdl-mixer-1.2
+ dev-libs/boost
+ media-libs/smpeg
+ =dev-libs/libsigc++-1.2*"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ local f
+
+ for f in ${A}
+ do
+ case ${f} in
+ *ogg)
+ cp "${DISTDIR}/${f}" "${S}/data/music" || die "cp music failed"
+ ;;
+ *) unpack ${f}
+ esac
+ done
+}
+
+src_compile() {
+ # Added --disable-paraguitest for bugs 26402 and 4488
+ # Added --disable-paragui for bug 61154 since it's not really used much
+ # and the case is well documented at http://www.asc-hq.org/
+ if [[ $(gcc-major-version) -eq 4 ]] ; then
+ replace-flags -O3 -O2
+ fi
+ egamesconf \
+ --disable-dependency-tracking \
+ --disable-paraguitest \
+ --disable-paragui \
+ --datadir="${GAMES_DATADIR_BASE}" \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README TODO
+ dohtml -r doc/*
+ prepgamesdirs
+}
diff --git a/games-strategy/asc/files/digest-asc-2.0.1.0 b/games-strategy/asc/files/digest-asc-2.0.1.0
new file mode 100644
index 000000000000..deb6bbab7ca2
--- /dev/null
+++ b/games-strategy/asc/files/digest-asc-2.0.1.0
@@ -0,0 +1,12 @@
+MD5 2758e2bbbd5892ccba8d9b4ac5a6d6af asc-2.0.1.0.tar.bz2 22283815
+RMD160 b34c4dae2e5e0f33a32683c08aef91c587f7bc26 asc-2.0.1.0.tar.bz2 22283815
+SHA256 6083f3dea1de6b18b68ba4949ae32842bcd9be6832e2abe6e1df4b16286380bd asc-2.0.1.0.tar.bz2 22283815
+MD5 c27415246734d59e27e6a786ee4820d2 frontiers.ogg 4691844
+RMD160 d9180257b34871301d55ec4db37fab3d144ceecf frontiers.ogg 4691844
+SHA256 eabc9b07d1db07626fa817a30dad23b11aada059e32c08914d2d0cf1d58c7fff frontiers.ogg 4691844
+MD5 b4421ddd67a9e44d90a49a1d8bdf44c3 machine_wars.ogg 3138308
+RMD160 41da08dce0671329bb7bb16f52249f1baeaa1b49 machine_wars.ogg 3138308
+SHA256 bd7f330c06090d98e5ba0dac5a691af1804ba383b783b7b2f960bc2e53400a77 machine_wars.ogg 3138308
+MD5 0f4de5275ab649f4426d110840e3e1ea time_to_strike.ogg 3830679
+RMD160 03f67601e729ba8cbdeb01b6e0b4317bbe10e435 time_to_strike.ogg 3830679
+SHA256 0334a027b8a45a5df88e1e3e7db9cace2def02396fbcc794d157289e41c9ad05 time_to_strike.ogg 3830679