summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-12-31 14:10:21 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-12-31 14:10:21 +0000
commitb715084bb33d98b3de5f960937634acabee61395 (patch)
treee3e674d7235b5016d3efb2c2d6e040c806a1d572 /games-strategy/defcon-demo
parentremove folks[eds/telepathy] and add -zeitgeist (diff)
downloadgentoo-2-b715084bb33d98b3de5f960937634acabee61395.tar.gz
gentoo-2-b715084bb33d98b3de5f960937634acabee61395.tar.bz2
gentoo-2-b715084bb33d98b3de5f960937634acabee61395.zip
version bump wrt #448434
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-strategy/defcon-demo')
-rw-r--r--games-strategy/defcon-demo/ChangeLog7
-rw-r--r--games-strategy/defcon-demo/defcon-demo-1.60.ebuild101
2 files changed, 107 insertions, 1 deletions
diff --git a/games-strategy/defcon-demo/ChangeLog b/games-strategy/defcon-demo/ChangeLog
index 29c922c1c055..56145a4440ba 100644
--- a/games-strategy/defcon-demo/ChangeLog
+++ b/games-strategy/defcon-demo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/defcon-demo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/defcon-demo/ChangeLog,v 1.6 2012/12/20 07:25:37 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/defcon-demo/ChangeLog,v 1.7 2012/12/31 14:10:21 hasufell Exp $
+
+*defcon-demo-1.60 (31 Dec 2012)
+
+ 31 Dec 2012; Julian Ospald <hasufell@gentoo.org> +defcon-demo-1.60.ebuild:
+ version bump wrt #448434
20 Dec 2012; Tupone Alfredo <tupone@gentoo.org> defcon-demo-1.42.ebuild:
Migrate to EAPI=5.
diff --git a/games-strategy/defcon-demo/defcon-demo-1.60.ebuild b/games-strategy/defcon-demo/defcon-demo-1.60.ebuild
new file mode 100644
index 000000000000..924e8dfc6840
--- /dev/null
+++ b/games-strategy/defcon-demo/defcon-demo-1.60.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/defcon-demo/defcon-demo-1.60.ebuild,v 1.1 2012/12/31 14:10:21 hasufell Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs gnome2-utils games
+
+MY_PN=defcon
+MY_PV=${PV:0:3}
+MY_PVR=1
+MY_P=defcon_${MY_PV}-${MY_PVR}
+
+DESCRIPTION="Global thermonuclear war simulation with multiplayer support"
+HOMEPAGE="http://www.introversion.co.uk/defcon/"
+SRC_URI="x86? ( http://www.introversion.co.uk/defcon/downloads/${MY_P}_i386.deb )
+ amd64? ( http://www.introversion.co.uk/defcon/downloads/${MY_P}_amd64.deb )"
+
+LICENSE="Introversion"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="+system-libs"
+RESTRICT="mirror strip"
+
+# glibc discussion:
+# http://forums.introversion.co.uk/defcon/viewtopic.php?t=4016
+RDEPEND="
+ media-libs/libogg
+ media-libs/libvorbis
+ >=sys-libs/glibc-2.3
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXext
+ x11-libs/libXdmcp
+ system-libs? ( media-libs/libsdl )"
+DEPEND=""
+
+QA_PREBUILT="${GAMES_PREFIX_OPT:1}/${PN}/lib/${MY_PN}.bin.x86"
+
+S=${WORKDIR}/usr/local/games/${MY_PN}
+
+src_unpack() {
+ default
+ unpack ./data.tar.gz
+
+ cd "${S}" || die
+ # maintain compatibility with old installation/script
+ [[ -e lib64 ]] && { mv lib64 lib || die ;}
+ [[ -e ${MY_PN}.bin.x86_64 ]] && { mv ${MY_PN}.bin.x86_64 ${MY_PN}.bin.x86 || die ;}
+}
+
+src_prepare() {
+ # FindPath scripts are ugly and unnecessary
+ if use system-libs ; then
+ rm -f lib/lib*
+ fi
+ sed \
+ -e "s:GAMEDIR:${GAMES_PREFIX_OPT}/${PN}:g" \
+ "${FILESDIR}"/${MY_PN} > "${T}"/${MY_PN} \
+ || die "sed failed"
+ echo "int chdir(const char *d) { return 0; }" > chdir.c \
+ || die "echo failed"
+}
+
+src_compile() {
+ echo "$(tc-getCC) ${CFLAGS} ${LDFLAGS} -fPIC -shared -o lib/chdir.so chdir.c"
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -fPIC -shared -o lib/chdir.so chdir.c || die
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+
+ insinto "${dir}/lib"
+ doins *.dat
+
+ exeinto "${dir}"/lib
+ doexe lib/*.so
+ doexe ${MY_PN}.bin.x86
+
+ doicon -s 128 ${MY_PN}.png
+
+ # Can be upgraded to full version, so is not installed as "demo"
+ dogamesbin "${T}"/${MY_PN}
+ make_desktop_entry ${MY_PN} "Defcon"
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+ elog "Screenshots will appear in ~/.${MY_PN}/lib"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}