summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-03-13 14:01:19 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-03-13 14:01:19 +0000
commitef579decde35595c2ad4dd9e8d506b526edc25a2 (patch)
treeedd931867eb7297d6798eb182736124c057cde41 /games-strategy/freeciv
parentppc stable wrt #358025 (diff)
downloadgentoo-2-ef579decde35595c2ad4dd9e8d506b526edc25a2.tar.gz
gentoo-2-ef579decde35595c2ad4dd9e8d506b526edc25a2.tar.bz2
gentoo-2-ef579decde35595c2ad4dd9e8d506b526edc25a2.zip
version bump
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'games-strategy/freeciv')
-rw-r--r--games-strategy/freeciv/ChangeLog8
-rw-r--r--games-strategy/freeciv/files/freeciv-2.2.5-clean-man.patch22
-rw-r--r--games-strategy/freeciv/freeciv-2.2.5.ebuild124
3 files changed, 153 insertions, 1 deletions
diff --git a/games-strategy/freeciv/ChangeLog b/games-strategy/freeciv/ChangeLog
index f459e342f4a7..4c8a5bff9eb3 100644
--- a/games-strategy/freeciv/ChangeLog
+++ b/games-strategy/freeciv/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/freeciv
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeciv/ChangeLog,v 1.125 2011/02/09 13:20:37 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeciv/ChangeLog,v 1.126 2011/03/13 14:01:18 mr_bones_ Exp $
+
+*freeciv-2.2.5 (13 Mar 2011)
+
+ 13 Mar 2011; Michael Sterrett <mr_bones_@gentoo.org>
+ +freeciv-2.2.5.ebuild, +files/freeciv-2.2.5-clean-man.patch:
+ version bump
09 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> freeciv-2.2.4.ebuild:
x86 stable wrt bug #353817
diff --git a/games-strategy/freeciv/files/freeciv-2.2.5-clean-man.patch b/games-strategy/freeciv/files/freeciv-2.2.5-clean-man.patch
new file mode 100644
index 000000000000..b5c4d2337360
--- /dev/null
+++ b/games-strategy/freeciv/files/freeciv-2.2.5-clean-man.patch
@@ -0,0 +1,22 @@
+diff -ru freeciv-2.2.0.orig/doc/man/Makefile.in freeciv-2.2.0/doc/man/Makefile.in
+--- freeciv-2.2.0.orig/doc/man/Makefile.in 2010-02-21 13:52:28.000000000 -0500
++++ freeciv-2.2.0/doc/man/Makefile.in 2010-02-26 04:00:07.713504939 -0500
+@@ -347,8 +347,7 @@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ MAN_PAGES = \
+- freeciv-server.6 \
+- freeciv-client.6
++ freeciv-server.6
+
+ MAN_LINKS = \
+ freeciv-gtk2.6 \
+@@ -357,7 +356,7 @@
+ freeciv-win32.6 \
+ freeciv-ftwl.6
+
+-man_MANS = $(MAN_PAGES) $(MAN_LINKS)
++man_MANS = $(MAN_PAGES)
+ EXTRA_DIST = $(man_MANS)
+ all: all-am
+
diff --git a/games-strategy/freeciv/freeciv-2.2.5.ebuild b/games-strategy/freeciv/freeciv-2.2.5.ebuild
new file mode 100644
index 000000000000..c27da8e61149
--- /dev/null
+++ b/games-strategy/freeciv/freeciv-2.2.5.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeciv/freeciv-2.2.5.ebuild,v 1.1 2011/03/13 14:01:18 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils gnome2-utils games-ggz games
+
+DESCRIPTION="multiplayer strategy game (Civilization Clone)"
+HOMEPAGE="http://www.freeciv.org/"
+SRC_URI="mirror://sourceforge/freeciv/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="auth dedicated ggz gtk ipv6 nls readline sdl +sound"
+
+RDEPEND="readline? ( sys-libs/readline )
+ sys-libs/zlib
+ app-arch/bzip2
+ auth? ( virtual/mysql )
+ !dedicated? (
+ nls? ( virtual/libintl )
+ gtk? ( x11-libs/gtk+:2 )
+ sdl? (
+ media-libs/libsdl[video]
+ media-libs/sdl-image[png]
+ media-libs/freetype
+ )
+ !gtk? ( !sdl? ( x11-libs/gtk+:2 ) )
+ sound? (
+ media-libs/libsdl[audio]
+ media-libs/sdl-mixer
+ )
+ ggz? ( games-board/ggz-gtk-client )
+ media-libs/libpng
+ )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ !dedicated? (
+ nls? ( sys-devel/gettext )
+ x11-proto/xextproto
+ )"
+
+src_prepare() {
+ # install the .desktop in /usr/share/applications
+ # install the icons in /usr/share/pixmaps
+ sed -i \
+ -e 's:^\(desktopfiledir = \).*:\1/usr/share/applications:' \
+ -e 's:^\(icon[0-9]*dir = \)$(prefix)\(.*\):\1/usr\2:' \
+ -e 's:^\(icon[0-9]*dir = \)$(datadir)\(.*\):\1/usr/share\2:' \
+ client/Makefile.in \
+ server/Makefile.in \
+ data/Makefile.in \
+ data/icons/Makefile.in \
+ || die "sed failed"
+
+ # remove civclient manpage if dedicated server
+ if use dedicated ; then
+ epatch "${FILESDIR}"/${P}-clean-man.patch
+ fi
+}
+
+src_configure() {
+ local myclient myopts
+
+ if use dedicated ; then
+ myclient="no"
+ else
+ use sdl && myclient="${myclient} sdl"
+ use gtk && myclient="${myclient} gtk"
+ [[ -z ${myclient} ]] && myclient="gtk" # default to gtk if none specified
+ myopts=$(use_with ggz ggz-client)
+ fi
+
+ egamesconf \
+ --disable-dependency-tracking \
+ --localedir=/usr/share/locale \
+ --with-ggzconfig=/usr/bin \
+ --enable-noregistry="${GGZ_MODDIR}" \
+ $(use_enable auth) \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_with readline) \
+ $(use_enable sound sdl-mixer) \
+ ${myopts} \
+ --enable-client="${myclient}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if ! use dedicated ; then
+ # Create and install the html manual. It can't be done for dedicated
+ # servers, because the 'civmanual' tool is then not built. Also
+ # delete civmanual from the GAMES_BINDIR, because it's then useless.
+ # Note: to have it localized, it should be ran from _postinst, or
+ # something like that, but then it's a PITA to avoid orphan files...
+ ./manual/civmanual || die "civmanual failed"
+ dohtml manual*.html || die "dohtml failed"
+ rm -f "${D}/${GAMES_BINDIR}"/civmanual
+ use sdl && make_desktop_entry freeciv-sdl "Freeciv (SDL)" freeciv-client
+ fi
+
+ dodoc ChangeLog NEWS doc/{BUGS,CodingStyle,HACKING,HOWTOPLAY,README*,TODO}
+ rm -rf "${D}$(games_get_libdir)"
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ games-ggz_update_modules
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ games-ggz_update_modules
+ gnome2_icon_cache_update
+}