summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-09-16 02:29:25 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-09-16 02:29:25 +0000
commit69258c4b2accf75970a4bc0b24972da40909ca2e (patch)
tree66c73bf1338676bdae0cca93cf4384fd68fcd153 /games-strategy/freecnc
parentMark 4.0.1-r2 stable on alpha (diff)
downloadgentoo-2-69258c4b2accf75970a4bc0b24972da40909ca2e.tar.gz
gentoo-2-69258c4b2accf75970a4bc0b24972da40909ca2e.tar.bz2
gentoo-2-69258c4b2accf75970a4bc0b24972da40909ca2e.zip
needs app-arch/unzip; tidy
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-strategy/freecnc')
-rw-r--r--games-strategy/freecnc/ChangeLog8
-rw-r--r--games-strategy/freecnc/freecnc-0.2.0.ebuild35
-rw-r--r--games-strategy/freecnc/freecnc-0.2.1.31072003.ebuild41
3 files changed, 47 insertions, 37 deletions
diff --git a/games-strategy/freecnc/ChangeLog b/games-strategy/freecnc/ChangeLog
index c2409c1fd87f..a48e5c822f00 100644
--- a/games-strategy/freecnc/ChangeLog
+++ b/games-strategy/freecnc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/freecnc
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecnc/ChangeLog,v 1.5 2004/11/08 01:41:04 josejx Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecnc/ChangeLog,v 1.6 2005/09/16 02:25:06 mr_bones_ Exp $
+
+ 16 Sep 2005; Michael Sterrett <mr_bones_@gentoo.org> freecnc-0.2.0.ebuild,
+ freecnc-0.2.1.31072003.ebuild:
+ needs app-arch/unzip; tidy
08 Nov 2004; Joseph Jezak <josejx@gentoo.org>
freecnc-0.2.1.31072003.ebuild:
diff --git a/games-strategy/freecnc/freecnc-0.2.0.ebuild b/games-strategy/freecnc/freecnc-0.2.0.ebuild
index 3d074aa20133..7aa40e6b2531 100644
--- a/games-strategy/freecnc/freecnc-0.2.0.ebuild
+++ b/games-strategy/freecnc/freecnc-0.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecnc/freecnc-0.2.0.ebuild,v 1.5 2005/05/02 23:22:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecnc/freecnc-0.2.0.ebuild,v 1.6 2005/09/16 02:25:06 mr_bones_ Exp $
inherit games flag-o-matic eutils
@@ -15,9 +15,11 @@ SLOT="0"
KEYWORDS="x86"
IUSE="zlib nocd"
-DEPEND="media-libs/libsdl
+RDEPEND="media-libs/libsdl
media-libs/sdl-net
zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
S=${WORKDIR}/freecnc++
@@ -30,37 +32,38 @@ src_unpack() {
mv ${f} `echo ${f} | awk '{print tolower($1)}'` || die "moving $f"
done
fi
- cd ${S}
- epatch ${FILESDIR}/${PV}-makefile-cflags.patch
- epatch ${FILESDIR}/${PV}-remove-root.patch
- epatch ${FILESDIR}/${PV}-gentoo-paths.patch
- epatch "${FILESDIR}"/${P}-endian.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-makefile-cflags.patch \
+ "${FILESDIR}"/${PV}-remove-root.patch \
+ "${FILESDIR}"/${PV}-gentoo-paths.patch \
+ "${FILESDIR}"/${P}-endian.patch
rm -f src/include/endian.h
sed -i \
-e "s:GENTOO_LOGDIR:${GAMES_LOGDIR}:" \
-e "s:GENTOO_CONFDIR:${GAMES_SYSCONFDIR}/${PN}/:" \
-e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}/:" \
- src/freecnc.cpp src/vfs/vfs.cpp
+ src/freecnc.cpp src/vfs/vfs.cpp \
+ || die "sed failed"
}
src_compile() {
- make EXTRACFLAGS="${CFLAGS}" || die
+ emake EXTRACFLAGS="${CFLAGS}" || die "emake failed"
}
src_install() {
- exeinto ${GAMES_LIBDIR}/${PN}
+ exeinto "${GAMES_LIBDIR}"/${PN}
doexe freecnc *.vfs
- dogamesbin ${FILESDIR}/freecnc
+ dogamesbin "${FILESDIR}"/freecnc || die "dogamesbin failed"
dosed "s:GENTOO_DIR:${GAMES_LIBDIR}/${PN}:" ${GAMES_BINDIR}/freecnc
- insinto ${GAMES_DATADIR}/${PN}/conf
+ insinto "${GAMES_DATADIR}"/${PN}/conf
doins conf/*
- insinto ${GAMES_SYSCONFDIR}/${PN}
+ insinto "${GAMES_SYSCONFDIR}"/${PN}
doins conf/*
dodoc AUTHORS ChangeLog NEWS README THANKS TODO
if use nocd ; then
- cd ${WORKDIR}/data
- insinto ${GAMES_DATADIR}/${PN}
- doins *.mix *.aud
+ cd "${WORKDIR}"/data
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins *.mix *.aud || die "doins failed"
dodoc *.txt
fi
prepgamesdirs
diff --git a/games-strategy/freecnc/freecnc-0.2.1.31072003.ebuild b/games-strategy/freecnc/freecnc-0.2.1.31072003.ebuild
index 245832fa8c5b..9a26a558e948 100644
--- a/games-strategy/freecnc/freecnc-0.2.1.31072003.ebuild
+++ b/games-strategy/freecnc/freecnc-0.2.1.31072003.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecnc/freecnc-0.2.1.31072003.ebuild,v 1.5 2004/11/08 01:41:04 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecnc/freecnc-0.2.1.31072003.ebuild,v 1.6 2005/09/16 02:25:06 mr_bones_ Exp $
-inherit games flag-o-matic eutils
+inherit flag-o-matic eutils games
DESCRIPTION="SDL-rewrite of the classical real time strategy hit Command & Conquer"
HOMEPAGE="http://freecnc-sf.holarse.net/"
@@ -13,12 +13,14 @@ SRC_URI="mirror://gentoo/freecnc++-${PV}-src.tar.bz2
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="~ppc ~x86"
IUSE="zlib nocd"
-DEPEND="media-libs/libsdl
+RDEPEND="media-libs/libsdl
media-libs/sdl-net
zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
S=${WORKDIR}/freecnc++
@@ -31,35 +33,36 @@ src_unpack() {
mv ${f} `echo ${f} | awk '{print tolower($1)}'` || die "moving $f"
done
fi
- cd ${S}
- epatch ${FILESDIR}/${PV}-makefile-cflags.patch
- epatch ${FILESDIR}/${PV}-remove-root.patch
- epatch ${FILESDIR}/${PV}-gentoo-paths.patch
+ cd "${S}"
+ epatch ${FILESDIR}/${PV}-makefile-cflags.patch \
+ ${FILESDIR}/${PV}-remove-root.patch \
+ ${FILESDIR}/${PV}-gentoo-paths.patch
sed -i \
-e "s:GENTOO_LOGDIR:${GAMES_LOGDIR}:" \
-e "s:GENTOO_CONFDIR:${GAMES_SYSCONFDIR}/${PN}/:" \
-e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}/:" \
- src/{freecnc,vfs/vfs}.cpp tools/audplay/audplay.cpp
+ src/{freecnc,vfs/vfs}.cpp tools/audplay/audplay.cpp \
+ || die "sed failed"
}
src_compile() {
- make linux EXTRACFLAGS="${CFLAGS}" || die
+ emake linux EXTRACFLAGS="${CFLAGS}" || die "emake failed"
}
src_install() {
- exeinto ${GAMES_LIBDIR}/${PN}
- doexe freecnc *.vfs audplay shpview tmpinied
- dogamesbin ${FILESDIR}/freecnc
+ exeinto "${GAMES_LIBDIR}"/${PN}
+ doexe freecnc *.vfs audplay shpview tmpinied || die "doexe failed"
+ dogamesbin "${FILESDIR}"/freecnc
dosed "s:GENTOO_DIR:${GAMES_LIBDIR}/${PN}:" ${GAMES_BINDIR}/freecnc
- insinto ${GAMES_DATADIR}/${PN}/conf
+ insinto "${GAMES_DATADIR}"/${PN}/conf
doins conf/*
- insinto ${GAMES_SYSCONFDIR}/${PN}
+ insinto "${GAMES_SYSCONFDIR}"/${PN}
doins conf/*
dodoc AUTHORS ChangeLog NEWS README THANKS TODO
if use nocd ; then
- cd ${WORKDIR}/data
- insinto ${GAMES_DATADIR}/${PN}
- doins *.mix *.aud
+ cd "${WORKDIR}"/data
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins *.mix *.aud || die "doins failed"
dodoc *.txt
fi
prepgamesdirs