summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <msterret@gentoo.org>2003-09-12 01:53:54 +0000
committerMichael Sterrett <msterret@gentoo.org>2003-09-12 01:53:54 +0000
commitb81bc5631dd86ba2794f1f1daa571816ca5bb414 (patch)
treee0aa7fa04105038c8874879610597eb9bdb723d1 /games-strategy/tornado
parentMoved to games-strategy (diff)
downloadgentoo-2-b81bc5631dd86ba2794f1f1daa571816ca5bb414.tar.gz
gentoo-2-b81bc5631dd86ba2794f1f1daa571816ca5bb414.tar.bz2
gentoo-2-b81bc5631dd86ba2794f1f1daa571816ca5bb414.zip
Moved to games-strategy
Diffstat (limited to 'games-strategy/tornado')
-rw-r--r--games-strategy/tornado/ChangeLog10
-rw-r--r--games-strategy/tornado/Manifest4
-rw-r--r--games-strategy/tornado/files/digest-tornado-1.2.1a1
-rw-r--r--games-strategy/tornado/tornado-1.2.1a.ebuild45
4 files changed, 58 insertions, 2 deletions
diff --git a/games-strategy/tornado/ChangeLog b/games-strategy/tornado/ChangeLog
new file mode 100644
index 000000000000..50baf190f0e4
--- /dev/null
+++ b/games-strategy/tornado/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-games/tornado
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/tornado/ChangeLog,v 1.1 2003/09/12 01:53:52 msterret Exp $
+
+*tornado-1.2.1a (05 Sep 2003)
+
+ 05 Sep 2003; Michael Sterrett <msterret@gentoo.org> tornado-1.2.1a.ebuild:
+ initial commit. ebuild based off the one submitted by Jan Brinkmann via bug
+ 28030
+
diff --git a/games-strategy/tornado/Manifest b/games-strategy/tornado/Manifest
index fd0e36eabad7..9f0f03661e67 100644
--- a/games-strategy/tornado/Manifest
+++ b/games-strategy/tornado/Manifest
@@ -1,3 +1,3 @@
-MD5 33e4b1ca261fad083f6b2c8d19f3b145 tornado-1.2.1a.ebuild 1115
-MD5 e5b0200c5605d6793f275c3dcd3b2db5 ChangeLog 413
+MD5 1c1e62d44b29fa46a816140303f1069f ChangeLog 418
+MD5 44f5ff1ab465179ca0e3a2ca76bed246 tornado-1.2.1a.ebuild 1120
MD5 3ae493c92807e676ee29bf2bcdb95283 files/digest-tornado-1.2.1a 65
diff --git a/games-strategy/tornado/files/digest-tornado-1.2.1a b/games-strategy/tornado/files/digest-tornado-1.2.1a
new file mode 100644
index 000000000000..f992c3bc7a99
--- /dev/null
+++ b/games-strategy/tornado/files/digest-tornado-1.2.1a
@@ -0,0 +1 @@
+MD5 e2ce8ebf2192206e159f33a24ef7a69d tornado-1.2.1a.tar.gz 51142
diff --git a/games-strategy/tornado/tornado-1.2.1a.ebuild b/games-strategy/tornado/tornado-1.2.1a.ebuild
new file mode 100644
index 000000000000..60459d964d10
--- /dev/null
+++ b/games-strategy/tornado/tornado-1.2.1a.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/tornado/tornado-1.2.1a.ebuild,v 1.1 2003/09/12 01:53:52 msterret Exp $
+
+inherit games
+
+DESCRIPTION="Clone of a C64 game - destroy the opponent's house"
+HOMEPAGE="http://home.kcore.de/~kiza/linux/tornado/"
+SRC_URI="http://home.kcore.de/~kiza/linux/tornado/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-libs/ncurses-5.3"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ sys-apps/textutils"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "s:/usr/local:/usr:" \
+ -e "s:-O2:${CFLAGS}:" Makefile || \
+ die "sed Makefile failed"
+
+ sed -i \
+ -e "s:PREFIX/bin:${GAMES_BINDIR}:" \
+ -e "s:PREFIX/man:/usr/man:" \
+ -e "s:/usr/local:/usr:" doc/man/tornado.6.in || \
+ die "sed doc/man/tornado.6 failed"
+}
+
+src_install() {
+ dogamesbin tornado
+ doman doc/man/tornado.6
+ dodoc AUTHOR CREDITS Changelog README TODO
+ insinto ${GAMES_STATEDIR}
+ doins tornado.scores
+ prepgamesdirs
+ fperms 664 ${GAMES_STATEDIR}/tornado.scores
+}