summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-01-20 01:25:36 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-01-20 01:25:36 +0000
commitbaf31243b2bcdfb2d3513f72493d3f33625929ac (patch)
tree83f22ce25aebc0aee057895ea01acff91315d98c /games-strategy/wesnoth
parentVersion bump. (diff)
downloadgentoo-2-baf31243b2bcdfb2d3513f72493d3f33625929ac.tar.gz
gentoo-2-baf31243b2bcdfb2d3513f72493d3f33625929ac.tar.bz2
gentoo-2-baf31243b2bcdfb2d3513f72493d3f33625929ac.zip
fix build with USE=dedicated
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-strategy/wesnoth')
-rw-r--r--games-strategy/wesnoth/ChangeLog6
-rw-r--r--games-strategy/wesnoth/files/wesnoth-1.12-cmake.patch22
-rw-r--r--games-strategy/wesnoth/wesnoth-1.12.ebuild3
3 files changed, 29 insertions, 2 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index 84419ff39b89..89813ed44fba 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.237 2015/01/13 18:11:11 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.238 2015/01/20 01:25:36 mr_bones_ Exp $
+
+ 20 Jan 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/wesnoth-1.12-cmake.patch, wesnoth-1.12.ebuild:
+ fix build with USE=dedicated
*wesnoth-1.12 (13 Jan 2015)
diff --git a/games-strategy/wesnoth/files/wesnoth-1.12-cmake.patch b/games-strategy/wesnoth/files/wesnoth-1.12-cmake.patch
new file mode 100644
index 000000000000..767dd6c8a3ae
--- /dev/null
+++ b/games-strategy/wesnoth/files/wesnoth-1.12-cmake.patch
@@ -0,0 +1,22 @@
+--- CMakeLists.txt.orig 2015-01-19 18:46:51.019420318 -0500
++++ CMakeLists.txt 2015-01-19 18:47:15.977567447 -0500
+@@ -590,13 +590,14 @@
+ endif(LIBDBUS_FOUND)
+ endif(ENABLE_NOTIFICATIONS)
+
+- if(ENABLE_BOOST_FILESYSTEM AND NOT ENABLE_PANDORA)
+- find_package( Boost 1.44 REQUIRED COMPONENTS filesystem )
+- find_package( Boost 1.48 REQUIRED COMPONENTS locale )
+- endif(ENABLE_BOOST_FILESYSTEM AND NOT ENABLE_PANDORA)
+-
+ endif(ENABLE_GAME)
+
++if(ENABLE_BOOST_FILESYSTEM AND NOT ENABLE_PANDORA)
++ find_package( Boost 1.44 REQUIRED COMPONENTS filesystem )
++ find_package( Boost 1.48 REQUIRED COMPONENTS locale )
++endif(ENABLE_BOOST_FILESYSTEM AND NOT ENABLE_PANDORA)
++
++
+ if(ENABLE_POT_UPDATE_TARGET)
+ find_package(TranslationTools REQUIRED)
+ endif(ENABLE_POT_UPDATE_TARGET)
diff --git a/games-strategy/wesnoth/wesnoth-1.12.ebuild b/games-strategy/wesnoth/wesnoth-1.12.ebuild
index 7390716dae86..8891d825fc64 100644
--- a/games-strategy/wesnoth/wesnoth-1.12.ebuild
+++ b/games-strategy/wesnoth/wesnoth-1.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.12.ebuild,v 1.1 2015/01/13 18:11:11 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.12.ebuild,v 1.2 2015/01/20 01:25:36 mr_bones_ Exp $
EAPI=5
inherit cmake-utils eutils multilib toolchain-funcs flag-o-matic games
@@ -62,6 +62,7 @@ src_prepare() {
done
echo "$langs" > po/LINGUAS || die
fi
+ epatch "${FILESDIR}/${P}-cmake.patch"
}
src_configure() {