summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-03-27 22:34:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-03-27 22:34:46 +0000
commit2e880157a959be3774b47f02dc8b450cafe35b89 (patch)
treed0bcafe5fe201275af5276978c2f029f3b91785a /games-strategy
parentRevbump to switch to gnu-classpath-0.98, move the install to /usr/lib/jamvm, ... (diff)
downloadgentoo-2-2e880157a959be3774b47f02dc8b450cafe35b89.tar.gz
gentoo-2-2e880157a959be3774b47f02dc8b450cafe35b89.tar.bz2
gentoo-2-2e880157a959be3774b47f02dc8b450cafe35b89.zip
correct boost:0 handling (bug #311635)
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/ChangeLog5
-rw-r--r--games-strategy/wesnoth/wesnoth-1.8.ebuild6
2 files changed, 7 insertions, 4 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index 7b4db82061cd..078f2c4249e2 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.173 2010/03/26 06:50:00 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.174 2010/03/27 22:34:46 mr_bones_ Exp $
+
+ 27 Mar 2010; Michael Sterrett <mr_bones_@gentoo.org> wesnoth-1.8.ebuild:
+ correct boost:0 handling (bug #311635)
26 Mar 2010; Michael Sterrett <mr_bones_@gentoo.org> wesnoth-1.8.ebuild:
Doesn't work with some boost versions so build/link against specific
diff --git a/games-strategy/wesnoth/wesnoth-1.8.ebuild b/games-strategy/wesnoth/wesnoth-1.8.ebuild
index 7d11e75d8a9a..2410d7658ed7 100644
--- a/games-strategy/wesnoth/wesnoth-1.8.ebuild
+++ b/games-strategy/wesnoth/wesnoth-1.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.8.ebuild,v 1.3 2010/03/26 07:43:49 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.8.ebuild,v 1.4 2010/03/27 22:34:46 mr_bones_ Exp $
EAPI=2
inherit cmake-utils eutils toolchain-funcs flag-o-matic games
@@ -22,7 +22,7 @@ RDEPEND=">=media-libs/libsdl-1.2.7[video,X]
!dedicated? (
dbus? ( sys-apps/dbus )
)
- || ( dev-libs/boost:1.42 dev-libs/boost:1.41 dev-libs/boost:1.35 )
+ || ( dev-libs/boost:1.42 dev-libs/boost:1.41 >=dev-libs/boost-1.35:0 )
sys-libs/zlib
x11-libs/pango
dev-lang/lua
@@ -57,7 +57,7 @@ src_prepare() {
|| die "sed failed"
fi
# how do I hate boost? Let me count the ways...
- has_version dev-libs/boost:1.35 && boost_ver=1_35
+ has_version dev-libs/boost:0 && boost_ver=1_35
has_version dev-libs/boost:1.41 && boost_ver=1_41
has_version dev-libs/boost:1.42 && boost_ver=1_42
append-cxxflags \