summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-03-26 06:50:00 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-03-26 06:50:00 +0000
commit3c6097492ae7bc1951589f9fc849c7cc9556e79f (patch)
tree01ceac9551190b92a92e6203d681665479b2ba0e /games-strategy
parentdev-util/cpptest: Trivial-bump to 1.1.1 (diff)
downloadgentoo-2-3c6097492ae7bc1951589f9fc849c7cc9556e79f.tar.gz
gentoo-2-3c6097492ae7bc1951589f9fc849c7cc9556e79f.tar.bz2
gentoo-2-3c6097492ae7bc1951589f9fc849c7cc9556e79f.zip
Doesn't work with some boost versions so build/link against specific versions
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/ChangeLog6
-rw-r--r--games-strategy/wesnoth/wesnoth-1.8.ebuild13
2 files changed, 16 insertions, 3 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index d6bb007404e4..7b4db82061cd 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.172 2010/03/25 16:20:33 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.173 2010/03/26 06:50:00 mr_bones_ Exp $
+
+ 26 Mar 2010; Michael Sterrett <mr_bones_@gentoo.org> wesnoth-1.8.ebuild:
+ Doesn't work with some boost versions so build/link against specific
+ versions
*wesnoth-1.8 (25 Mar 2010)
diff --git a/games-strategy/wesnoth/wesnoth-1.8.ebuild b/games-strategy/wesnoth/wesnoth-1.8.ebuild
index 69ac4036405a..2c65c63ee19a 100644
--- a/games-strategy/wesnoth/wesnoth-1.8.ebuild
+++ b/games-strategy/wesnoth/wesnoth-1.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.8.ebuild,v 1.1 2010/03/25 16:20:33 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.8.ebuild,v 1.2 2010/03/26 06:50:00 mr_bones_ Exp $
EAPI=2
inherit cmake-utils eutils toolchain-funcs flag-o-matic games
@@ -22,7 +22,7 @@ RDEPEND=">=media-libs/libsdl-1.2.7[video,X]
!dedicated? (
dbus? ( sys-apps/dbus )
)
- >=dev-libs/boost-1.35
+ || ( dev-libs/boost:1.42 dev-libs/boost:1.41 dev-libs/boost:1.37 dev-libs/boost:1.35 )
sys-libs/zlib
x11-libs/pango
dev-lang/lua
@@ -56,6 +56,15 @@ src_prepare() {
doc/CMakeLists.txt \
|| die "sed failed"
fi
+ # how do I hate boost? Let me count the ways...
+ has_version dev-libs/boost:1.35 && boost_ver=1_35
+ has_version dev-libs/boost:1.37 && boost_ver=1_37
+ has_version dev-libs/boost:1.41 && boost_ver=1_41
+ has_version dev-libs/boost:1.42 && boost_ver=1_42
+ append-cxxflags \
+ -I/usr/include/boost-${boost_ver}
+ append-ldflags \
+ -L/usr/$(get_libdir)/boost-${boost_ver}
}
src_configure() {