summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-09-21 05:25:35 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-09-21 05:25:35 +0000
commit4d31d3d4c1f1c97b361191ef37a2213d854d307d (patch)
tree3d6b9710ec3b12b0b067a2c432ba171fbdce3f31 /games-strategy
parentclean out old, non-modX ebuild (diff)
downloadgentoo-2-4d31d3d4c1f1c97b361191ef37a2213d854d307d.tar.gz
gentoo-2-4d31d3d4c1f1c97b361191ef37a2213d854d307d.tar.bz2
gentoo-2-4d31d3d4c1f1c97b361191ef37a2213d854d307d.zip
masked version bump
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/ChangeLog8
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-1.1.103
-rw-r--r--games-strategy/wesnoth/wesnoth-1.1.10.ebuild88
3 files changed, 98 insertions, 1 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index 57de7f140e5a..3a3d3b1f72e3 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.76 2006/09/10 08:44:49 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.77 2006/09/21 05:25:35 mr_bones_ Exp $
+
+*wesnoth-1.1.10 (21 Sep 2006)
+
+ 21 Sep 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ +wesnoth-1.1.10.ebuild:
+ masked version bump
10 Sep 2006; Michael Sterrett <mr_bones_@gentoo.org> wesnoth-1.0.2.ebuild,
wesnoth-1.1.9.ebuild:
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-1.1.10 b/games-strategy/wesnoth/files/digest-wesnoth-1.1.10
new file mode 100644
index 000000000000..8e9e6f37f8b3
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-1.1.10
@@ -0,0 +1,3 @@
+MD5 49e2efb48bfef1fec7741d1a7aec4d0b wesnoth-1.1.10.tar.gz 75496116
+RMD160 eeca0bd33a3436749f780a0cb27373290a26cc43 wesnoth-1.1.10.tar.gz 75496116
+SHA256 c3ec170b054ed1dadaeaa8d264f36320d57707c3fb41d4d47cc6c76b6311f88f wesnoth-1.1.10.tar.gz 75496116
diff --git a/games-strategy/wesnoth/wesnoth-1.1.10.ebuild b/games-strategy/wesnoth/wesnoth-1.1.10.ebuild
new file mode 100644
index 000000000000..f817a6ba852d
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-1.1.10.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.1.10.ebuild,v 1.1 2006/09/21 05:25:35 mr_bones_ Exp $
+
+inherit autotools eutils toolchain-funcs flag-o-matic games
+
+MY_PV=${PV/_/}
+DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="mirror://sourceforge/wesnoth/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE="dedicated editor gnome kde lite nls server tools"
+
+DEPEND=">=media-libs/libsdl-1.2.7
+ !dedicated? (
+ || (
+ x11-libs/libX11
+ virtual/x11 )
+ >=media-libs/freetype-2 )
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-image-1.2
+ media-libs/sdl-net
+ sys-libs/zlib"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+pkg_setup() {
+ if ! built_with_use -o media-libs/sdl-mixer vorbis oggvorbis ; then
+ die "Please emerge sdl-mixer with USE=vorbis"
+ fi
+ if ! built_with_use media-libs/sdl-image png ; then
+ die "Please emerge sdl-image with USE=png"
+ fi
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack "${A}"
+ if use server ; then
+ sed \
+ -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
+ -e "s:GAMES_STATEDIR:${GAMES_STATEDIR}:" \
+ -e "s/GAMES_USER_DED/${GAMES_USER_DED}/" \
+ -e "s/GAMES_GROUP/${GAMES_GROUP}/" "${FILESDIR}"/wesnothd.rc \
+ > "${T}"/wesnothd \
+ || die "sed failed"
+ fi
+}
+
+src_compile() {
+ filter-flags -ftracer -fomit-frame-pointer
+ if [[ $(gcc-major-version) -eq 3 ]] ; then
+ filter-flags -fstack-protector
+ append-flags -fno-stack-protector
+ fi
+ egamesconf \
+ --disable-dependency-tracking \
+ --without-fribidi \
+ --with-localedir=/usr/share/locale \
+ --with-icondir=/usr/share/icons \
+ --with-desktopdir=/usr/share/applications \
+ $(use_enable lite) \
+ $(use_enable server) \
+ $(use_enable server campaign-server) \
+ $(use server && echo --with-server-uid=${GAMES_USER_DED} --with-server-gid=${GAMES_GROUP}) \
+ $(use_enable editor) \
+ $(use_enable tools) \
+ $(use_enable nls) \
+ $(use_enable nls dummy-locales) \
+ $(use_enable !dedicated game) \
+ $(use_with gnome) \
+ $(use_with kde) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc MANUAL changelog
+ if use server; then
+ keepdir "${GAMES_STATEDIR}/run/wesnothd"
+ doinitd "${T}"/wesnothd || die "doinitd failed"
+ fi
+ prepgamesdirs
+}