summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-06-03 10:46:03 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-06-03 10:46:03 +0000
commit50cdd250f9a9a308be6cc91209352f3666636d8e (patch)
tree1e7e301e76028e16fb5e501de1f753845bd6616e /games-strategy
parentOld patch. (diff)
downloadgentoo-2-50cdd250f9a9a308be6cc91209352f3666636d8e.tar.gz
gentoo-2-50cdd250f9a9a308be6cc91209352f3666636d8e.tar.bz2
gentoo-2-50cdd250f9a9a308be6cc91209352f3666636d8e.zip
Version bump, bug #272230
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/warzone2100/ChangeLog7
-rw-r--r--games-strategy/warzone2100/warzone2100-2.2.0.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/games-strategy/warzone2100/ChangeLog b/games-strategy/warzone2100/ChangeLog
index b84b520068d6..8d1f1e4a70ec 100644
--- a/games-strategy/warzone2100/ChangeLog
+++ b/games-strategy/warzone2100/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/warzone2100
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/ChangeLog,v 1.29 2009/04/10 02:32:44 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/ChangeLog,v 1.30 2009/06/03 10:46:03 nyhm Exp $
+
+*warzone2100-2.2.0 (03 Jun 2009)
+
+ 03 Jun 2009; Tristan Heaven <nyhm@gentoo.org> +warzone2100-2.2.0.ebuild:
+ Version bump, bug #272230
*warzone2100-2.1.3 (10 Apr 2009)
diff --git a/games-strategy/warzone2100/warzone2100-2.2.0.ebuild b/games-strategy/warzone2100/warzone2100-2.2.0.ebuild
new file mode 100644
index 000000000000..3e61f963775a
--- /dev/null
+++ b/games-strategy/warzone2100/warzone2100-2.2.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/warzone2100-2.2.0.ebuild,v 1.1 2009/06/03 10:46:03 nyhm Exp $
+
+EAPI=2
+inherit versionator games
+
+MY_PV=$(get_version_component_range -2)
+DESCRIPTION="3D real-time strategy game"
+HOMEPAGE="http://wz2100.net/"
+SRC_URI="http://download.gna.org/warzone/releases/${MY_PV}/${P}.tar.bz2
+ videos? ( http://download.gna.org/warzone/videos/sequences-${MY_PV}.wz )"
+
+LICENSE="GPL-2 CCPL-Attribution-ShareAlike-3.0 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+# upstream requested debug support
+IUSE="debug nls videos"
+
+RDEPEND="dev-db/sqlite:3
+ dev-games/physfs
+ dev-libs/popt
+ media-libs/libogg
+ media-libs/libpng
+ media-libs/libsdl[opengl]
+ media-libs/libtheora
+ media-libs/libvorbis
+ media-libs/openal
+ media-libs/sdl-net
+ media-libs/quesoglc
+ virtual/glu
+ virtual/opengl
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ app-arch/zip
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+RDEPEND="${RDEPEND}
+ media-fonts/dejavu"
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --docdir=/usr/share/doc/${PF} \
+ --localedir=/usr/share/locale \
+ --with-distributor="Gentoo ${PF}" \
+ --with-icondir=/usr/share/pixmaps \
+ --with-applicationdir=/usr/share/applications \
+ $(use_enable debug) \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rm -f "${D}"/usr/share/doc/${PF}/COPYING*
+ if use videos ; then
+ insinto "${GAMES_DATADIR}"/${PN}
+ newins "${DISTDIR}"/sequences-${MY_PV}.wz sequences.wz \
+ || die "newins failed"
+ fi
+ prepgamesdirs
+}