summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-06-16 20:48:24 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-06-16 20:48:24 +0000
commit661d2c1ffc8dd2368b368af0a071a648d0103eb9 (patch)
tree383397818fed37469d51616251955d2a0e6c5889 /games-strategy
parentremove unused versions (diff)
downloadgentoo-2-661d2c1ffc8dd2368b368af0a071a648d0103eb9.tar.gz
gentoo-2-661d2c1ffc8dd2368b368af0a071a648d0103eb9.tar.bz2
gentoo-2-661d2c1ffc8dd2368b368af0a071a648d0103eb9.zip
Version bump
(Portage version: 2.2_pre8/cvs/Linux 2.6.25.6 x86_64)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/freecol/ChangeLog8
-rw-r--r--games-strategy/freecol/files/freecol-0.7.4-home.patch22
-rw-r--r--games-strategy/freecol/freecol-0.7.4.ebuild68
3 files changed, 97 insertions, 1 deletions
diff --git a/games-strategy/freecol/ChangeLog b/games-strategy/freecol/ChangeLog
index dc9cd761ca5a..e6c8b3f1d666 100644
--- a/games-strategy/freecol/ChangeLog
+++ b/games-strategy/freecol/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/freecol
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecol/ChangeLog,v 1.29 2008/02/29 19:45:56 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecol/ChangeLog,v 1.30 2008/06/16 20:48:23 nyhm Exp $
+
+*freecol-0.7.4 (16 Jun 2008)
+
+ 16 Jun 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/freecol-0.7.4-home.patch, +freecol-0.7.4.ebuild:
+ Version bump
29 Feb 2008; Carsten Lohrke <carlo@gentoo.org> ChangeLog:
Remove icon extension from desktop entry to match Icon Theme Specification.
diff --git a/games-strategy/freecol/files/freecol-0.7.4-home.patch b/games-strategy/freecol/files/freecol-0.7.4-home.patch
new file mode 100644
index 000000000000..f52e943e0c6b
--- /dev/null
+++ b/games-strategy/freecol/files/freecol-0.7.4-home.patch
@@ -0,0 +1,22 @@
+--- src/net/sf/freecol/common/logging/DefaultHandler.java
++++ src/net/sf/freecol/common/logging/DefaultHandler.java
+@@ -22,7 +22,7 @@
+
+ public static final String REVISION = "$Revision: 1.1 $";
+
+- private static final String fileName = new String("FreeCol.log");
++ private static final String fileName = new String(System.getProperty("user.home") + "/.freecol/FreeCol.log");
+
+ private FileWriter fileWriter;
+
+--- src/net/sf/freecol/FreeCol.java
++++ src/net/sf/freecol/FreeCol.java
+@@ -314,7 +314,7 @@
+ private static void createAndSetDirectories() {
+ // TODO: The location of the save directory should be determined by the installer.;
+
+- File mainUserDirectory = new File(System.getProperty("user.home"), "freecol");
++ File mainUserDirectory = new File(System.getProperty("user.home"), ".freecol");
+ if (mainUserDirectory.exists() && mainUserDirectory.isFile()) {
+ logger.warning("Could not create .freecol under "
+ + System.getProperty("user.home") + " because there "
diff --git a/games-strategy/freecol/freecol-0.7.4.ebuild b/games-strategy/freecol/freecol-0.7.4.ebuild
new file mode 100644
index 000000000000..42339e27e7b7
--- /dev/null
+++ b/games-strategy/freecol/freecol-0.7.4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecol/freecol-0.7.4.ebuild,v 1.1 2008/06/16 20:48:23 nyhm Exp $
+
+WANT_ANT_TASKS="ant-nodeps"
+inherit eutils java-pkg-2 java-ant-2 games
+
+DESCRIPTION="An open source clone of the game Colonization"
+HOMEPAGE="http://www.freecol.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-java/higlayout"
+DEPEND="${RDEPEND}
+ test? (
+ dev-java/ant-junit
+ dev-java/ant-trax
+ )
+ >=virtual/jdk-1.6"
+RDEPEND="${RDEPEND}
+ >=virtual/jre-1.6"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ games_pkg_setup
+ java-pkg-2_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -fv $(find . -name '*.jar')
+ java-pkg_jar-from --into jars higlayout
+ epatch "${FILESDIR}"/${P}-home.patch
+ sed -i \
+ -e "/Class-Path/s:jars/.*\":$(java-pkg_getjars higlayout)\":" \
+ build.xml \
+ || die "sed failed"
+}
+
+src_compile() {
+ eant
+}
+
+src_test() {
+ java-pkg_jar-from --into test/lib junit
+ ANT_TASKS="ant-junit ant-trax ant-nodeps" eant testall
+}
+
+src_install () {
+ java-pkg_jarinto "${GAMES_DATADIR}"/${PN}
+ java-pkg_dojar FreeCol.jar
+ java-pkg_dolauncher ${PN} \
+ -into "${GAMES_PREFIX}" \
+ --pwd "${GAMES_DATADIR}"/${PN} \
+ --java_args -Xmx512M
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data || die "doins failed"
+ doicon ${PN}.xpm
+ make_desktop_entry ${PN} FreeCol
+ dodoc README
+ prepgamesdirs
+}