summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-07-13 10:46:03 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-07-13 10:46:03 +0000
commit6c5f73f0c1b1b49d0b8f7a81c0227d60e3a8e702 (patch)
tree2f906df9f3eb5d632d6095065cb6a11b7a9c130f /games-strategy
parentFixed encoding in ChangeLog (diff)
downloadgentoo-2-6c5f73f0c1b1b49d0b8f7a81c0227d60e3a8e702.tar.gz
gentoo-2-6c5f73f0c1b1b49d0b8f7a81c0227d60e3a8e702.tar.bz2
gentoo-2-6c5f73f0c1b1b49d0b8f7a81c0227d60e3a8e702.zip
Fix build with gcc-4.4 Bug #277179
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/glob2/ChangeLog6
-rw-r--r--games-strategy/glob2/files/glob2-0.9.4.1-gcc44.patch12
-rw-r--r--games-strategy/glob2/glob2-0.9.4.1.ebuild4
3 files changed, 20 insertions, 2 deletions
diff --git a/games-strategy/glob2/ChangeLog b/games-strategy/glob2/ChangeLog
index cb9b663ae98e..caacc3e3a5ff 100644
--- a/games-strategy/glob2/ChangeLog
+++ b/games-strategy/glob2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/glob2
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/ChangeLog,v 1.47 2009/06/09 08:48:02 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/ChangeLog,v 1.48 2009/07/13 10:46:02 tupone Exp $
+
+ 13 Jul 2009; Tupone Alfredo <tupone@gentoo.org>
+ +files/glob2-0.9.4.1-gcc44.patch, glob2-0.9.4.1.ebuild:
+ Fix build with gcc-4.4 Bug #277179 by <flameeyes@gentoo.org>
09 Jun 2009; Christian Faulhammer <fauli@gentoo.org> glob2-0.9.4.1.ebuild:
stable x86, bug 272098
diff --git a/games-strategy/glob2/files/glob2-0.9.4.1-gcc44.patch b/games-strategy/glob2/files/glob2-0.9.4.1-gcc44.patch
new file mode 100644
index 000000000000..67aa1a0789c4
--- /dev/null
+++ b/games-strategy/glob2/files/glob2-0.9.4.1-gcc44.patch
@@ -0,0 +1,12 @@
+--- libgag/include/StreamBackend.h.old 2009-07-13 10:52:36.000000000 +0200
++++ libgag/include/StreamBackend.h 2009-07-13 10:52:57.000000000 +0200
+@@ -28,6 +28,9 @@
+ #ifdef putc
+ #undef putc
+ #endif
++#ifdef getc
++#undef getc
++#endif
+
+ namespace GAGCore
+ {
diff --git a/games-strategy/glob2/glob2-0.9.4.1.ebuild b/games-strategy/glob2/glob2-0.9.4.1.ebuild
index 255be1afede6..02fbdbd7ba80 100644
--- a/games-strategy/glob2/glob2-0.9.4.1.ebuild
+++ b/games-strategy/glob2/glob2-0.9.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/glob2-0.9.4.1.ebuild,v 1.4 2009/06/09 08:48:02 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/glob2-0.9.4.1.ebuild,v 1.5 2009/07/13 10:46:02 tupone Exp $
EAPI=2
inherit eutils games
@@ -27,6 +27,8 @@ RDEPEND="virtual/opengl
DEPEND="${RDEPEND}
>=dev-util/scons-1"
+PATCHES=( "${FILESDIR}"/${P}-gcc44.patch )
+
src_compile() {
local sconsopts=$(echo "${MAKEOPTS}" | sed -ne "/-j/ { s/.*\(-j[0-9]\+\).*/\1/; p }")