summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-03-29 08:17:56 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-03-29 08:17:56 +0000
commit719bf939dfdf29b2af3b40c67b0aac236c753266 (patch)
tree9401ad0f9d488161320a25ad11834dc0853acc9e /games-strategy
parentinitial commit (diff)
downloadgentoo-2-719bf939dfdf29b2af3b40c67b0aac236c753266.tar.gz
gentoo-2-719bf939dfdf29b2af3b40c67b0aac236c753266.tar.bz2
gentoo-2-719bf939dfdf29b2af3b40c67b0aac236c753266.zip
EAPI=5
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/heroes3/ChangeLog8
-rw-r--r--games-strategy/heroes3/heroes3-1.3.1a-r2.ebuild26
2 files changed, 17 insertions, 17 deletions
diff --git a/games-strategy/heroes3/ChangeLog b/games-strategy/heroes3/ChangeLog
index 14e8eb15aeb5..33b2c206f800 100644
--- a/games-strategy/heroes3/ChangeLog
+++ b/games-strategy/heroes3/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-strategy/heroes3
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/heroes3/ChangeLog,v 1.24 2014/09/07 09:54:24 ulm Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/heroes3/ChangeLog,v 1.25 2015/03/29 08:17:56 mr_bones_ Exp $
+
+ 29 Mar 2015; Michael Sterrett <mr_bones_@gentoo.org> heroes3-1.3.1a-r2.ebuild:
+ EAPI=5
07 Sep 2014; Ulrich Müller <ulm@gentoo.org> heroes3-1.3.1a-r2.ebuild:
Drop reverse dependencies of sys-libs/lib-compat to unstable, bug 517932.
@@ -103,4 +106,3 @@
29 Sep 2004; Chris Gianelloni <wolf31o2@gentoo.org> +metadata.xml,
+heroes3-1.3.1a.ebuild:
Initial import. Ebuild submitted by me. Closing bug #33206.
-
diff --git a/games-strategy/heroes3/heroes3-1.3.1a-r2.ebuild b/games-strategy/heroes3/heroes3-1.3.1a-r2.ebuild
index 95e364d21637..04afaf9b79fe 100644
--- a/games-strategy/heroes3/heroes3-1.3.1a-r2.ebuild
+++ b/games-strategy/heroes3/heroes3-1.3.1a-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/heroes3/heroes3-1.3.1a-r2.ebuild,v 1.16 2014/09/07 09:54:24 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/heroes3/heroes3-1.3.1a-r2.ebuild,v 1.17 2015/03/29 08:17:56 mr_bones_ Exp $
# [x] Base Install Required (+4 MB)
# [x] Scenarios (+7 MB)
@@ -10,6 +10,7 @@
# --------------------
# Total 341 MB
+EAPI=5
LANGS="de es pl"
LANGPACKPREFIX="${PN}-lang"
LANGPACKBASE="http://babelize.org/download/"
@@ -164,11 +165,11 @@ src_install() {
# done
# fi
- tar zxf "${CDROM_ROOT}"/hiscore.tar.gz -C "${Ddir}" || die "unpacking hiscore"
+ tar zxf "${CDROM_ROOT}"/hiscore.tar.gz -C "${Ddir}" || die
cd "${S}"
loki_patch --verify patch.dat
- loki_patch patch.dat "${Ddir}" >& /dev/null || die "patching"
+ loki_patch patch.dat "${Ddir}" >& /dev/null || die
# now, since these files are coming off a cd, the times/sizes/md5sums wont
# be different ... that means portage will try to unmerge some files (!)
@@ -183,24 +184,21 @@ src_install() {
if ! use ppc
then
einfo "Linking libs provided by 'sys-libs/lib-compat-loki' to '${dir}'."
- dosym /lib/loki_ld-linux.so.2 "${dir}"/ld-linux.so.2 || die "dosym"
- dosym /usr/lib/loki_libc.so.6 "${dir}"/libc.so.6 || die "dosym"
- dosym /usr/lib/loki_libnss_files.so.2 "${dir}"/libnss_files.so.2 \
- || die "dosym failed"
+ dosym /lib/loki_ld-linux.so.2 "${dir}"/ld-linux.so.2
+ dosym /usr/lib/loki_libc.so.6 "${dir}"/libc.so.6
+ dosym /usr/lib/loki_libnss_files.so.2 "${dir}"/libnss_files.so.2
fi
elog "Changing 'hiscore.dat' to be writeable for group 'games'."
- fperms g+w "${dir}/data/hiscore.dat" || die "fperms failed"
+ fperms g+w "${dir}/data/hiscore.dat"
# in order to play campaign games, put this wrapper in place.
# it changes CWD to a user-writeable directory before executing heroes3.
# (fixes bug #93604)
einfo "Preparing wrapper."
- cp "${FILESDIR}"/heroes3-wrapper.sh "${T}"/heroes3 || \
- die "copying wrapper failed"
- sed -i -e "s:GAMES_PREFIX_OPT:${GAMES_PREFIX_OPT}:" "${T}"/heroes3 ||
- die "sed failed"
- dogamesbin "${T}"/heroes3 || die "doexe failed"
+ cp "${FILESDIR}"/heroes3-wrapper.sh "${T}"/heroes3 || die
+ sed -i -e "s:GAMES_PREFIX_OPT:${GAMES_PREFIX_OPT}:" "${T}"/heroes3 || die
+ dogamesbin "${T}"/heroes3
}