summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2012-09-11 16:01:06 +0000
committerThomas Kahle <tomka@gentoo.org>2012-09-11 16:01:06 +0000
commit72c37d8a532f86867af695dbe72f4474c6181c8a (patch)
tree91d7c6e1df397c85f0c8f1b28f3d20210dc468f1 /games-strategy
parentBump to recent svn version and import to main tree (bug #349367) (diff)
downloadgentoo-2-72c37d8a532f86867af695dbe72f4474c6181c8a.tar.gz
gentoo-2-72c37d8a532f86867af695dbe72f4474c6181c8a.tar.bz2
gentoo-2-72c37d8a532f86867af695dbe72f4474c6181c8a.zip
Bump to recent svn and import to main tree (Bug 402019)
(Portage version: 2.1.11.14/cvs/Linux x86_64)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/freeorion/ChangeLog23
-rw-r--r--games-strategy/freeorion/freeorion-0.4.2_pre20120910.ebuild96
-rw-r--r--games-strategy/freeorion/metadata.xml18
3 files changed, 137 insertions, 0 deletions
diff --git a/games-strategy/freeorion/ChangeLog b/games-strategy/freeorion/ChangeLog
new file mode 100644
index 000000000000..96bb9a0cb6df
--- /dev/null
+++ b/games-strategy/freeorion/ChangeLog
@@ -0,0 +1,23 @@
+# ChangeLog for games-strategy/freeorion
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeorion/ChangeLog,v 1.1 2012/09/11 16:01:06 tomka Exp $
+
+*freeorion-0.4.2_pre20120910 (11 Sep 2012)
+
+ 11 Sep 2012; Thomas Kahle <tomka@gentoo.org>
+ +freeorion-0.4.2_pre20120910.ebuild, +metadata.xml:
+ Bump to recent svn and import to main tree (Bug 402019)
+
+ 05 May 2012; Mike Gilbert <floppym@gentoo.org> freeorion-0.3.17_p4823.ebuild:
+ Use pkgconfig virtual.
+
+ 23 Apr 2012; hasufell <julian.ospald@googlemail.com>
+ freeorion-0.3.17_p4823.ebuild:
+ fix dep
+
+*freeorion-0.3.17_p4823 (23 Apr 2012)
+
+ 23 Apr 2012; hasufell <julian.ospald@googlemail.com>
+ +freeorion-0.3.17_p4823.ebuild, +metadata.xml:
+ New Ebuild for bug 402019 thanks to all
+
diff --git a/games-strategy/freeorion/freeorion-0.4.2_pre20120910.ebuild b/games-strategy/freeorion/freeorion-0.4.2_pre20120910.ebuild
new file mode 100644
index 000000000000..bf250974ea9d
--- /dev/null
+++ b/games-strategy/freeorion/freeorion-0.4.2_pre20120910.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeorion/freeorion-0.4.2_pre20120910.ebuild,v 1.1 2012/09/11 16:01:06 tomka Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+
+inherit cmake-utils python games
+
+DESCRIPTION="A free turn-based space empire and galactic conquest game"
+HOMEPAGE="http://www.freeorion.org"
+SRC_URI="http://dev.gentoo.org/~tomka/files/FreeOrion-${PV}.tar.bz2"
+
+LICENSE="GPL-2 CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="cg"
+
+# Needs a dev-games/gigi from the freeorion source directory.
+# It's safest to use the same version.
+RDEPEND="
+ dev-games/gigi[ogre,ois]
+ dev-games/ogre[cg?,opengl]
+ >=dev-libs/boost-1.47[python]
+ media-libs/freealut
+ media-libs/libogg
+ media-libs/libsdl[X,opengl,video]
+ media-libs/libvorbis
+ media-libs/openal
+ sci-physics/bullet
+ sys-libs/zlib
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/FreeOrion-${PV}/"
+CMAKE_USE_DIR="${S}"
+CMAKE_VERBOSE="1"
+
+src_prepare() {
+ # set OGRE plugin-dir
+ sed \
+ -e "s:PluginFolder=.:PluginFolder=$(pkg-config --variable=plugindir OGRE):" \
+ -i "${CMAKE_USE_DIR}"/ogre_plugins.cfg || die
+
+ if use cg ; then
+ # add cg ogre plugin to config
+ echo "Plugin=Plugin_CgProgramManager" \
+ >> "${CMAKE_USE_DIR}"/ogre_plugins.cfg || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DRELEASE_COMPILE_FLAGS=""
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ # data files
+ rm "${CMAKE_USE_DIR}"/default/COPYING || die
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r "${CMAKE_USE_DIR}"/default || die
+
+ # bin
+ dogamesbin "${CMAKE_BUILD_DIR}"/${PN}{ca,d} || die
+ newgamesbin "${CMAKE_BUILD_DIR}"/${PN} ${PN}.bin || die
+ games_make_wrapper ${PN} \
+ "${GAMES_BINDIR}/${PN}.bin --resource-dir ./default" \
+ "${GAMES_DATADIR}/${PN}"
+
+ # config
+ insinto "${GAMES_SYSCONFDIR}"/${PN}
+ doins "${CMAKE_USE_DIR}"/{OISInput,ogre_plugins}.cfg || die
+ # game uses relative paths
+ dosym "${GAMES_SYSCONFDIR}"/${PN}/ogre_plugins.cfg \
+ "${GAMES_DATADIR}"/${PN}/ogre_plugins.cfg || die
+ dosym "${GAMES_SYSCONFDIR}"/${PN}/OISInput.cfg \
+ "${GAMES_DATADIR}"/${PN}/OISInput.cfg || die
+
+ # other
+ dodoc "${CMAKE_USE_DIR}"/changelog.txt || die
+ newicon "${CMAKE_USE_DIR}"/default/data/art/icons/FO_Icon_32x32.png \
+ ${PN}.png || die
+ make_desktop_entry ${PN} ${PN} ${PN}
+
+ # permissions
+ prepgamesdirs
+}
diff --git a/games-strategy/freeorion/metadata.xml b/games-strategy/freeorion/metadata.xml
new file mode 100644
index 000000000000..5c66c093895c
--- /dev/null
+++ b/games-strategy/freeorion/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tomka@gentoo.org</email>
+ <name>Thomas Kahle</name>
+ </maintainer>
+ <use>
+ <flag name="cg">Add support for NVIDIA toolkit plugin</flag>
+ </use>
+<longdescription lang="en">
+ FreeOrion is a free, open source, turn-based space empire and
+ galactic conquest (4X) computer game being designed and built by the
+ FreeOrion project. FreeOrion is inspired by the tradition of the
+ Master of Orion games, but is not a clone or remake of that series
+ or any other game.
+</longdescription>
+</pkgmetadata>