summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-04-27 06:38:00 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-04-27 06:38:00 +0000
commit7da476d85efd03b208fc0efcf1ebc7bc6da4a65f (patch)
tree0f3f332e2a26b4a35b9cdce9d8f8e62286c1ecec /games-strategy
parentgames-strategy/freeciv ggz use mask for archs with missing dep keywording (diff)
downloadgentoo-2-7da476d85efd03b208fc0efcf1ebc7bc6da4a65f.tar.gz
gentoo-2-7da476d85efd03b208fc0efcf1ebc7bc6da4a65f.tar.bz2
gentoo-2-7da476d85efd03b208fc0efcf1ebc7bc6da4a65f.zip
add required ggz deps (bug #317289)
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/freeciv/ChangeLog5
-rw-r--r--games-strategy/freeciv/freeciv-2.2.0.ebuild13
2 files changed, 12 insertions, 6 deletions
diff --git a/games-strategy/freeciv/ChangeLog b/games-strategy/freeciv/ChangeLog
index a706ecd67e7a..74233a36e045 100644
--- a/games-strategy/freeciv/ChangeLog
+++ b/games-strategy/freeciv/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-strategy/freeciv
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeciv/ChangeLog,v 1.102 2010/04/13 15:49:21 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeciv/ChangeLog,v 1.103 2010/04/27 06:38:00 mr_bones_ Exp $
+
+ 27 Apr 2010; Michael Sterrett <mr_bones_@gentoo.org> freeciv-2.2.0.ebuild:
+ add required ggz deps (bug #317289); drop mips due to missing keywords
13 Apr 2010; Michael Sterrett <mr_bones_@gentoo.org> freeciv-2.2.0.ebuild:
fix deps for auth support (bug #315005)
diff --git a/games-strategy/freeciv/freeciv-2.2.0.ebuild b/games-strategy/freeciv/freeciv-2.2.0.ebuild
index b76b46c74197..e222a53a87bf 100644
--- a/games-strategy/freeciv/freeciv-2.2.0.ebuild
+++ b/games-strategy/freeciv/freeciv-2.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeciv/freeciv-2.2.0.ebuild,v 1.4 2010/04/13 15:49:21 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeciv/freeciv-2.2.0.ebuild,v 1.5 2010/04/27 06:38:00 mr_bones_ Exp $
EAPI=2
inherit eutils gnome2-utils games
@@ -11,12 +11,13 @@ SRC_URI="mirror://sourceforge/freeciv/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="auth dedicated ggz gtk ipv6 nls readline sdl +sound"
RDEPEND="readline? ( sys-libs/readline )
sys-libs/zlib
app-arch/bzip2
+ dev-games/libggz
auth? ( virtual/mysql )
!dedicated? (
nls? ( virtual/libintl )
@@ -31,7 +32,7 @@ RDEPEND="readline? ( sys-libs/readline )
media-libs/libsdl[audio]
media-libs/sdl-mixer
)
- ggz? ( dev-games/ggz-client-libs )
+ ggz? ( games-board/ggz-gtk-client )
media-libs/libpng
)"
DEPEND="${RDEPEND}
@@ -61,7 +62,7 @@ src_prepare() {
}
src_configure() {
- local myclient
+ local myclient myopts
if use dedicated ; then
myclient="no"
@@ -69,17 +70,19 @@ src_configure() {
use sdl && myclient="${myclient} sdl"
use gtk && myclient="${myclient} gtk"
[[ -z ${myclient} ]] && myclient="gtk" # default to gtk if none specified
+ myopts=$(use_with ggz ggz-client)
fi
egamesconf \
--disable-dependency-tracking \
--localedir=/usr/share/locale \
+ --with-ggzconfig=/usr/bin \
$(use_enable auth) \
$(use_enable ipv6) \
$(use_enable nls) \
$(use_with readline) \
$(use_enable sound sdl-mixer) \
- $(use_with ggz ggz-client) \
+ ${myopts} \
--enable-client="${myclient}"
}