summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-10-04 14:29:16 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-10-04 14:29:16 +0000
commita7267020855c29a4e3ca1ad9218fc8ff01a142b1 (patch)
tree5a36177eee652ae6df98aaf07a4371ad25cc9a5d /games-strategy
parentAdd also the kde meta ebuild. (diff)
downloadgentoo-2-a7267020855c29a4e3ca1ad9218fc8ff01a142b1.tar.gz
gentoo-2-a7267020855c29a4e3ca1ad9218fc8ff01a142b1.tar.bz2
gentoo-2-a7267020855c29a4e3ca1ad9218fc8ff01a142b1.zip
Version bump, bug #145958
(Portage version: 2.1.2_pre2-r2)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wormux/ChangeLog8
-rw-r--r--games-strategy/wormux/files/digest-wormux-0.7.43
-rw-r--r--games-strategy/wormux/files/wormux-0.7.4-user-CFLAGS.patch13
-rw-r--r--games-strategy/wormux/wormux-0.7.4.ebuild55
4 files changed, 78 insertions, 1 deletions
diff --git a/games-strategy/wormux/ChangeLog b/games-strategy/wormux/ChangeLog
index 5d7816a4df43..ea4183e13277 100644
--- a/games-strategy/wormux/ChangeLog
+++ b/games-strategy/wormux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/wormux
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wormux/ChangeLog,v 1.15 2006/10/04 12:10:54 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wormux/ChangeLog,v 1.16 2006/10/04 14:29:16 nyhm Exp $
+
+*wormux-0.7.4 (04 Oct 2006)
+
+ 04 Oct 2006; Tristan Heaven <nyhm@gentoo.org>
+ +files/wormux-0.7.4-user-CFLAGS.patch, +wormux-0.7.4.ebuild:
+ Version bump, bug #145958
04 Oct 2006; Simon Stelling <blubb@gentoo.org> wormux-0.7.3.ebuild:
stable on amd64
diff --git a/games-strategy/wormux/files/digest-wormux-0.7.4 b/games-strategy/wormux/files/digest-wormux-0.7.4
new file mode 100644
index 000000000000..fd3bb6ad7eae
--- /dev/null
+++ b/games-strategy/wormux/files/digest-wormux-0.7.4
@@ -0,0 +1,3 @@
+MD5 271de7da072bc4e8c023f55e85a42eb0 wormux-0.7.4.tar.gz 30566963
+RMD160 7464a1be0c9281d09ae330295ba634ea3013b109 wormux-0.7.4.tar.gz 30566963
+SHA256 4dd96ab04b7152154586d1bcfc6e60956341b8551661c7f14dc86d87058fc020 wormux-0.7.4.tar.gz 30566963
diff --git a/games-strategy/wormux/files/wormux-0.7.4-user-CFLAGS.patch b/games-strategy/wormux/files/wormux-0.7.4-user-CFLAGS.patch
new file mode 100644
index 000000000000..6f865a211079
--- /dev/null
+++ b/games-strategy/wormux/files/wormux-0.7.4-user-CFLAGS.patch
@@ -0,0 +1,13 @@
+--- configure
++++ configure
+@@ -6766,9 +6766,7 @@
+ GCC_FLAGS="$GCC_FLAGS -Wno-unused-parameter"
+
+ if test "${debug}" = "yes"; then
+- GCC_FLAGS="$GCC_FLAGS -O0 -g -DDEBUG -Werror"
+- else
+- GCC_FLAGS="$GCC_FLAGS -O2"
++ GCC_FLAGS="$GCC_FLAGS -DDEBUG"
+ fi
+
+ CFLAGS="$CFLAGS $GCC_FLAGS"
diff --git a/games-strategy/wormux/wormux-0.7.4.ebuild b/games-strategy/wormux/wormux-0.7.4.ebuild
new file mode 100644
index 000000000000..b51b9313f172
--- /dev/null
+++ b/games-strategy/wormux/wormux-0.7.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wormux/wormux-0.7.4.ebuild,v 1.1 2006/10/04 14:29:16 nyhm Exp $
+
+inherit eutils debug games
+
+DESCRIPTION="A free Worms clone"
+HOMEPAGE="http://www.wormux.org/"
+SRC_URI="http://download.gna.org/wormux/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug nls"
+
+RDEPEND=">=media-libs/libsdl-1.2.6
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-ttf-2.0
+ media-libs/sdl-net
+ >=media-libs/sdl-gfx-2.0.13
+ >=dev-cpp/libxmlpp-2.6
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-user-CFLAGS.patch"
+ # avoid the strip on install
+ sed -i \
+ -e "s/@INSTALL_STRIP_PROGRAM@/@INSTALL_PROGRAM@/" \
+ src/Makefile.in \
+ || die "sed failed"
+}
+
+src_compile() {
+ egamesconf \
+ --with-datadir-name="${GAMES_DATADIR}/${PN}" \
+ --with-localedir-name="/usr/share/locale" \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README
+ newicon data/wormux-32.xpm wormux.xpm
+ make_desktop_entry wormux Wormux wormux.xpm
+ prepgamesdirs
+}