summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-08-15 21:03:02 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-08-15 21:03:02 +0000
commitc3f875a27be1a04c2afdb6827409f290ed8128ed (patch)
treeb453c5e022475f5301c77361de1c5eb6ea3eb0ce /games-strategy
parentMissing explicit sys/stat.h include for recent glibc wrt #332295 by Diego E. ... (diff)
downloadgentoo-2-c3f875a27be1a04c2afdb6827409f290ed8128ed.tar.gz
gentoo-2-c3f875a27be1a04c2afdb6827409f290ed8128ed.tar.bz2
gentoo-2-c3f875a27be1a04c2afdb6827409f290ed8128ed.zip
Missing explicit sys/stat.h include for recent glibc wrt #331667 by Diego E. Pettenò.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/glest/ChangeLog7
-rw-r--r--games-strategy/glest/files/glest-3.2.2-glibc212.patch10
-rw-r--r--games-strategy/glest/glest-3.2.2.ebuild5
3 files changed, 19 insertions, 3 deletions
diff --git a/games-strategy/glest/ChangeLog b/games-strategy/glest/ChangeLog
index 91ebf39b4d7b..26d1c97af46e 100644
--- a/games-strategy/glest/ChangeLog
+++ b/games-strategy/glest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/glest
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/glest/ChangeLog,v 1.28 2010/03/22 18:55:42 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glest/ChangeLog,v 1.29 2010/08/15 21:03:02 ssuominen Exp $
+
+ 15 Aug 2010; Samuli Suominen <ssuominen@gentoo.org> glest-3.2.2.ebuild,
+ +files/glest-3.2.2-glibc212.patch:
+ Missing explicit sys/stat.h include for recent glibc wrt #331667 by Diego
+ E. Pettenò.
22 Mar 2010; Michael Sterrett <mr_bones_@gentoo.org> glest-3.2.2.ebuild:
clean up install and install tutorial (bug #285680)
diff --git a/games-strategy/glest/files/glest-3.2.2-glibc212.patch b/games-strategy/glest/files/glest-3.2.2-glibc212.patch
new file mode 100644
index 000000000000..cc7f99825104
--- /dev/null
+++ b/games-strategy/glest/files/glest-3.2.2-glibc212.patch
@@ -0,0 +1,10 @@
+--- glest_game/main/main.cpp
++++ glest_game/main/main.cpp
+@@ -13,6 +13,7 @@
+
+ #include <string>
+ #include <cstdlib>
++#include <sys/stat.h>
+
+ #include "game.h"
+ #include "main_menu.h"
diff --git a/games-strategy/glest/glest-3.2.2.ebuild b/games-strategy/glest/glest-3.2.2.ebuild
index 75f09cfd17a6..1717f4bc8062 100644
--- a/games-strategy/glest/glest-3.2.2.ebuild
+++ b/games-strategy/glest/glest-3.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/glest/glest-3.2.2.ebuild,v 1.8 2010/03/22 18:58:17 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glest/glest-3.2.2.ebuild,v 1.9 2010/08/15 21:03:02 ssuominen Exp $
EAPI=2
inherit eutils wxwidgets games
@@ -36,7 +36,8 @@ src_prepare() {
epatch \
"${FILESDIR}"/${P}-gentoo.patch \
"${FILESDIR}"/${P}-xerces-c.patch \
- "${FILESDIR}"/${P}-glibc210.patch
+ "${FILESDIR}"/${P}-glibc210.patch \
+ "${FILESDIR}"/${P}-glibc212.patch
sed -i \
-e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \