summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-11-19 23:08:31 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-11-19 23:08:31 +0000
commite654da1d3aa8c915e21fc5aec8d043b1db1b6c4c (patch)
tree01b91c36bf48569f14ba0d2edca07f4045e1eb31 /games-strategy
parentVersion bump with bugfixes and translation updates. Stop compiling tests and ... (diff)
downloadgentoo-2-e654da1d3aa8c915e21fc5aec8d043b1db1b6c4c.tar.gz
gentoo-2-e654da1d3aa8c915e21fc5aec8d043b1db1b6c4c.tar.bz2
gentoo-2-e654da1d3aa8c915e21fc5aec8d043b1db1b6c4c.zip
use scons-utils; honor CXX
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/glob2/ChangeLog6
-rw-r--r--games-strategy/glob2/files/glob2-0.9.4.4-scons-blows.patch26
-rw-r--r--games-strategy/glob2/glob2-0.9.4.4.ebuild20
3 files changed, 37 insertions, 15 deletions
diff --git a/games-strategy/glob2/ChangeLog b/games-strategy/glob2/ChangeLog
index ff3b2968de64..710a9cda22a3 100644
--- a/games-strategy/glob2/ChangeLog
+++ b/games-strategy/glob2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/glob2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/ChangeLog,v 1.52 2010/09/11 20:37:55 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/ChangeLog,v 1.53 2010/11/19 23:08:31 mr_bones_ Exp $
+
+ 19 Nov 2010; Michael Sterrett <mr_bones_@gentoo.org> glob2-0.9.4.4.ebuild,
+ +files/glob2-0.9.4.4-scons-blows.patch:
+ use scons-utils; honor CXX
11 Sep 2010; Michael Sterrett <mr_bones_@gentoo.org> glob2-0.9.4.4.ebuild:
update sdl-image dep for bug #336791
diff --git a/games-strategy/glob2/files/glob2-0.9.4.4-scons-blows.patch b/games-strategy/glob2/files/glob2-0.9.4.4-scons-blows.patch
new file mode 100644
index 000000000000..e8aa31d84d94
--- /dev/null
+++ b/games-strategy/glob2/files/glob2-0.9.4.4-scons-blows.patch
@@ -0,0 +1,26 @@
+--- SConstruct.orig 2010-11-19 17:56:30.206360948 -0500
++++ SConstruct 2010-11-19 17:58:48.914746243 -0500
+@@ -1,6 +1,7 @@
+ EnsureSConsVersion(0, 96, 92)
+ import sys
+ import os
++import SCons.Util
+ import glob
+ sys.path.append( os.path.abspath("scons") )
+ import bundle
+@@ -268,6 +269,15 @@
+ env["TARFILE"] = env.Dir("#").abspath + "/glob2-" + env["VERSION"] + ".tar.gz"
+ env["TARFLAGS"] = "-c -z"
+ env.Alias("dist", env["TARFILE"])
++ # Using suggestions for http://dev.gentoo.org/~vapier/scons-blows.txt
++ if os.environ.has_key('CC'):
++ env['CC'] = os.environ['CC']
++ if os.environ.has_key('CXX'):
++ env['CXX'] = os.environ['CXX']
++ if os.environ.has_key('CXXFLAGS'):
++ env['CXXFLAGS'] += SCons.Util.CLVar(os.environ['CXXFLAGS'])
++ if os.environ.has_key('LDFLAGS'):
++ env['LINKFLAGS'] += SCons.Util.CLVar(os.environ['LDFLAGS'])
+
+ def PackTar(target, source):
+ if "dist" in COMMAND_LINE_TARGETS:
diff --git a/games-strategy/glob2/glob2-0.9.4.4.ebuild b/games-strategy/glob2/glob2-0.9.4.4.ebuild
index 42a8d13b6a69..c62dc4d8cf6e 100644
--- a/games-strategy/glob2/glob2-0.9.4.4.ebuild
+++ b/games-strategy/glob2/glob2-0.9.4.4.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/glob2-0.9.4.4.ebuild,v 1.4 2010/09/11 20:37:55 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/glob2-0.9.4.4.ebuild,v 1.5 2010/11/19 23:08:31 mr_bones_ Exp $
EAPI=2
-inherit eutils games
+inherit eutils scons-utils games
DESCRIPTION="Real Time Strategy (RTS) game involving a brave army of globs"
HOMEPAGE="http://globulation2.org/"
@@ -14,7 +14,7 @@ SLOT="0"
KEYWORDS="~amd64 ~hppa ppc x86"
IUSE=""
-RDEPEND="virtual/opengl
+DEPEND="virtual/opengl
virtual/glu
>=dev-libs/boost-1.34
media-libs/libsdl[opengl]
@@ -24,21 +24,13 @@ RDEPEND="virtual/opengl
media-libs/libvorbis
dev-libs/fribidi
media-libs/speex"
-DEPEND="${RDEPEND}
- >=dev-util/scons-1"
-PATCHES=( "${FILESDIR}"/${P}-gcc44.patch )
+PATCHES=( "${FILESDIR}"/${P}-gcc44.patch "${FILESDIR}"/${P}-scons-blows.patch )
src_compile() {
- local sconsopts=$(echo "${MAKEOPTS}" | sed -ne "/-j/ { s/.*\(-j[:space:]*[0-9]\+\).*/\1/; p }")
-
- scons \
- ${sconsopts} \
- CXXFLAGS="${CXXFLAGS}" \
- LINKFLAGS="${LDFLAGS}" \
+ escons \
INSTALLDIR="${GAMES_DATADIR}"/${PN} \
- DATADIR="${GAMES_DATADIR}"/${PN} \
- || die "scons failed again"
+ DATADIR="${GAMES_DATADIR}"/${PN}
}
src_install() {