summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2013-09-16 18:20:55 +0000
committerThomas Kahle <tomka@gentoo.org>2013-09-16 18:20:55 +0000
commited2cf2cf7dd978bad30ec1b2fb9f8e3585879935 (patch)
tree788b1371e88e9e7c94f3e80a22a8a52bf820a6b7 /games-strategy
parentDeprecate python_get_PYTHON and python_get_EPYTHON. (diff)
downloadgentoo-2-ed2cf2cf7dd978bad30ec1b2fb9f8e3585879935.tar.gz
gentoo-2-ed2cf2cf7dd978bad30ec1b2fb9f8e3585879935.tar.bz2
gentoo-2-ed2cf2cf7dd978bad30ec1b2fb9f8e3585879935.zip
bump to 0.4.3, remove old
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key 0x89DEB219565C32BC!)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/freeorion/ChangeLog8
-rw-r--r--games-strategy/freeorion/freeorion-0.4.3.ebuild (renamed from games-strategy/freeorion/freeorion-0.4.2_pre20121225.ebuild)36
2 files changed, 27 insertions, 17 deletions
diff --git a/games-strategy/freeorion/ChangeLog b/games-strategy/freeorion/ChangeLog
index 91bab0684e6b..1dfb3899ca4c 100644
--- a/games-strategy/freeorion/ChangeLog
+++ b/games-strategy/freeorion/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/freeorion
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeorion/ChangeLog,v 1.5 2013/03/12 16:59:50 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeorion/ChangeLog,v 1.6 2013/09/16 18:20:55 tomka Exp $
+
+*freeorion-0.4.3 (16 Sep 2013)
+
+ 16 Sep 2013; Thomas Kahle <tomka@gentoo.org> +freeorion-0.4.3.ebuild,
+ -freeorion-0.4.2_pre20121225.ebuild:
+ bump to 0.4.3, remove old
*freeorion-0.4.3_pre20130312 (12 Mar 2013)
diff --git a/games-strategy/freeorion/freeorion-0.4.2_pre20121225.ebuild b/games-strategy/freeorion/freeorion-0.4.3.ebuild
index b8ecd54004c2..1b0130f9335f 100644
--- a/games-strategy/freeorion/freeorion-0.4.2_pre20121225.ebuild
+++ b/games-strategy/freeorion/freeorion-0.4.3.ebuild
@@ -1,28 +1,27 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeorion/freeorion-0.4.2_pre20121225.ebuild,v 1.2 2013/02/07 22:17:01 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeorion/freeorion-0.4.3.ebuild,v 1.1 2013/09/16 18:20:55 tomka Exp $
-EAPI=4
+EAPI=5
-PYTHON_DEPEND="2"
-
-inherit cmake-utils python games
+PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
+inherit cmake-utils python-any-r1 games
myPN="FreeOrion"
DESCRIPTION="A free turn-based space empire and galactic conquest game"
HOMEPAGE="http://www.freeorion.org"
-SRC_URI="http://dev.gentoo.org/~tomka/files/FreeOrion-${PV}.tar.gz"
+SRC_URI="http://dev.gentoo.org/~tomka/files/${P}.tar.bz2"
LICENSE="GPL-2 CC-BY-SA-3.0"
SLOT="0"
KEYWORDS="~amd64"
IUSE="cg"
-# Needs a dev-games/gigi from the freeorion source directory.
-# It's safest to use the same version.
+# Needs it's own version of GG(dev-games/gigi) which it ships.
+# The split version dev-games/gigi is not used anymore as of 0.4.3
RDEPEND="
- dev-games/gigi[ogre,ois]
+ !dev-games/gigi
dev-games/ogre[cg?,opengl]
>=dev-libs/boost-1.47[python]
media-libs/freealut
@@ -34,24 +33,24 @@ RDEPEND="
sys-libs/zlib
virtual/opengl"
DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
virtual/pkgconfig"
-S="${WORKDIR}/${myPN}"
+S="${WORKDIR}/${P}/${myPN}"
CMAKE_USE_DIR="${S}"
CMAKE_VERBOSE="1"
pkg_setup() {
# build system is using FindPythonLibs.cmake which needs python:2
- python_set_active_version 2
- python_pkg_setup
+ python-any-r1_pkg_setup
games_pkg_setup
}
src_prepare() {
# set OGRE plugin-dir
sed \
- -e "s:PluginFolder=.:PluginFolder=$(pkg-config --variable=plugindir OGRE):" \
- -i "${CMAKE_USE_DIR}"/ogre_plugins.cfg || die
+ -e "s:PluginFolder=.*$:PluginFolder=$(pkg-config --variable=plugindir OGRE):" \
+ -i "${CMAKE_USE_DIR}"/ogre_plugins.cfg.in || die
if use cg ; then
# add cg ogre plugin to config
@@ -60,7 +59,7 @@ src_prepare() {
fi
# set revision for display in game -- update on bump!
- sed -i -e 's/???/5576/' CMakeLists.txt
+ sed -i -e 's/???/6281/' CMakeLists.txt
}
src_configure() {
@@ -88,9 +87,14 @@ src_install() {
"${GAMES_BINDIR}/${PN}.bin --resource-dir ./default" \
"${GAMES_DATADIR}/${PN}"
+ # lib
+ dogameslib "${CMAKE_BUILD_DIR}"/libfreeorion{common,parse}.so || die
+ dogameslib "${CMAKE_BUILD_DIR}"/libGiGi*.so || die
+
# config
insinto "${GAMES_SYSCONFDIR}"/${PN}
- doins "${CMAKE_USE_DIR}"/{OISInput,ogre_plugins}.cfg || die
+ doins "${CMAKE_BUILD_DIR}"/ogre_plugins.cfg || die
+ doins "${CMAKE_USE_DIR}"/OISInput.cfg || die
# game uses relative paths
dosym "${GAMES_SYSCONFDIR}"/${PN}/ogre_plugins.cfg \
"${GAMES_DATADIR}"/${PN}/ogre_plugins.cfg || die