summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-08-12 16:56:49 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-08-12 16:56:49 +0000
commit63a01a624ede4a43b3ebe91f8289a6cc438ac6d4 (patch)
treed2e3cad67eca8a06e029fa3cd4229ed277f2edc6 /games-util/joystick
parentRemoved old unused flag (diff)
downloadgentoo-2-63a01a624ede4a43b3ebe91f8289a6cc438ac6d4.tar.gz
gentoo-2-63a01a624ede4a43b3ebe91f8289a6cc438ac6d4.tar.bz2
gentoo-2-63a01a624ede4a43b3ebe91f8289a6cc438ac6d4.zip
Add libsdl use dep; respect LDFLAGS (bug #332459)
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-util/joystick')
-rw-r--r--games-util/joystick/ChangeLog8
-rw-r--r--games-util/joystick/files/joystick-20060731-asneeded.patch4
-rw-r--r--games-util/joystick/joystick-20060731.ebuild6
3 files changed, 11 insertions, 7 deletions
diff --git a/games-util/joystick/ChangeLog b/games-util/joystick/ChangeLog
index b7169527e9ef..8d10f1f28d45 100644
--- a/games-util/joystick/ChangeLog
+++ b/games-util/joystick/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-util/joystick
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/ChangeLog,v 1.8 2009/12/21 15:47:29 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/ChangeLog,v 1.9 2010/08/12 16:56:49 mr_bones_ Exp $
+
+ 12 Aug 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ joystick-20060731.ebuild, files/joystick-20060731-asneeded.patch:
+ Add libsdl use dep; respect LDFLAGS (bug #332459)
21 Dec 2009; Samuli Suominen <ssuominen@gentoo.org>
joystick-20060731.ebuild, +files/joystick-20060731-asneeded.patch:
diff --git a/games-util/joystick/files/joystick-20060731-asneeded.patch b/games-util/joystick/files/joystick-20060731-asneeded.patch
index 3bfe30f01ea2..d9bbc07240ae 100644
--- a/games-util/joystick/files/joystick-20060731-asneeded.patch
+++ b/games-util/joystick/files/joystick-20060731-asneeded.patch
@@ -5,7 +5,7 @@
ffcfstress: ffcfstress.c
$(CC) $(CFLAGS) -funsigned-char \
- -lm ffcfstress.c -o ffcfstress
-+ ffcfstress.c -o ffcfstress -lm
++ ffcfstress.c -o ffcfstress $(LDFLAGS) -lm
ffmvforce.o: ffmvforce.c
$(CC) -c $(CFLAGS) $(CPPFLAGS) $^ -o $@ `sdl-config --cflags`
@@ -14,7 +14,7 @@
jscal: jscal.o
- $(CC) $(CFLAGS) $(CPPFLAGS) -lm $^ -o $@
-+ $(CC) $(CFLAGS) $(CPPFLAGS) $^ -o $@ -lm
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $^ -o $@ -lm
gencodes: gencodes.c scancodes.h
$(CC) $(CFLAGS) $(CPPFLAGS) gencodes.c -o gencodes
diff --git a/games-util/joystick/joystick-20060731.ebuild b/games-util/joystick/joystick-20060731.ebuild
index 1649235b761d..b0b5c41a1abc 100644
--- a/games-util/joystick/joystick-20060731.ebuild
+++ b/games-util/joystick/joystick-20060731.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/joystick-20060731.ebuild,v 1.6 2009/12/21 15:47:29 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/joystick-20060731.ebuild,v 1.7 2010/08/12 16:56:49 mr_bones_ Exp $
EAPI=2
inherit eutils toolchain-funcs
@@ -14,7 +14,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
IUSE="sdl"
-DEPEND="sdl? ( media-libs/libsdl )
+DEPEND="sdl? ( media-libs/libsdl[video] )
!x11-libs/tslib"
S=${WORKDIR}/utils