summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-30 18:33:25 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-30 18:33:25 +0000
commit131a8a1dc3ee74b16cda2f832691a43759f6a960 (patch)
tree96ef3da0106d91a4c746ad5be84e95e5c126d653 /games-util
parentAdd ~arm keyword, tested by Anton Romanov, reported in bug #392323. (diff)
downloadgentoo-2-131a8a1dc3ee74b16cda2f832691a43759f6a960.tar.gz
gentoo-2-131a8a1dc3ee74b16cda2f832691a43759f6a960.tar.bz2
gentoo-2-131a8a1dc3ee74b16cda2f832691a43759f6a960.zip
Bump. Adds support for Crucible expansion, fleet boosting, wormhole effects.
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/pyfa/ChangeLog8
-rw-r--r--games-util/pyfa/files/pyfa-1.1-staticPath.patch27
-rw-r--r--games-util/pyfa/pyfa-1.1.ebuild70
3 files changed, 104 insertions, 1 deletions
diff --git a/games-util/pyfa/ChangeLog b/games-util/pyfa/ChangeLog
index 1eb4bf94a37b..470d140c906c 100644
--- a/games-util/pyfa/ChangeLog
+++ b/games-util/pyfa/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-util/pyfa
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/pyfa/ChangeLog,v 1.1 2011/11/02 23:59:34 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/pyfa/ChangeLog,v 1.2 2011/11/30 18:33:25 tetromino Exp $
+
+*pyfa-1.1 (30 Nov 2011)
+
+ 30 Nov 2011; Alexandre Rostovtsev <tetromino@gentoo.org> +pyfa-1.1.ebuild,
+ +files/pyfa-1.1-staticPath.patch:
+ Bump. Adds support for Crucible expansion, fleet boosting, wormhole effects.
*pyfa-1.0.6 (02 Nov 2011)
diff --git a/games-util/pyfa/files/pyfa-1.1-staticPath.patch b/games-util/pyfa/files/pyfa-1.1-staticPath.patch
new file mode 100644
index 000000000000..d477f9c94d7f
--- /dev/null
+++ b/games-util/pyfa/files/pyfa-1.1-staticPath.patch
@@ -0,0 +1,27 @@
+From 9a8411e9a6c58e5285ab3ae0a4feed05b6107acf Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Wed, 30 Nov 2011 12:50:53 -0500
+Subject: [PATCH] Make staticPath settable from configforced
+
+---
+ config.py | 4 +++-
+ 1 files changed, 3 insertions(+), 1 deletions(-)
+
+diff --git a/config.py b/config.py
+index f2844b5..1f51700 100644
+--- a/config.py
++++ b/config.py
+@@ -48,7 +48,9 @@ def defPaths():
+ savePath = unicode(os.path.expanduser(os.path.join("~", ".pyfa")), sys.getfilesystemencoding())
+
+ # Static EVE Data from the staticdata repository, should be in the staticdata directory in our pyfa directory
+- staticPath = os.path.join(pyfaPath, "staticdata")
++ staticPath = getattr(configforced, "staticPath", None)
++ if staticPath is None:
++ staticPath = os.path.join(pyfaPath, "staticdata")
+
+ # The database where we store all the fits etc
+ saveDB = os.path.join(savePath, "saveddata.db")
+--
+1.7.8.rc3
+
diff --git a/games-util/pyfa/pyfa-1.1.ebuild b/games-util/pyfa/pyfa-1.1.ebuild
new file mode 100644
index 000000000000..d89ed0fe65c1
--- /dev/null
+++ b/games-util/pyfa/pyfa-1.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/pyfa/pyfa-1.1.ebuild,v 1.1 2011/11/30 18:33:25 tetromino Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2:2.6"
+PYTHON_USE_WITH="sqlite threads"
+
+inherit eutils python
+
+if [[ ${PV/_rc*/} == ${PV} ]] ; then
+ MY_PV=${PV}-crucible-src
+ FOLDER=stable/${PV}
+else
+ MY_PV=${PV/_rc/-stable-RC}-src
+ FOLDER=stable/${PV/*_rc/RC}
+fi
+
+DESCRIPTION="Python Fitting Assistant - a ship fitting application for EVE Online"
+HOMEPAGE="http://www.evefit.org/Pyfa"
+SRC_URI="http://dl.evefit.org/${FOLDER}/${PN}-${MY_PV}.tar.bz2"
+
+LICENSE="GPL-3 LGPL-2.1 CCPL-Attribution-2.5 free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+graph"
+
+RDEPEND="dev-python/sqlalchemy
+ >=dev-python/wxpython-2.8
+ graph? ( dev-python/matplotlib[wxwidgets] dev-python/numpy )"
+DEPEND=""
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # make staticPath settable from configforced again
+ epatch "${FILESDIR}/${PN}-1.1-staticPath.patch"
+
+ python_convert_shebangs -r -x 2 .
+ sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
+ -e "s:%%EPREFIX%%:${EPREFIX}:" \
+ "${FILESDIR}/configforced.py" > configforced.py
+}
+
+src_install() {
+ local packagedir=$(python_get_sitedir)/${PN}
+ insinto "${packagedir}"
+ doins -r eos gui icons service config*.py info.py gpl.txt
+ exeinto "${packagedir}"
+ doexe ${PN}.py
+ dosym "${packagedir}/${PN}.py" /usr/bin/${PN}
+ insinto /usr/share/${PN}
+ doins -r staticdata
+ dodoc readme.txt
+ doicon icons/${PN}.png
+ domenu "${FILESDIR}/${PN}.desktop"
+}
+
+pkg_postinst() {
+ python_mod_optimize ${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${PN}
+}