summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-11-01 19:53:37 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-11-01 19:53:37 +0000
commit3e550c1813a2b8cc0033bcccda369d85a22ae830 (patch)
tree5b56d475e9097b78bc283669dda0018fbbf0f253 /games-util
parentRemove minimal USE flag and add einfo for the utilities that were pulled in a... (diff)
downloadgentoo-2-3e550c1813a2b8cc0033bcccda369d85a22ae830.tar.gz
gentoo-2-3e550c1813a2b8cc0033bcccda369d85a22ae830.tar.bz2
gentoo-2-3e550c1813a2b8cc0033bcccda369d85a22ae830.zip
version bump
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/nml/ChangeLog8
-rw-r--r--games-util/nml/nml-0.2.4.ebuild32
2 files changed, 38 insertions, 2 deletions
diff --git a/games-util/nml/ChangeLog b/games-util/nml/ChangeLog
index cb0cd26e94ef..b3eed9bf512d 100644
--- a/games-util/nml/ChangeLog
+++ b/games-util/nml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-util/nml
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/nml/ChangeLog,v 1.7 2012/06/27 17:41:22 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/nml/ChangeLog,v 1.8 2012/11/01 19:53:37 mr_bones_ Exp $
+
+*nml-0.2.4 (01 Nov 2012)
+
+ 01 Nov 2012; Michael Sterrett <mr_bones_@gentoo.org> +nml-0.2.4.ebuild:
+ version bump
27 Jun 2012; Markus Meier <maekke@gentoo.org> nml-0.2.3.ebuild:
add ~arm, bug #412329
@@ -26,4 +31,3 @@
17 Apr 2012; Tomáš Chvátal <scarabeus@gentoo.org> +metadata.xml,
+nml-0.2.3.ebuild:
Initial commit for new tool used to build OpenGFX files used by OpenTTD.
-
diff --git a/games-util/nml/nml-0.2.4.ebuild b/games-util/nml/nml-0.2.4.ebuild
new file mode 100644
index 000000000000..b17586c3793e
--- /dev/null
+++ b/games-util/nml/nml-0.2.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/nml/nml-0.2.4.ebuild,v 1.1 2012/11/01 19:53:37 mr_bones_ Exp $
+
+EAPI=4
+PYTHON_DEPEND="2:2.5"
+inherit distutils
+
+DESCRIPTION="Compiler of NML files into grf/nfo files"
+HOMEPAGE="http://dev.openttdcoop.org/projects/nml"
+SRC_URI="http://bundles.openttdcoop.org/nml/releases/${PV}/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-python/imaging
+ dev-python/ply"
+DEPEND=${RDEPEND}
+
+DOCS="docs/changelog.txt docs/readme.txt"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ distutils_src_install
+ doman docs/nmlc.1
+}