summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-02-13 16:31:56 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-02-13 16:31:56 +0000
commit7d4cc0b23b7f4e94369d77cf16743f53ede57d90 (patch)
treec7bb623b7c92533e58d096c3e02136672ea9902e /games-util
parentStable for ppc64, wrt bug #456544 (diff)
downloadgentoo-2-7d4cc0b23b7f4e94369d77cf16743f53ede57d90.tar.gz
gentoo-2-7d4cc0b23b7f4e94369d77cf16743f53ede57d90.tar.bz2
gentoo-2-7d4cc0b23b7f4e94369d77cf16743f53ede57d90.zip
tidy
(Portage version: 2.1.11.50/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/xboxdrv/ChangeLog7
-rw-r--r--games-util/xboxdrv/files/xboxdrv-0.8.4-libusbx-1.0.13-fix.patch18
-rw-r--r--games-util/xboxdrv/xboxdrv-0.8.4-r1.ebuild6
3 files changed, 8 insertions, 23 deletions
diff --git a/games-util/xboxdrv/ChangeLog b/games-util/xboxdrv/ChangeLog
index c0d991cec70f..237097b2a48a 100644
--- a/games-util/xboxdrv/ChangeLog
+++ b/games-util/xboxdrv/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-util/xboxdrv
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/xboxdrv/ChangeLog,v 1.27 2013/01/09 14:19:22 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/xboxdrv/ChangeLog,v 1.28 2013/02/13 16:31:55 mr_bones_ Exp $
+
+ 13 Feb 2013; Michael Sterrett <mr_bones_@gentoo.org>
+ files/xboxdrv-0.8.4-libusbx-1.0.13-fix.patch, xboxdrv-0.8.4-r1.ebuild:
+ tidy
*xboxdrv-0.8.4-r1 (09 Jan 2013)
@@ -114,4 +118,3 @@
04 Mar 2010; Tristan Heaven <nyhm@gentoo.org> +xboxdrv-0.4.10.ebuild,
+files/xboxdrv-0.4.10-build.patch, +metadata.xml:
Initial commit, based on Frittella Laurento's ebuild from bug #279652
-
diff --git a/games-util/xboxdrv/files/xboxdrv-0.8.4-libusbx-1.0.13-fix.patch b/games-util/xboxdrv/files/xboxdrv-0.8.4-libusbx-1.0.13-fix.patch
index 6da7e7dab5d2..5b8d2f453ede 100644
--- a/games-util/xboxdrv/files/xboxdrv-0.8.4-libusbx-1.0.13-fix.patch
+++ b/games-util/xboxdrv/files/xboxdrv-0.8.4-libusbx-1.0.13-fix.patch
@@ -6,8 +6,6 @@ Date: Wed Dec 19 11:39:31 2012 +0100
Fixes #28
-diff --git a/src/firestorm_dual_controller.cpp b/src/firestorm_dual_controller.cpp
-index 675949c..5255b9b 100644
--- a/src/firestorm_dual_controller.cpp
+++ b/src/firestorm_dual_controller.cpp
@@ -99,8 +99,6 @@ FirestormDualController::FirestormDualController(libusb_device* dev, bool is_vsb
@@ -19,8 +17,6 @@ index 675949c..5255b9b 100644
}
void
-diff --git a/src/generic_usb_controller.cpp b/src/generic_usb_controller.cpp
-index 1c5ce31..b8ad696 100644
--- a/src/generic_usb_controller.cpp
+++ b/src/generic_usb_controller.cpp
@@ -62,8 +62,6 @@ GenericUSBController::GenericUSBController(libusb_device* dev,
@@ -32,8 +28,6 @@ index 1c5ce31..b8ad696 100644
}
void
-diff --git a/src/playstation3_usb_controller.cpp b/src/playstation3_usb_controller.cpp
-index 86b5c72..676ebf9 100644
--- a/src/playstation3_usb_controller.cpp
+++ b/src/playstation3_usb_controller.cpp
@@ -37,8 +37,6 @@ Playstation3USBController::Playstation3USBController(libusb_device* dev, bool tr
@@ -45,8 +39,6 @@ index 86b5c72..676ebf9 100644
}
#define HID_GET_REPORT 0x01
-diff --git a/src/saitek_p2500_controller.cpp b/src/saitek_p2500_controller.cpp
-index a3be21b..4734776 100644
--- a/src/saitek_p2500_controller.cpp
+++ b/src/saitek_p2500_controller.cpp
@@ -66,8 +66,6 @@ SaitekP2500Controller::SaitekP2500Controller(libusb_device* dev, bool try_detach
@@ -58,8 +50,6 @@ index a3be21b..4734776 100644
}
void
-diff --git a/src/usb_controller.cpp b/src/usb_controller.cpp
-index 828b3b6..6c9c5e4 100644
--- a/src/usb_controller.cpp
+++ b/src/usb_controller.cpp
@@ -28,7 +28,8 @@
@@ -284,8 +274,6 @@ index 828b3b6..6c9c5e4 100644
int
USBController::usb_find_ep(int direction, uint8_t if_class, uint8_t if_subclass, uint8_t if_protocol)
{
-diff --git a/src/usb_controller.hpp b/src/usb_controller.hpp
-index 726e9c2..f808be3 100644
--- a/src/usb_controller.hpp
+++ b/src/usb_controller.hpp
@@ -22,6 +22,7 @@
@@ -317,8 +305,6 @@ index 726e9c2..f808be3 100644
void usb_write(int endpoint, uint8_t* data, int len);
void usb_control(uint8_t bmRequestType, uint8_t bRequest,
-diff --git a/src/xbox360_controller.cpp b/src/xbox360_controller.cpp
-index 818b61f..dfae576 100644
--- a/src/xbox360_controller.cpp
+++ b/src/xbox360_controller.cpp
@@ -86,8 +86,6 @@ Xbox360Controller::Xbox360Controller(libusb_device* dev,
@@ -330,8 +316,6 @@ index 818b61f..dfae576 100644
}
void
-diff --git a/src/xbox360_wireless_controller.cpp b/src/xbox360_wireless_controller.cpp
-index 5b24db3..4e7ea1f 100644
--- a/src/xbox360_wireless_controller.cpp
+++ b/src/xbox360_wireless_controller.cpp
@@ -50,8 +50,6 @@ Xbox360WirelessController::Xbox360WirelessController(libusb_device* dev, int con
@@ -343,8 +327,6 @@ index 5b24db3..4e7ea1f 100644
}
void
-diff --git a/src/xbox_controller.cpp b/src/xbox_controller.cpp
-index afa5bd2..8e72353 100644
--- a/src/xbox_controller.cpp
+++ b/src/xbox_controller.cpp
@@ -41,8 +41,6 @@ XboxController::XboxController(libusb_device* dev, bool try_detach) :
diff --git a/games-util/xboxdrv/xboxdrv-0.8.4-r1.ebuild b/games-util/xboxdrv/xboxdrv-0.8.4-r1.ebuild
index cabeb58a8b3c..aed831082081 100644
--- a/games-util/xboxdrv/xboxdrv-0.8.4-r1.ebuild
+++ b/games-util/xboxdrv/xboxdrv-0.8.4-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/xboxdrv/xboxdrv-0.8.4-r1.ebuild,v 1.1 2013/01/09 14:19:22 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/xboxdrv/xboxdrv-0.8.4-r1.ebuild,v 1.2 2013/02/13 16:31:55 mr_bones_ Exp $
EAPI=5
inherit base linux-info scons-utils toolchain-funcs
-MY_P="${PN}-linux-${PV}"
+MY_P=${PN}-linux-${PV}
DESCRIPTION="Userspace Xbox 360 Controller driver"
HOMEPAGE="http://pingus.seul.org/~grumbel/xboxdrv/"
SRC_URI="http://pingus.seul.org/~grumbel/xboxdrv/${MY_P}.tar.bz2"
@@ -24,7 +24,7 @@ RDEPEND="dev-libs/boost
DEPEND="${RDEPEND}
virtual/pkgconfig"
-S="${WORKDIR}/${MY_P}"
+S=${WORKDIR}/${MY_P}
CONFIG_CHECK="~INPUT_EVDEV ~INPUT_JOYDEV ~INPUT_UINPUT ~!JOYSTICK_XPAD"