summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2011-10-16 03:26:02 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2011-10-16 03:26:02 +0000
commita5f788d6ba1346ecbf83435f890a243ba4080c8e (patch)
tree7f210e13fe48479c17673b4cbb97efe00a73c60b /games-util
parentVersion bump, bug 379617. Take over maintenance. (diff)
downloadgentoo-2-a5f788d6ba1346ecbf83435f890a243ba4080c8e.tar.gz
gentoo-2-a5f788d6ba1346ecbf83435f890a243ba4080c8e.tar.bz2
gentoo-2-a5f788d6ba1346ecbf83435f890a243ba4080c8e.zip
Bump new revision to get flightgear-2.4.0 support. Take over.
(Portage version: 2.2.0_alpha67/cvs/Linux x86_64)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/atlas/ChangeLog9
-rw-r--r--games-util/atlas/atlas-0.3.1_p20101101-r1.ebuild82
-rw-r--r--games-util/atlas/files/atlas-0.3.1_p20101101-simgear-2.4.0.patch12
-rw-r--r--games-util/atlas/metadata.xml4
4 files changed, 106 insertions, 1 deletions
diff --git a/games-util/atlas/ChangeLog b/games-util/atlas/ChangeLog
index 0ffdb17edf73..4105fd73e971 100644
--- a/games-util/atlas/ChangeLog
+++ b/games-util/atlas/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-util/atlas
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/ChangeLog,v 1.27 2011/10/08 17:03:37 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/ChangeLog,v 1.28 2011/10/16 03:26:02 reavertm Exp $
+
+*atlas-0.3.1_p20101101-r1 (16 Oct 2011)
+
+ 16 Oct 2011; Maciej Mrozowski <reavertm@gentoo.org>
+ +atlas-0.3.1_p20101101-r1.ebuild,
+ +files/atlas-0.3.1_p20101101-simgear-2.4.0.patch, metadata.xml:
+ Bump new revision to get flightgear-2.4.0 support. Take over.
08 Oct 2011; Samuli Suominen <ssuominen@gentoo.org>
-atlas-0.3.1_p20100302.ebuild:
diff --git a/games-util/atlas/atlas-0.3.1_p20101101-r1.ebuild b/games-util/atlas/atlas-0.3.1_p20101101-r1.ebuild
new file mode 100644
index 000000000000..d3dca7a39327
--- /dev/null
+++ b/games-util/atlas/atlas-0.3.1_p20101101-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/atlas-0.3.1_p20101101-r1.ebuild,v 1.1 2011/10/16 03:26:02 reavertm Exp $
+
+EAPI=3
+inherit autotools eutils games
+
+DESCRIPTION="Chart Program to use with Flightgear Flight Simulator"
+HOMEPAGE="http://atlas.sourceforge.net/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ media-libs/freeglut
+ >=media-libs/libpng-1.4
+ net-misc/curl
+ virtual/glu
+ virtual/jpeg
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXt
+ x11-libs/libXmu
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-games/simgear-2.4.0
+ media-libs/plib
+"
+RDEPEND="${COMMON_DEPEND}
+ >=games-simulation/flightgear-2.4.0
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libpng15.patch
+ epatch "${FILESDIR}"/${P}-simgear-2.4.0.patch
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-fgbase="${GAMES_DATADIR}"/flightgear
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ insinto "${GAMES_DATADIR}"/flightgear/Atlas
+ doins src/data/*.{jpg,png} || die
+ insinto "${GAMES_DATADIR}"/flightgear/Atlas/Palettes
+ doins src/data/Palettes/*.ap || die
+ insinto "${GAMES_DATADIR}"/flightgear/Atlas/Fonts
+ doins src/data/Fonts/*.txf || die
+ dodoc AUTHORS NEWS README
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "You now can make the maps with the following commands:"
+ elog "${GAMES_BINDIR}/Map --atlas=${GAMES_DATADIR}/flightgear/Atlas"
+ elog
+ elog "To run Atlas concurrently with FlightGear use the following:"
+ elog "Atlas --path=[path of map images] --udp=[port number]"
+ elog "and start fgfs with the following switch (or in .fgfsrc):"
+ elog "--nmea=socket,out,0.5,[host that you run Atlas on],[port number],udp"
+ echo
+}
+
+pkg_postrm() {
+ elog "You must manually remove the maps if you don't want them around."
+ elog "They are found in the following directory:"
+ echo
+ elog "${GAMES_DATADIR}/flightgear/Atlas"
+ echo
+}
diff --git a/games-util/atlas/files/atlas-0.3.1_p20101101-simgear-2.4.0.patch b/games-util/atlas/files/atlas-0.3.1_p20101101-simgear-2.4.0.patch
new file mode 100644
index 000000000000..4b8b548d150c
--- /dev/null
+++ b/games-util/atlas/files/atlas-0.3.1_p20101101-simgear-2.4.0.patch
@@ -0,0 +1,12 @@
+diff -ruN atlas-0.3.1_p20101101/src/Subbucket.cxx my/src/Subbucket.cxx
+--- atlas-0.3.1_p20101101/src/Subbucket.cxx 2010-04-26 23:15:29.000000000 +0200
++++ my/src/Subbucket.cxx 2011-10-16 05:11:01.175028326 +0200
+@@ -72,7 +72,7 @@
+ // All points within the chunk are relative to the reference
+ // point. Therefore, to place points in absolute 3D space, we
+ // need to add the reference point to all points.
+- const SGVec3<double>& gbs_p = _chunk.get_gbs_center2();
++ const SGVec3<double>& gbs_p = _chunk.get_gbs_center();
+
+ // Get all the points, and use them to set our maximum elevation
+ // figure.
diff --git a/games-util/atlas/metadata.xml b/games-util/atlas/metadata.xml
index d3c2cc926f0b..bf9480ea717d 100644
--- a/games-util/atlas/metadata.xml
+++ b/games-util/atlas/metadata.xml
@@ -2,4 +2,8 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>games</herd>
+<maintainer>
+ <email>reavertm@gentoo.org</email>
+ <name>Maciej Mrozowski</name>
+</maintainer>
</pkgmetadata>