summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-08-12 19:51:26 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-08-12 19:51:26 +0000
commitcecd6f40460f8028fcd2800cb6d2b33e64cd10ab (patch)
treecfbd9f57177e68e2274c2620a453ee423b1a958d /games-util
parentCleaning out old version (diff)
downloadgentoo-2-cecd6f40460f8028fcd2800cb6d2b33e64cd10ab.tar.gz
gentoo-2-cecd6f40460f8028fcd2800cb6d2b33e64cd10ab.tar.bz2
gentoo-2-cecd6f40460f8028fcd2800cb6d2b33e64cd10ab.zip
CVS snap version bump from Samuli Suominen via bug #280236
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/atlas/ChangeLog10
-rw-r--r--games-util/atlas/atlas-0.3.1_p20090812.ebuild67
2 files changed, 75 insertions, 2 deletions
diff --git a/games-util/atlas/ChangeLog b/games-util/atlas/ChangeLog
index afcf0a16bc50..ce48d36e4c8b 100644
--- a/games-util/atlas/ChangeLog
+++ b/games-util/atlas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-util/atlas
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/ChangeLog,v 1.15 2008/07/22 19:03:34 tupone Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/ChangeLog,v 1.16 2009/08/12 19:51:26 mr_bones_ Exp $
+
+*atlas-0.3.1_p20090812 (12 Aug 2009)
+
+ 12 Aug 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +atlas-0.3.1_p20090812.ebuild:
+ CVS snap version bump from Samuli Suominen via bug #280236
22 Jul 2008; Tupone Alfredo <tupone@gentoo.org>
+files/atlas-0.3.1-gcc-4.3.patch, atlas-0.3.1.ebuild:
diff --git a/games-util/atlas/atlas-0.3.1_p20090812.ebuild b/games-util/atlas/atlas-0.3.1_p20090812.ebuild
new file mode 100644
index 000000000000..98106718815e
--- /dev/null
+++ b/games-util/atlas/atlas-0.3.1_p20090812.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/atlas-0.3.1_p20090812.ebuild,v 1.1 2009/08/12 19:51:26 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools games
+
+MY_P=Atlas-${PV}
+DESCRIPTION="Chart Program to use with Flightgear Flight Simulator"
+HOMEPAGE="http://atlas.sourceforge.net/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="games-simulation/flightgear
+ media-libs/libpng
+ media-libs/jpeg
+ x11-libs/libXi
+ x11-libs/libXmu
+ net-misc/curl"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-fgbase="${GAMES_DATADIR}"/FlightGear
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ insinto "${GAMES_DATADIR}"/FlightGear/Atlas
+ doins src/data/*.jpg || die "doins failed"
+ insinto "${GAMES_DATADIR}"/FlightGear/Atlas/Palettes
+ doins src/data/Palettes/*.ap || die "doins failed"
+ insinto "${GAMES_DATADIR}"/FlightGear/Atlas/Fonts
+ doins src/data/Fonts/*.txf || die "doins failed"
+ dodoc AUTHORS NEWS README
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "You now can make the maps with the following commands:"
+ elog "${GAMES_BINDIR}/Map --atlas=${GAMES_DATADIR}/FlightGear/Atlas"
+ elog
+ elog "To run Atlas concurrently with FlightGear use the following:"
+ elog "Atlas --path=[path of map images] --udp=[port number]"
+ elog "and start fgfs with the following switch (or in .fgfsrc):"
+ elog "--nmea=socket,out,0.5,[host that you run Atlas on],[port number],udp"
+ echo
+}
+
+pkg_postrm() {
+ elog "You must manually remove the maps if you don't want them around."
+ elog "They are found in the following directory:"
+ echo
+ elog "${GAMES_DATADIR}/FlightGear/Atlas"
+ echo
+}