summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-08-21 15:15:53 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-08-21 15:15:53 +0000
commitd401a3a9e7dc95bdc78d366aca5378f07597be5a (patch)
treeebc7ed4c91b704dd430fd038b7ded98e2f5b83f2 /gnome-base/bonobo
parentdisabled mozilla support until new nautilus is released that works with lates... (diff)
downloadgentoo-2-d401a3a9e7dc95bdc78d366aca5378f07597be5a.tar.gz
gentoo-2-d401a3a9e7dc95bdc78d366aca5378f07597be5a.tar.bz2
gentoo-2-d401a3a9e7dc95bdc78d366aca5378f07597be5a.zip
do a little sed on po/pl.po becuase it generates lots of warnings when starting oafd otherwise
Diffstat (limited to 'gnome-base/bonobo')
-rw-r--r--gnome-base/bonobo/bonobo-1.0.8-r1.ebuild59
-rw-r--r--gnome-base/bonobo/files/digest-bonobo-1.0.8-r11
2 files changed, 60 insertions, 0 deletions
diff --git a/gnome-base/bonobo/bonobo-1.0.8-r1.ebuild b/gnome-base/bonobo/bonobo-1.0.8-r1.ebuild
new file mode 100644
index 000000000000..55ab528d1c53
--- /dev/null
+++ b/gnome-base/bonobo/bonobo-1.0.8-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/bonobo/bonobo-1.0.8-r1.ebuild,v 1.1 2001/08/21 15:15:53 hallski Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A set of language and system independant CORBA interfaces"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}
+ ftp://gnome.eazel.com/pub/gnome/stable/sources/${PN}/${A}"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND="nls? ( sys-devel/gettext ) sys-devel/perl
+ >=gnome-base/oaf-0.6.5
+ >=dev-util/xml-i18n-tools-0.8.4
+ >=gnome-base/ORBit-0.5.8
+ >=gnome-base/gnome-print-0.25"
+
+RDEPEND=">=gnome-base/oaf-0.6.5
+ >=gnome-base/ORBit-0.5.8
+ >=gnome-base/gnome-print-0.25"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/po
+ cp pl.po pl.po.orig
+ sed -e "s:\\\\\"::g" pl.po.orig > pl.po
+ rm pl.po.orig
+}
+
+src_compile() {
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ # on of the samples in the package need to be regenerated from the idl files
+ rm -f ${S}/samples/bonobo-class/Bonobo_Sample_Echo.h
+ rm -f ${S}/samples/bonobo-class/Bonobo_Sample_Echo-*.c
+
+ ./configure --host=${CHOST} --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome ${myconf} || die
+ make || die # make -j 4 didn't work
+}
+
+src_install() {
+
+ make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome install || die
+
+ dodoc AUTHORS COPYING* ChangeLog README
+ dodoc NEWS TODO
+}
+
+
+
+
+
+
+
diff --git a/gnome-base/bonobo/files/digest-bonobo-1.0.8-r1 b/gnome-base/bonobo/files/digest-bonobo-1.0.8-r1
new file mode 100644
index 000000000000..03253a958f9a
--- /dev/null
+++ b/gnome-base/bonobo/files/digest-bonobo-1.0.8-r1
@@ -0,0 +1 @@
+MD5 a21755814671e25d86988c098ebb68f3 bonobo-1.0.8.tar.gz