summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2011-10-09 09:43:47 +0000
committerFabio Erculiani <lxnay@gentoo.org>2011-10-09 09:43:47 +0000
commitd7b5cc27199f8657822971c08a5c92780c9eda3d (patch)
tree7688bda828e7b47feced5f7ca79fccf169264710 /gnome-base/librsvg/librsvg-2.34.1.ebuild
parentadd ewarn in case of gdk-pixbuf-query-loaders failure (diff)
downloadgentoo-2-d7b5cc27199f8657822971c08a5c92780c9eda3d.tar.gz
gentoo-2-d7b5cc27199f8657822971c08a5c92780c9eda3d.tar.bz2
gentoo-2-d7b5cc27199f8657822971c08a5c92780c9eda3d.zip
add ewarn in case of gdk-pixbuf-query-loaders failure
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base/librsvg/librsvg-2.34.1.ebuild')
-rw-r--r--gnome-base/librsvg/librsvg-2.34.1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnome-base/librsvg/librsvg-2.34.1.ebuild b/gnome-base/librsvg/librsvg-2.34.1.ebuild
index 6c1bc1bf573d..d3db6c3d5c7f 100644
--- a/gnome-base/librsvg/librsvg-2.34.1.ebuild
+++ b/gnome-base/librsvg/librsvg-2.34.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/librsvg-2.34.1.ebuild,v 1.6 2011/10/09 08:54:42 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/librsvg-2.34.1.ebuild,v 1.7 2011/10/09 09:43:47 lxnay Exp $
EAPI="4"
GNOME2_LA_PUNT="yes"
@@ -61,6 +61,8 @@ pkg_postinst() {
gdk-pixbuf-query-loaders > "${tmp_file}"
if [ "${?}" = "0" ]; then
cat "${tmp_file}" > "${EROOT}usr/$(get_libdir)/gdk-pixbuf-2.0/2.10.0/loaders.cache"
+ else
+ ewarn "Cannot update loaders.cache, gdk-pixbuf-query-loaders failed to run"
fi
rm "${tmp_file}"
}
@@ -74,6 +76,8 @@ pkg_postrm() {
gdk-pixbuf-query-loaders > "${tmp_file}"
if [ "${?}" = "0" ]; then
cat "${tmp_file}" > "${EROOT}usr/$(get_libdir)/gdk-pixbuf-2.0/2.10.0/loaders.cache"
+ else
+ ewarn "Cannot update loaders.cache, gdk-pixbuf-query-loaders failed to run"
fi
rm "${tmp_file}"
}