summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorScott W Taylor <swtaylor@gentoo.org>2004-09-28 21:38:24 +0000
committerScott W Taylor <swtaylor@gentoo.org>2004-09-28 21:38:24 +0000
commit258a54c30d9ec96e1160bd0c0ccf7dc24dd77be6 (patch)
tree94cddaaef03bf8821dddcd84f654f02751d5ca4f /gnome-base/nautilus
parentdon't use typeaheadfind for firefox >= 1.0PR. another thing that would be fi... (diff)
downloadgentoo-2-258a54c30d9ec96e1160bd0c0ccf7dc24dd77be6.tar.gz
gentoo-2-258a54c30d9ec96e1160bd0c0ccf7dc24dd77be6.tar.bz2
gentoo-2-258a54c30d9ec96e1160bd0c0ccf7dc24dd77be6.zip
now happy with libexif-0.6 as per bug 13463
Diffstat (limited to 'gnome-base/nautilus')
-rw-r--r--gnome-base/nautilus/ChangeLog6
-rw-r--r--gnome-base/nautilus/files/nautilus-2.6.3-libexif-0.6.patch18
-rw-r--r--gnome-base/nautilus/nautilus-2.6.3-r1.ebuild4
3 files changed, 25 insertions, 3 deletions
diff --git a/gnome-base/nautilus/ChangeLog b/gnome-base/nautilus/ChangeLog
index e81cfe2183e9..9c5f1da4d923 100644
--- a/gnome-base/nautilus/ChangeLog
+++ b/gnome-base/nautilus/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnome-base/nautilus
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/ChangeLog,v 1.104 2004/09/16 12:55:50 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/ChangeLog,v 1.105 2004/09/28 21:38:24 swtaylor Exp $
+
+ 28 Sep 2004; Scott W Taylor <swtaylor@gentoo.org>
+ +files/nautilus-2.6.3-libexif-0.6.patch, nautilus-2.6.3-r1.ebuild:
+ handle libexif 0.6 as per bug 13463
*nautilus-2.8.0 (16 Sep 2004)
diff --git a/gnome-base/nautilus/files/nautilus-2.6.3-libexif-0.6.patch b/gnome-base/nautilus/files/nautilus-2.6.3-libexif-0.6.patch
new file mode 100644
index 000000000000..8617d5e2185a
--- /dev/null
+++ b/gnome-base/nautilus/files/nautilus-2.6.3-libexif-0.6.patch
@@ -0,0 +1,18 @@
+--- nautilus-2.6.3/components/image_properties/nautilus-image-properties-view.c.oldexif 2004-09-14 19:02:02.000000000 -0400
++++ nautilus-2.6.3/components/image_properties/nautilus-image-properties-view.c 2004-09-14 19:04:44.000000000 -0400
+@@ -124,13 +124,14 @@
+ exif_content_callback (ExifContent *content, gpointer data)
+ {
+ struct ExifAttribute *attribute;
++ char tagdata[1024];
+
+ attribute = (struct ExifAttribute *)data;
+ if (attribute->found) {
+ return;
+ }
+
+- attribute->value = g_strdup (exif_content_get_value (content, attribute->tag));
++ attribute->value = g_strdup (exif_content_get_value (content, attribute->tag, tagdata, sizeof(tagdata)));
+ if (attribute->value != NULL) {
+ attribute->found = TRUE;
+ }
diff --git a/gnome-base/nautilus/nautilus-2.6.3-r1.ebuild b/gnome-base/nautilus/nautilus-2.6.3-r1.ebuild
index d99ab27e494d..ddadb4bb0a76 100644
--- a/gnome-base/nautilus/nautilus-2.6.3-r1.ebuild
+++ b/gnome-base/nautilus/nautilus-2.6.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/nautilus-2.6.3-r1.ebuild,v 1.3 2004/08/22 17:54:48 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/nautilus-2.6.3-r1.ebuild,v 1.4 2004/09/28 21:38:24 swtaylor Exp $
inherit gnome2 eutils
@@ -83,7 +83,7 @@ src_unpack() {
# applying patch to optionally remove volumes from the desktop,
# see bug #51343 <obz@gentoo.org>
epatch ${FILESDIR}/${P}-novolumes.patch
-
+ has_version '>=media-libs/libexif-0.6' && epatch ${FILESDIR}/${P}-libexif-0.6.patch
}
pkg_postinst() {