summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2007-03-17 07:50:05 +0000
committerMart Raudsepp <leio@gentoo.org>2007-03-17 07:50:05 +0000
commitc0d5b34900218e96f4bb0afe5c7f4c712edaf025 (patch)
tree91ef3aa5793a89e6cec36b6192b84e0fcb896498 /gnome-base/orbit
parentmake the highscore stuff look better (diff)
downloadgentoo-2-c0d5b34900218e96f4bb0afe5c7f4c712edaf025.tar.gz
gentoo-2-c0d5b34900218e96f4bb0afe5c7f4c712edaf025.tar.bz2
gentoo-2-c0d5b34900218e96f4bb0afe5c7f4c712edaf025.zip
Bump to 2.14.7
(Portage version: 2.1.2.2)
Diffstat (limited to 'gnome-base/orbit')
-rw-r--r--gnome-base/orbit/ChangeLog7
-rw-r--r--gnome-base/orbit/files/digest-orbit-2.14.73
-rw-r--r--gnome-base/orbit/orbit-2.14.7.ebuild41
3 files changed, 50 insertions, 1 deletions
diff --git a/gnome-base/orbit/ChangeLog b/gnome-base/orbit/ChangeLog
index 73acb750815e..97e7c6b35ab6 100644
--- a/gnome-base/orbit/ChangeLog
+++ b/gnome-base/orbit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-base/orbit
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/ChangeLog,v 1.89 2007/03/06 15:50:30 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/ChangeLog,v 1.90 2007/03/17 07:50:05 leio Exp $
+
+*orbit-2.14.7 (17 Mar 2007)
+
+ 17 Mar 2007; Mart Raudsepp <leio@gentoo.org> +orbit-2.14.7.ebuild:
+ Bump to 2.14.7
06 Mar 2007; Daniel Gryniewicz <dang@gentoo.org> -orbit-2.14.3.ebuild:
Remove broken 2.14.3 (from bug #146929) now that 2.14.4 is in the tree
diff --git a/gnome-base/orbit/files/digest-orbit-2.14.7 b/gnome-base/orbit/files/digest-orbit-2.14.7
new file mode 100644
index 000000000000..239eeb4eb7be
--- /dev/null
+++ b/gnome-base/orbit/files/digest-orbit-2.14.7
@@ -0,0 +1,3 @@
+MD5 3440c44aaef14dd96e4ccd7ce22a7e6e ORBit2-2.14.7.tar.bz2 729469
+RMD160 4ac003754c037ec8bb151bb344db31c0888a852c ORBit2-2.14.7.tar.bz2 729469
+SHA256 751b76344462748b1ac79b739ce2e0251fe985c6c8d65a0b9f3246e4ab1dd6fa ORBit2-2.14.7.tar.bz2 729469
diff --git a/gnome-base/orbit/orbit-2.14.7.ebuild b/gnome-base/orbit/orbit-2.14.7.ebuild
new file mode 100644
index 000000000000..e6fff459af5c
--- /dev/null
+++ b/gnome-base/orbit/orbit-2.14.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.7.ebuild,v 1.1 2007/03/17 07:50:05 leio Exp $
+
+inherit gnome2
+
+MY_P="ORBit2-${PV}"
+PVP=(${PV//[-\._]/ })
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="ORBit2 is a high-performance CORBA ORB"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="mirror://gnome/sources/ORBit2/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/glib-2.8
+ >=dev-libs/libIDL-0.8.2"
+
+# FIXME linc is now integrated, but a block isn't necessary
+# and probably complicated FIXME
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.18
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* TODO"
+
+src_compile() {
+ # We need to unset IDL_DIR, which is set by RSI's IDL. This causes certain
+ # files to be not found by autotools when compiling ORBit. See bug #58540
+ # for more information. Please don't remove -- 8/18/06
+ unset IDL_DIR
+
+ gnome2_src_compile
+}