summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-12-24 16:39:24 +0000
committerPacho Ramos <pacho@gentoo.org>2013-12-24 16:39:24 +0000
commit17d38b80cec42073a154efbfc03099990ef2786f (patch)
tree4250fb62b59ee467e2c6a773c978f4d1d5911887 /gnome-base
parentVersion bump for Gnome 3.10 (diff)
downloadgentoo-2-17d38b80cec42073a154efbfc03099990ef2786f.tar.gz
gentoo-2-17d38b80cec42073a154efbfc03099990ef2786f.tar.bz2
gentoo-2-17d38b80cec42073a154efbfc03099990ef2786f.zip
Version bump for Gnome 3.10
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/libgnome-keyring/ChangeLog8
-rw-r--r--gnome-base/libgnome-keyring/libgnome-keyring-3.10.1.ebuild (renamed from gnome-base/libgnome-keyring/libgnome-keyring-3.6.0.ebuild)32
2 files changed, 23 insertions, 17 deletions
diff --git a/gnome-base/libgnome-keyring/ChangeLog b/gnome-base/libgnome-keyring/ChangeLog
index ccd1b47fd50a..d0390b0f0969 100644
--- a/gnome-base/libgnome-keyring/ChangeLog
+++ b/gnome-base/libgnome-keyring/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/libgnome-keyring
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnome-keyring/ChangeLog,v 1.43 2013/12/08 18:37:27 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnome-keyring/ChangeLog,v 1.44 2013/12/24 16:39:24 pacho Exp $
+
+*libgnome-keyring-3.10.1 (24 Dec 2013)
+
+ 24 Dec 2013; Pacho Ramos <pacho@gentoo.org> +libgnome-keyring-3.10.1.ebuild,
+ -libgnome-keyring-3.6.0.ebuild:
+ Version bump for Gnome 3.10
08 Dec 2013; Pacho Ramos <pacho@gentoo.org> libgnome-keyring-3.8.0.ebuild:
x86 stable, bug #478252
diff --git a/gnome-base/libgnome-keyring/libgnome-keyring-3.6.0.ebuild b/gnome-base/libgnome-keyring/libgnome-keyring-3.10.1.ebuild
index 14c107dddcfe..3620a6ab1c67 100644
--- a/gnome-base/libgnome-keyring/libgnome-keyring-3.6.0.ebuild
+++ b/gnome-base/libgnome-keyring/libgnome-keyring-3.10.1.ebuild
@@ -1,53 +1,53 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnome-keyring/libgnome-keyring-3.6.0.ebuild,v 1.2 2013/02/25 09:19:55 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnome-keyring/libgnome-keyring-3.10.1.ebuild,v 1.1 2013/12/24 16:39:24 pacho Exp $
EAPI="5"
GCONF_DEBUG="yes"
GNOME2_LA_PUNT="yes"
VALA_MIN_API_VERSION="0.16"
VALA_USE_DEPEND="vapigen"
+PYTHON_COMPAT=( python{2_6,2_7} )
-inherit gnome2 python vala
+inherit gnome2 python-any-r1 vala
DESCRIPTION="Compatibility library for accessing secrets"
HOMEPAGE="http://live.gnome.org/GnomeKeyring"
LICENSE="LGPL-2+ GPL-2+" # tests are GPL-2
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris"
IUSE="debug +introspection test vala"
REQUIRED_USE="vala? ( introspection )"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris"
-RDEPEND=">=sys-apps/dbus-1.0
+RDEPEND="
+ >=sys-apps/dbus-1
>=gnome-base/gnome-keyring-3.1.92
- introspection? ( >=dev-libs/gobject-introspection-1.30.0 )"
+ introspection? ( >=dev-libs/gobject-introspection-1.30.0 )
+"
DEPEND="${RDEPEND}
dev-util/gtk-doc-am
>=dev-util/intltool-0.35
sys-devel/gettext
virtual/pkgconfig
- test? ( =dev-lang/python-2* )
- vala? ( $(vala_depend) )"
-
-pkg_setup() {
- if use test; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
+ test? ( ${PYTHON_DEPS} )
+ vala? ( $(vala_depend) )
+"
src_prepare() {
- G2CONF="${G2CONF} $(use_enable vala)"
use vala && vala_src_prepare
gnome2_src_prepare
- # FIXME: Remove silly CFLAGS
+ # FIXME: Remove silly CFLAGS, report upstream
sed -e 's:CFLAGS="$CFLAGS -g:CFLAGS="$CFLAGS:' \
-e 's:CFLAGS="$CFLAGS -O0:CFLAGS="$CFLAGS:' \
-i configure.ac configure || die "sed failed"
}
+src_configure() {
+ gnome2_src_configure $(use_enable vala)
+}
+
src_test() {
unset DBUS_SESSION_BUS_ADDRESS
dbus-launch emake check || die "tests failed"