summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-07 08:05:12 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-07 08:05:12 +0000
commit72cf061798709052a73be952fc967031cb608e1b (patch)
treed45f85240ef51431f0825b1e2dba0803b9620960 /gnome-base
parentNon-maintainer Version Bump (diff)
downloadgentoo-2-72cf061798709052a73be952fc967031cb608e1b.tar.gz
gentoo-2-72cf061798709052a73be952fc967031cb608e1b.tar.bz2
gentoo-2-72cf061798709052a73be952fc967031cb608e1b.zip
Version bump for gnome-3.4; adds undo support for common operations.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/nautilus/ChangeLog8
-rw-r--r--gnome-base/nautilus/files/nautilus-3.4.1-gmount-double-unref.patch36
-rw-r--r--gnome-base/nautilus/nautilus-3.4.1.ebuild110
3 files changed, 153 insertions, 1 deletions
diff --git a/gnome-base/nautilus/ChangeLog b/gnome-base/nautilus/ChangeLog
index 45dd4babbaa3..b6b4f6790139 100644
--- a/gnome-base/nautilus/ChangeLog
+++ b/gnome-base/nautilus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/nautilus
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/ChangeLog,v 1.395 2012/05/05 05:38:08 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/ChangeLog,v 1.396 2012/05/07 08:05:12 tetromino Exp $
+
+*nautilus-3.4.1 (07 May 2012)
+
+ 07 May 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +nautilus-3.4.1.ebuild, +files/nautilus-3.4.1-gmount-double-unref.patch:
+ Version bump for gnome-3.4; adds undo support for common operations.
05 May 2012; Jeff Horelick <jdhore@gentoo.org> nautilus-2.32.2.1.ebuild,
nautilus-2.32.2.1-r1.ebuild, nautilus-2.32.2.1-r2.ebuild,
diff --git a/gnome-base/nautilus/files/nautilus-3.4.1-gmount-double-unref.patch b/gnome-base/nautilus/files/nautilus-3.4.1-gmount-double-unref.patch
new file mode 100644
index 000000000000..6f3268ab178c
--- /dev/null
+++ b/gnome-base/nautilus/files/nautilus-3.4.1-gmount-double-unref.patch
@@ -0,0 +1,36 @@
+From 4e59e4cfc7bc68534664d9f72d0c7ea680b79db3 Mon Sep 17 00:00:00 2001
+From: Cosimo Cecchi <cosimoc@gnome.org>
+Date: Fri, 4 May 2012 14:38:43 -0400
+Subject: [PATCH] places-sidebar: don't double unref GMount objects
+
+Fixes a lot of reported crashers with NFS/Samba volumes.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=674659
+---
+ src/nautilus-places-sidebar.c | 3 +--
+ 1 files changed, 1 insertions(+), 2 deletions(-)
+
+diff --git a/src/nautilus-places-sidebar.c b/src/nautilus-places-sidebar.c
+index 61f3658..672a4b0 100644
+--- a/src/nautilus-places-sidebar.c
++++ b/src/nautilus-places-sidebar.c
+@@ -774,7 +774,7 @@ update_places (NautilusPlacesSidebar *sidebar)
+ root = g_mount_get_default_location (mount);
+
+ if (!g_file_is_native (root)) {
+- network_mounts = g_list_prepend (network_mounts, g_object_ref (mount));
++ network_mounts = g_list_prepend (network_mounts, mount);
+ continue;
+ }
+
+@@ -856,7 +856,6 @@ update_places (NautilusPlacesSidebar *sidebar)
+ name, icon, mount_uri,
+ NULL, NULL, mount, 0, tooltip);
+ g_object_unref (root);
+- g_object_unref (mount);
+ g_object_unref (icon);
+ g_free (name);
+ g_free (mount_uri);
+--
+1.7.8.6
+
diff --git a/gnome-base/nautilus/nautilus-3.4.1.ebuild b/gnome-base/nautilus/nautilus-3.4.1.ebuild
new file mode 100644
index 000000000000..e9f3ee884d23
--- /dev/null
+++ b/gnome-base/nautilus/nautilus-3.4.1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/nautilus-3.4.1.ebuild,v 1.1 2012/05/07 08:05:12 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 virtualx
+
+DESCRIPTION="A file manager for the GNOME desktop"
+HOMEPAGE="http://live.gnome.org/Nautilus"
+
+LICENSE="GPL-2 LGPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="doc exif gnome +introspection packagekit +previewer sendto tracker xmp"
+
+# Require {glib,gdbus-codegen}-2.30.0 due to GDBus API changes between 2.29.92
+# and 2.30.0
+COMMON_DEPEND=">=dev-libs/glib-2.31.9:2
+ >=x11-libs/pango-1.28.3
+ >=x11-libs/gtk+-3.3.17:3[introspection?]
+ >=dev-libs/libxml2-2.7.8:2
+ >=gnome-base/gnome-desktop-3.0.0:3
+
+ gnome-base/dconf
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/libnotify-0.7
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+
+ exif? ( >=media-libs/libexif-0.6.20 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.4 )
+ tracker? ( >=app-misc/tracker-0.12 )
+ xmp? ( >=media-libs/exempi-2.1.0 )"
+DEPEND="${COMMON_DEPEND}
+ >=dev-lang/perl-5
+ >=dev-util/gdbus-codegen-2.31.0
+ >=dev-util/intltool-0.40.1
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-proto/xproto
+ doc? ( >=dev-util/gtk-doc-1.4 )"
+RDEPEND="${COMMON_DEPEND}
+ packagekit? ( app-admin/packagekit-base )
+ sendto? ( !<gnome-extra/nautilus-sendto-3.0.1 )"
+# For eautoreconf
+# gnome-base/gnome-common
+# dev-util/gtk-doc-am"
+PDEPEND="gnome? (
+ >=x11-themes/gnome-icon-theme-1.1.91
+ x11-themes/gnome-icon-theme-symbolic )
+ tracker? ( >=gnome-extra/nautilus-tracker-tags-0.12 )
+ previewer? ( >=gnome-extra/sushi-0.1.9 )
+ sendto? ( >=gnome-extra/nautilus-sendto-3.0.1 )
+ >=gnome-base/gvfs-0.1.2"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-update-mimedb
+ $(use_enable exif libexif)
+ $(use_enable introspection)
+ $(use_enable packagekit)
+ $(use_enable sendto nst-extension)
+ $(use_enable tracker)
+ $(use_enable xmp)"
+ DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README THANKS TODO"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Restore the nautilus-2.x Delete shortcut (Ctrl+Delete will still work);
+ # bug #393663
+ epatch "${FILESDIR}/${PN}-3.2.1-delete.patch"
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=664573
+ epatch "${FILESDIR}/${PN}-3.2.1-key-press-forwarding.patch"
+
+ # In next release
+ epatch "${FILESDIR}/${P}-gmount-double-unref.patch"
+
+ # Remove crazy CFLAGS
+ sed 's:-DG.*DISABLE_DEPRECATED::g' -i configure.in configure \
+ || die "sed 1 failed"
+}
+
+src_test() {
+ addpredict "/root/.gnome2_private"
+ unset SESSION_MANAGER
+ unset ORBIT_SOCKETDIR
+ unset DBUS_SESSION_BUS_ADDRESS
+ export GSETTINGS_BACKEND="memory"
+ Xemake check
+ unset GSETTINGS_BACKEND
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ if use previewer; then
+ elog "nautilus uses gnome-extra/sushi to preview media files."
+ elog "To activate the previewer, select a file and press space; to"
+ elog "close the previewer, press space again."
+ else
+ elog "To preview media files, emerge nautilus with USE=previewer"
+ fi
+}