summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2013-02-12 06:53:58 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2013-02-12 06:53:58 +0000
commit8a767d0772c5eb71ae7cc330b6ea428a36ce100a (patch)
treec2b0b959aa365c303e2b937ef86e23fee3b499a2 /gnome-base
parentFixed copy header file, Bug #456884 (diff)
downloadgentoo-2-8a767d0772c5eb71ae7cc330b6ea428a36ce100a.tar.gz
gentoo-2-8a767d0772c5eb71ae7cc330b6ea428a36ce100a.tar.bz2
gentoo-2-8a767d0772c5eb71ae7cc330b6ea428a36ce100a.zip
Drop useless doc USE flag. Punt .la files and make static-libs optional (bug #456772, thanks to Agostino Sarubbo). Fix link_protocol_is_local logic for ipv4 on ipv6-enabled machines (bug #413231, thanks to Patrick Lauer).
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/orbit/ChangeLog11
-rw-r--r--gnome-base/orbit/files/orbit-2.14.19-link_protocol_is_local.patch35
-rw-r--r--gnome-base/orbit/orbit-2.14.19-r1.ebuild14
-rw-r--r--gnome-base/orbit/orbit-2.14.19-r2.ebuild79
4 files changed, 131 insertions, 8 deletions
diff --git a/gnome-base/orbit/ChangeLog b/gnome-base/orbit/ChangeLog
index 5b05ccfb58b9..f0728ef15b61 100644
--- a/gnome-base/orbit/ChangeLog
+++ b/gnome-base/orbit/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for gnome-base/orbit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/ChangeLog,v 1.185 2013/02/10 07:49:31 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/ChangeLog,v 1.186 2013/02/12 06:53:58 tetromino Exp $
+
+*orbit-2.14.19-r2 (12 Feb 2013)
+
+ 12 Feb 2013; Alexandre Rostovtsev <tetromino@gentoo.org>
+ orbit-2.14.19-r1.ebuild, +orbit-2.14.19-r2.ebuild,
+ +files/orbit-2.14.19-link_protocol_is_local.patch:
+ Drop useless doc USE flag. Punt .la files and make static-libs optional (bug
+ #456772, thanks to Agostino Sarubbo). Fix link_protocol_is_local logic for
+ ipv4 on ipv6-enabled machines (bug #413231, thanks to Patrick Lauer).
10 Feb 2013; Pacho Ramos <pacho@gentoo.org> -orbit-2.14.19.ebuild:
Drop old
diff --git a/gnome-base/orbit/files/orbit-2.14.19-link_protocol_is_local.patch b/gnome-base/orbit/files/orbit-2.14.19-link_protocol_is_local.patch
new file mode 100644
index 000000000000..c7b80326002c
--- /dev/null
+++ b/gnome-base/orbit/files/orbit-2.14.19-link_protocol_is_local.patch
@@ -0,0 +1,35 @@
+From 244ff588863a18d1eff4aec1e8df22fa8e001444 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Tue, 12 Feb 2013 00:27:41 -0500
+Subject: [PATCH] Fix link_protocol_is_local_ipv46 for ipv4 on some
+ ipv6-enabled machines
+
+Ensure that saddr is compared to an ipv4 local_addr, not to an ipv6 one,
+by setting hints.ai_family before calling getaddrinfo().
+
+Note that we only set hints.ai_family if proto->family == AF_INET,
+because in a check below, link_protocol_is_local_ipv46() explicitly
+treats the "proto->family!=AF_INET but local_addr->ai_family!=AF_INET6"
+case as non-local.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=693636
+---
+ linc2/src/linc-protocols.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/linc2/src/linc-protocols.c b/linc2/src/linc-protocols.c
+index e6895f4..711fb79 100644
+--- a/linc2/src/linc-protocols.c
++++ b/linc2/src/linc-protocols.c
+@@ -383,6 +383,8 @@ link_protocol_is_local_ipv46 (const LinkProtocolInfo *proto,
+ memset(&hints, 0, sizeof(hints));
+ hints.ai_socktype = SOCK_STREAM;
+ hints.ai_flags = AI_CANONNAME;
++ if (proto->family == AF_INET)
++ hints.ai_family = AF_INET;
+
+ if (getaddrinfo(link_get_local_hostname(), NULL, &hints, &local_addr) != 0) {
+ if (!warned++)
+--
+1.8.1.2
+
diff --git a/gnome-base/orbit/orbit-2.14.19-r1.ebuild b/gnome-base/orbit/orbit-2.14.19-r1.ebuild
index db974cc83b16..7cee8cf484cc 100644
--- a/gnome-base/orbit/orbit-2.14.19-r1.ebuild
+++ b/gnome-base/orbit/orbit-2.14.19-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.19-r1.ebuild,v 1.12 2012/05/09 01:35:12 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.19-r1.ebuild,v 1.13 2013/02/12 06:53:58 tetromino Exp $
EAPI="3"
GCONF_DEBUG="yes"
@@ -14,15 +14,15 @@ HOMEPAGE="http://projects.gnome.org/ORBit2/"
LICENSE="GPL-2 LGPL-2"
SLOT="2"
KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="doc test"
+IUSE="test"
RDEPEND=">=dev-libs/glib-2.8:2
- >=dev-libs/libIDL-0.8.2"
-
+ >=dev-libs/libIDL-0.8.2
+"
DEPEND="${RDEPEND}
- virtual/pkgconfig
dev-util/gtk-doc-am
- doc? ( >=dev-util/gtk-doc-1 )"
+ virtual/pkgconfig
+"
pkg_setup() {
DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* TODO"
diff --git a/gnome-base/orbit/orbit-2.14.19-r2.ebuild b/gnome-base/orbit/orbit-2.14.19-r2.ebuild
new file mode 100644
index 000000000000..92b498ec6b8d
--- /dev/null
+++ b/gnome-base/orbit/orbit-2.14.19-r2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.19-r2.ebuild,v 1.1 2013/02/12 06:53:58 tetromino Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME_ORG_MODULE="ORBit2"
+GNOME_TARBALL_SUFFIX="bz2"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 toolchain-funcs autotools
+
+DESCRIPTION="ORBit2 is a high-performance CORBA ORB"
+HOMEPAGE="http://projects.gnome.org/ORBit2/"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="static-libs test"
+REQUIRED_USE="test? ( debug )"
+
+RDEPEND=">=dev-libs/glib-2.8:2
+ >=dev-libs/libIDL-0.8.2
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Fix wrong process kill, bug #268142
+ sed "s:killall lt-timeout-server:killall timeout-server:" \
+ -i test/timeout.sh || die "sed 1 failed"
+
+ # Do not mess with CFLAGS
+ sed 's/-ggdb -O0//' -i configure.in configure || die "sed 2 failed"
+
+ if ! use test; then
+ sed -i -e 's/test //' Makefile.am || die
+ fi
+
+ # Drop failing test, bug #331709
+ sed -i -e 's/test-mem //' test/Makefile.am || die
+
+ # Fix link_protocol_is_local() for ipv4 on machines with ipv6
+ # https://bugzilla.gnome.org/show_bug.cgi?id=693636
+ epatch "${FILESDIR}/${PN}-2.14.19-link_protocol_is_local.patch"
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* TODO"
+
+ # We need to unset IDL_DIR, which is set by RSI's IDL. This causes certain
+ # files to be not found by autotools when compiling ORBit. See bug #58540
+ # for more information. Please don't remove -- 8/18/06
+ unset IDL_DIR
+
+ # We need to use the hosts IDL compiler if cross-compiling, bug #262741
+ if tc-is-cross-compiler; then
+ # check that host version is present and executable
+ [ -x /usr/bin/orbit-idl-2 ] || die "Please emerge ~${CATEGORY}/${P} on the host system first"
+ G2CONF="${G2CONF} --with-idl-compiler=/usr/bin/orbit-idl-2"
+ fi
+ gnome2_src_configure $(use_enable static-libs static)
+}
+
+src_compile() {
+ # Parallel build fails from time to time, bug #273031
+ MAKEOPTS="${MAKEOPTS} -j1"
+ gnome2_src_compile
+}
+
+src_test() {
+ # can fail in parallel, see bug #235994
+ emake -j1 check
+}