summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-06-13 21:41:06 +0000
committerPacho Ramos <pacho@gentoo.org>2010-06-13 21:41:06 +0000
commit7159c92849e24d8794c252ac72420ed3f03cb2be (patch)
tree293612f7437f75ddc13b2640af544821b56a1b79 /gnome-extra/evolution-exchange
parentAdd new version for Gnome 2.30 (diff)
downloadgentoo-2-7159c92849e24d8794c252ac72420ed3f03cb2be.tar.gz
gentoo-2-7159c92849e24d8794c252ac72420ed3f03cb2be.tar.bz2
gentoo-2-7159c92849e24d8794c252ac72420ed3f03cb2be.zip
Add new version for Gnome 2.30
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/evolution-exchange')
-rw-r--r--gnome-extra/evolution-exchange/ChangeLog12
-rw-r--r--gnome-extra/evolution-exchange/evolution-exchange-2.30.1.ebuild67
-rw-r--r--gnome-extra/evolution-exchange/files/evolution-exchange-2.30.1-fix-warnings.patch21
-rw-r--r--gnome-extra/evolution-exchange/files/evolution-exchange-2.30.1-ldap-flags.patch30
-rw-r--r--gnome-extra/evolution-exchange/files/evolution-exchange-2.30.1-message-source.patch35
-rw-r--r--gnome-extra/evolution-exchange/files/evolution-exchange-2.30.1-windows-mobile.patch38
6 files changed, 202 insertions, 1 deletions
diff --git a/gnome-extra/evolution-exchange/ChangeLog b/gnome-extra/evolution-exchange/ChangeLog
index 72d7b7a63889..0b299fcf6e8a 100644
--- a/gnome-extra/evolution-exchange/ChangeLog
+++ b/gnome-extra/evolution-exchange/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for gnome-extra/evolution-exchange
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/ChangeLog,v 1.114 2010/06/04 21:01:22 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/ChangeLog,v 1.115 2010/06/13 21:41:06 pacho Exp $
+
+*evolution-exchange-2.30.1 (13 Jun 2010)
+
+ 13 Jun 2010; Pacho Ramos <pacho@gentoo.org>
+ +evolution-exchange-2.30.1.ebuild,
+ +files/evolution-exchange-2.30.1-fix-warnings.patch,
+ +files/evolution-exchange-2.30.1-ldap-flags.patch,
+ +files/evolution-exchange-2.30.1-message-source.patch,
+ +files/evolution-exchange-2.30.1-windows-mobile.patch:
+ Add new version for Gnome 2.30.
04 Jun 2010; Markus Meier <maekke@gentoo.org>
evolution-exchange-2.28.3.ebuild:
diff --git a/gnome-extra/evolution-exchange/evolution-exchange-2.30.1.ebuild b/gnome-extra/evolution-exchange/evolution-exchange-2.30.1.ebuild
new file mode 100644
index 000000000000..205afbffdbdb
--- /dev/null
+++ b/gnome-extra/evolution-exchange/evolution-exchange-2.30.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/evolution-exchange-2.30.1.ebuild,v 1.1 2010/06/13 21:41:06 pacho Exp $
+
+EAPI="2"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange"
+HOMEPAGE="http://www.novell.com/products/desktop/features/evolution.html"
+LICENSE="GPL-2"
+
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug doc static"
+
+RDEPEND="
+ >=mail-client/evolution-${PV}
+ >=gnome-extra/evolution-data-server-${PV}[ldap,kerberos]
+ >=dev-libs/glib-2.16.0
+ >=x11-libs/gtk+-2.10
+ >=gnome-base/gconf-2.0
+ >=gnome-base/libbonobo-2.20.3
+ >=gnome-base/libglade-2.0
+ >=gnome-base/libgnomeui-2.0
+ dev-libs/libxml2
+ net-libs/libsoup:2.4
+ >=net-nds/openldap-2.1.30-r2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --with-openldap
+ --disable-static
+ $(use_with debug e2k-debug)
+ $(use_with static static-ldap)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Add LDAP build flags to the EPlugin.
+ epatch "${FILESDIR}/${P}-ldap-flags.patch"
+
+ # bgo#403903:Appointments don't display in Windows Mobile 5
+ epatch "${FILESDIR}/${P}-windows-mobile.patch"
+
+ # bgo#616913: Unnecessary check producing false critical warnings
+ epatch "${FILESDIR}/${P}-fix-warnings.patch"
+
+ # bgo#617510: Displays source of a message sent by RoadSync 5
+ epatch "${FILESDIR}/${P}-message-source.patch"
+
+ # FIXME: Fix compilation flags crazyness
+ sed 's/CFLAGS="$CFLAGS $WARNING_FLAGS"//' \
+ -i configure.ac configure || die "sed 1 failed"
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+}
diff --git a/gnome-extra/evolution-exchange/files/evolution-exchange-2.30.1-fix-warnings.patch b/gnome-extra/evolution-exchange/files/evolution-exchange-2.30.1-fix-warnings.patch
new file mode 100644
index 000000000000..74a127c97c5e
--- /dev/null
+++ b/gnome-extra/evolution-exchange/files/evolution-exchange-2.30.1-fix-warnings.patch
@@ -0,0 +1,21 @@
+From ed3fb164eb20364498d8a619671328c024068bfe Mon Sep 17 00:00:00 2001
+From: Milan Crha <mcrha@redhat.com>
+Date: Fri, 30 Apr 2010 14:24:45 +0000
+Subject: Bug #616913 - Unnecessary check producing false critical warnings
+
+---
+diff --git a/tools/exchange-share-config-listener.c b/tools/exchange-share-config-listener.c
+index 8d8bc66..3dc1ae1 100644
+--- a/tools/exchange-share-config-listener.c
++++ b/tools/exchange-share-config-listener.c
+@@ -736,8 +736,6 @@ exchange_share_config_listener_get_account_for_uri (ExchangeShareConfigListener
+ GSList *accounts, *a;
+ ExchangeAccount *res = NULL;
+
+- g_return_val_if_fail (uri != NULL, NULL);
+-
+ if (!excl)
+ excl = exchange_share_config_listener_get_global ();
+
+--
+cgit v0.8.3.1
diff --git a/gnome-extra/evolution-exchange/files/evolution-exchange-2.30.1-ldap-flags.patch b/gnome-extra/evolution-exchange/files/evolution-exchange-2.30.1-ldap-flags.patch
new file mode 100644
index 000000000000..0c7f7c804c7b
--- /dev/null
+++ b/gnome-extra/evolution-exchange/files/evolution-exchange-2.30.1-ldap-flags.patch
@@ -0,0 +1,30 @@
+From 5f4159f4050fdc84753a342fa2fb6c1f9e47dc51 Mon Sep 17 00:00:00 2001
+From: Matthew Barnes <mbarnes@redhat.com>
+Date: Wed, 28 Apr 2010 12:49:46 +0000
+Subject: Add LDAP build flags to the EPlugin.
+
+---
+diff --git a/eplugin/Makefile.am b/eplugin/Makefile.am
+index 4f710d7..b256dd5 100644
+--- a/eplugin/Makefile.am
++++ b/eplugin/Makefile.am
+@@ -27,7 +27,8 @@ liborg_gnome_exchange_operations_la_CPPFLAGS = \
+ $(EVOLUTION_DATA_SERVER_CFLAGS) \
+ $(EVOLUTION_PLUGIN_CFLAGS) \
+ $(EVOLUTION_SHELL_CFLAGS) \
+- $(EVOLUTION_MAIL_CFLAGS)
++ $(EVOLUTION_MAIL_CFLAGS) \
++ $(LDAP_CFLAGS)
+
+
+ liborg_gnome_exchange_operations_la_SOURCES = \
+@@ -65,6 +66,7 @@ liborg_gnome_exchange_operations_la_LIBADD = \
+ $(EVOLUTION_SHELL_LIBS) \
+ $(EVOLUTION_MAIL_LIBS) \
+ $(PTHREAD_LIB) \
++ $(LDAP_LIBS) \
+ $(DNS_LIBS)
+
+ liborg_gnome_exchange_operations_la_LDFLAGS = \
+--
+cgit v0.8.3.1
diff --git a/gnome-extra/evolution-exchange/files/evolution-exchange-2.30.1-message-source.patch b/gnome-extra/evolution-exchange/files/evolution-exchange-2.30.1-message-source.patch
new file mode 100644
index 000000000000..55b8c07303c7
--- /dev/null
+++ b/gnome-extra/evolution-exchange/files/evolution-exchange-2.30.1-message-source.patch
@@ -0,0 +1,35 @@
+From c81811577adc7003b6917e9b22c8a9cdd769fc24 Mon Sep 17 00:00:00 2001
+From: Milan Crha <mcrha@redhat.com>
+Date: Mon, 10 May 2010 12:23:03 +0000
+Subject: Bug #617510 - Displays source of a message sent by RoadSync 5
+
+---
+diff --git a/camel/camel-exchange-folder.c b/camel/camel-exchange-folder.c
+index c45243a..abbad0b 100644
+--- a/camel/camel-exchange-folder.c
++++ b/camel/camel-exchange-folder.c
+@@ -423,6 +423,22 @@ get_message (CamelFolder *folder, const gchar *uid, CamelException *ex)
+ if (!ba)
+ return NULL;
+
++ while ((ba->len > 10 && g_str_has_prefix ((const gchar *)ba->data, "MAIL FROM:")) ||
++ (ba->len > 8 && g_str_has_prefix ((const gchar *)ba->data, "RCPT TO:")) ||
++ (ba->len > 2 && (ba->data[0] == '\n' || ba->data[1] == '\n'))) {
++ guint i;
++
++ i = 0;
++ while (i < ba->len && ba->data[i] != '\n')
++ i++;
++
++ if (i < ba->len)
++ g_byte_array_remove_range (ba, 0, i + 1);
++ else
++ break;
++ }
++
++
+ stream = camel_stream_mem_new_with_byte_array (ba);
+
+ crlffilter = camel_mime_filter_crlf_new (CAMEL_MIME_FILTER_CRLF_DECODE, CAMEL_MIME_FILTER_CRLF_MODE_CRLF_ONLY);
+--
+cgit v0.8.3.1
diff --git a/gnome-extra/evolution-exchange/files/evolution-exchange-2.30.1-windows-mobile.patch b/gnome-extra/evolution-exchange/files/evolution-exchange-2.30.1-windows-mobile.patch
new file mode 100644
index 000000000000..ee11e5df5fc1
--- /dev/null
+++ b/gnome-extra/evolution-exchange/files/evolution-exchange-2.30.1-windows-mobile.patch
@@ -0,0 +1,38 @@
+From 2ecc00b0c4ba504d67549977e21509ddf53c5ac8 Mon Sep 17 00:00:00 2001
+From: Peter <peter@petesbox.net>
+Date: Thu, 29 Apr 2010 19:08:49 +0000
+Subject: Bug #403903 - Appointments don't display in Windows Mobile 5
+
+---
+diff --git a/calendar/e-cal-backend-exchange-calendar.c b/calendar/e-cal-backend-exchange-calendar.c
+index e17f495..8a84afa 100644
+--- a/calendar/e-cal-backend-exchange-calendar.c
++++ b/calendar/e-cal-backend-exchange-calendar.c
+@@ -748,6 +748,7 @@ create_object (ECalBackendSync *backend, EDataCal *cal,
+ E2kContext *e2kctx;
+ struct _cb_data *cbdata;
+ gboolean send_options;
++ ECalComponentClassification classif;
+
+ d(printf ("ecbexc_create_object(%p, %p, %s, %s)", backend, cal, *calobj ? *calobj : NULL, *uid ? *uid : NULL));
+
+@@ -836,6 +837,17 @@ create_object (ECalBackendSync *backend, EDataCal *cal,
+ cbdata->vcal_comp = e_cal_util_new_top_level ();
+ cbdata->cal = cal;
+
++ /* Though OWA produces "CLASS:" (which we map to
++ * "CLASS:PUBLIC" above), it will accept "CLASS:PUBLIC".
++ * However, some other exchange clients, notably Windows
++ * Mobile Outlook, don't work unless we map "CLASS:PUBLIC"
++ * back to "CLASS:". For details, see
++ * https://bugzilla.gnome.org/show_bug.cgi?id=403903#c23
++ */
++ e_cal_component_get_classification (comp, &classif);
++ if (classif == E_CAL_COMPONENT_CLASS_PUBLIC)
++ e_cal_component_set_classification (comp, E_CAL_COMPONENT_CLASS_NONE);
++
+ /* Remove X parameters from properties */
+ /* This is specifically for X-EVOLUTION-END-DATE,
+ but removing anything else is probably ok too */
+--
+cgit v0.8.3.1