summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-05-18 21:24:24 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-05-18 21:24:24 +0000
commit2bd3188ec58051821a6c525039310240cf777b2b (patch)
treec14e391e38522ad11f8b20199062fde7b23bf2dc /gnome-extra/hamster-applet
parentBump to 3.26.2. Bug fixes and translation updates. (diff)
downloadgentoo-2-2bd3188ec58051821a6c525039310240cf777b2b.tar.gz
gentoo-2-2bd3188ec58051821a6c525039310240cf777b2b.tar.bz2
gentoo-2-2bd3188ec58051821a6c525039310240cf777b2b.zip
Bump to 2.26.2. Bug fixes and translation updates.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/hamster-applet')
-rw-r--r--gnome-extra/hamster-applet/ChangeLog8
-rw-r--r--gnome-extra/hamster-applet/hamster-applet-2.26.2.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/gnome-extra/hamster-applet/ChangeLog b/gnome-extra/hamster-applet/ChangeLog
index 9fd8edd56c54..467db0b44ceb 100644
--- a/gnome-extra/hamster-applet/ChangeLog
+++ b/gnome-extra/hamster-applet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/hamster-applet
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/hamster-applet/ChangeLog,v 1.9 2009/05/10 22:50:40 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/hamster-applet/ChangeLog,v 1.10 2009/05/18 21:24:24 eva Exp $
+
+*hamster-applet-2.26.2 (18 May 2009)
+
+ 18 May 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +hamster-applet-2.26.2.ebuild:
+ Bump to 2.26.2. Bug fixes and translation updates.
*hamster-applet-2.26.0 (10 May 2009)
diff --git a/gnome-extra/hamster-applet/hamster-applet-2.26.2.ebuild b/gnome-extra/hamster-applet/hamster-applet-2.26.2.ebuild
new file mode 100644
index 000000000000..f1e826e0c404
--- /dev/null
+++ b/gnome-extra/hamster-applet/hamster-applet-2.26.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/hamster-applet/hamster-applet-2.26.2.ebuild,v 1.1 2009/05/18 21:24:24 eva Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+SCROLLKEEPER_UPDATE="no"
+
+inherit eutils gnome2 python
+
+DESCRIPTION="Time tracking for the masses, in a GNOME applet"
+HOMEPAGE="http://projecthamster.wordpress.com/"
+
+# license on homepage is out-of-date, was changed to GPL-2 on 2008-04-16
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="eds libnotify"
+
+RDEPEND="
+ || ( >=dev-lang/python-2.5[sqlite]
+ ( dev-lang/python:2.4
+ dev-python/pysqlite:2 ) )
+ dev-python/gconf-python
+ dev-python/libgnome-python
+ dev-python/gnome-applets-python
+ dev-python/dbus-python
+ eds? ( dev-python/evolution-python )
+ libnotify? ( dev-python/notify-python )
+ >=dev-python/pygobject-2.14
+ >=dev-python/pygtk-2.12
+ >=x11-libs/gtk+-2.12
+ x11-libs/libXScrnSaver"
+
+DEPEND="${RDEPEND}
+ x11-proto/scrnsaverproto
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ python_need_rebuild
+ python_mod_optimize $(python_get_sitedir)/hamster
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+
+ python_mod_cleanup $(python_get_sitedir)/hamster
+}