summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2007-08-30 05:25:47 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2007-08-30 05:25:47 +0000
commit04df469ef8dd5d27936547bbd5e7e83ea03de74c (patch)
tree0888d8d070733d1a0b41b938eeca0073ff55d6f6 /gnome-extra/nautilus-sendto
parentStable for HPPA (bug #190531). (diff)
downloadgentoo-2-04df469ef8dd5d27936547bbd5e7e83ea03de74c.tar.gz
gentoo-2-04df469ef8dd5d27936547bbd5e7e83ea03de74c.tar.bz2
gentoo-2-04df469ef8dd5d27936547bbd5e7e83ea03de74c.zip
revbump to fix undefined symbol in pidgin plugin and versioning
(Portage version: 2.1.3.7)
Diffstat (limited to 'gnome-extra/nautilus-sendto')
-rw-r--r--gnome-extra/nautilus-sendto/ChangeLog11
-rw-r--r--gnome-extra/nautilus-sendto/files/digest-nautilus-sendto-0.12-r13
-rw-r--r--gnome-extra/nautilus-sendto/files/nautilus-sendto-0.12-debug-statements.patch15
-rw-r--r--gnome-extra/nautilus-sendto/files/nautilus-sendto-0.12-pidgin-plugin-versioning.patch21
-rw-r--r--gnome-extra/nautilus-sendto/nautilus-sendto-0.12-r1.ebuild81
5 files changed, 130 insertions, 1 deletions
diff --git a/gnome-extra/nautilus-sendto/ChangeLog b/gnome-extra/nautilus-sendto/ChangeLog
index 7eeb746f35b7..433bf3a2a87b 100644
--- a/gnome-extra/nautilus-sendto/ChangeLog
+++ b/gnome-extra/nautilus-sendto/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for gnome-extra/nautilus-sendto
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nautilus-sendto/ChangeLog,v 1.18 2007/08/29 03:59:47 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nautilus-sendto/ChangeLog,v 1.19 2007/08/30 05:25:46 compnerd Exp $
+
+*nautilus-sendto-0.12-r1 (30 Aug 2007)
+
+ 30 Aug 2007; Saleem Abdulrasool <compnerd@gentoo.org>
+ +files/nautilus-sendto-0.12-debug-statements.patch,
+ +files/nautilus-sendto-0.12-pidgin-plugin-versioning.patch,
+ +nautilus-sendto-0.12-r1.ebuild:
+ Add patches for versioning and undefined symbols in pidgin plugin. (bug
+ #190677)
*nautilus-sendto-0.12 (29 Aug 2007)
diff --git a/gnome-extra/nautilus-sendto/files/digest-nautilus-sendto-0.12-r1 b/gnome-extra/nautilus-sendto/files/digest-nautilus-sendto-0.12-r1
new file mode 100644
index 000000000000..a663b2d7bbd9
--- /dev/null
+++ b/gnome-extra/nautilus-sendto/files/digest-nautilus-sendto-0.12-r1
@@ -0,0 +1,3 @@
+MD5 9ec9a476be9a1c24ceddcfd76c6b3be2 nautilus-sendto-0.12.tar.bz2 336188
+RMD160 d90730aa1af385240d62d38bbda78ffdb699fe76 nautilus-sendto-0.12.tar.bz2 336188
+SHA256 e91af28d5473997836e85aa5eabb39e53f88fdc7cc535d2b0399afdaee1184ab nautilus-sendto-0.12.tar.bz2 336188
diff --git a/gnome-extra/nautilus-sendto/files/nautilus-sendto-0.12-debug-statements.patch b/gnome-extra/nautilus-sendto/files/nautilus-sendto-0.12-debug-statements.patch
new file mode 100644
index 000000000000..0f8c25643117
--- /dev/null
+++ b/gnome-extra/nautilus-sendto/files/nautilus-sendto-0.12-debug-statements.patch
@@ -0,0 +1,15 @@
+--- pidgin_plugin/nautilus-sendto-plugin.c.orig 2007-08-29 22:10:10.000000000 -0700
++++ pidgin_plugin/nautilus-sendto-plugin.c 2007-08-29 22:10:26.000000000 -0700
+@@ -123,10 +123,10 @@
+ fclose (fd);
+ g_string_free (buddies_str, TRUE);
+ buddies_str = str;
+- gaim_debug_info ("nautilus", "save blist online\n");
++ purple_debug_info ("nautilus", "save blist online\n");
+ }else{
+ g_string_free (str, TRUE);
+- gaim_debug_info ("nautilus", "don't save blist online. No change\n");
++ purple_debug_info ("nautilus", "don't save blist online. No change\n");
+ }
+ g_free (fd_name);
+ }else{
diff --git a/gnome-extra/nautilus-sendto/files/nautilus-sendto-0.12-pidgin-plugin-versioning.patch b/gnome-extra/nautilus-sendto/files/nautilus-sendto-0.12-pidgin-plugin-versioning.patch
new file mode 100644
index 000000000000..db2fe4dbfeb1
--- /dev/null
+++ b/gnome-extra/nautilus-sendto/files/nautilus-sendto-0.12-pidgin-plugin-versioning.patch
@@ -0,0 +1,21 @@
+--- pidgin_plugin/Makefile.am.orig 2007-08-29 22:15:29.000000000 -0700
++++ pidgin_plugin/Makefile.am 2007-08-29 22:15:52.000000000 -0700
+@@ -6,6 +6,7 @@
+ nautilus_la_LDFLAGS = -module -avoid-version
+
+ AM_CPPFLAGS = \
++ -DVERSION=\"$(VERSION)\" \
+ -DLIBDIR=\"$(PIDGIN_LIBDIR)/pidgin/\" \
+ -DDATADIR=\"$(PIDGIN_DATADIR)\" \
+ $(NAUTILUS_SENDTO_CFLAGS) \
+--- pidgin_plugin/nautilus-sendto-plugin.c.orig 2007-08-29 22:13:55.000000000 -0700
++++ pidgin_plugin/nautilus-sendto-plugin.c 2007-08-29 22:16:23.000000000 -0700
+@@ -306,7 +306,7 @@
+
+ "gtk-nautilus", /* id */
+ N_("Nautilus Integration"), /* name */
+- "0.8", /* version */
++ VERSION, /* version */
+ N_("Provides integration with Nautilus"), /* summary */
+ N_("Provides integration with Nautilus"), /* description */
+
diff --git a/gnome-extra/nautilus-sendto/nautilus-sendto-0.12-r1.ebuild b/gnome-extra/nautilus-sendto/nautilus-sendto-0.12-r1.ebuild
new file mode 100644
index 000000000000..968d916960a7
--- /dev/null
+++ b/gnome-extra/nautilus-sendto/nautilus-sendto-0.12-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nautilus-sendto/nautilus-sendto-0.12-r1.ebuild,v 1.1 2007/08/30 05:25:46 compnerd Exp $
+
+inherit gnome2 eutils autotools
+
+DESCRIPTION="A nautilus extension for sending files to locations"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="bluetooth eds gajim pidgin sylpheed thunderbird"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ >=dev-libs/glib-2.6
+ >=gnome-base/libglade-2.5.1
+ >=gnome-base/libbonobo-2.13.0
+ >=gnome-base/libbonoboui-2.13.0
+ >=gnome-base/libgnome-2.13.0
+ >=gnome-base/libgnomeui-2.13.0
+ >=gnome-base/nautilus-2.13.3
+ >=gnome-base/gconf-2.13.0
+ >=dev-libs/dbus-glib-0.71
+ bluetooth? ( >=net-wireless/gnome-bluetooth-0.6 )
+ eds? ( >=gnome-extra/evolution-data-server-1.5.3 )
+ gajim? ( net-im/gajim )
+ pidgin? ( >=net-im/pidgin-2.0.0 )
+ sylpheed? ( || (
+ mail-client/sylpheed
+ mail-client/claws-mail
+ mail-client/sylpheed-claws
+ )
+ )
+ thunderbird? ( mail-client/mozilla-thunderbird )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=gnome-base/gnome-common-0.12
+ >=dev-util/pkgconfig-0.19
+ >=dev-util/intltool-0.35"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-gaim \
+ $(use_enable bluetooth) \
+ $(use_enable eds evolution) \
+ $(use_enable pidgin) \
+ $(use_enable gajim) \
+ $(use_enable sylpheed) \
+ $(use_enable thunderbird)"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Convert autodetection into hard options
+ epatch ${FILESDIR}/${PN}-0.12-configure-options.patch
+
+ # Fix thunderbird support
+ epatch ${FILESDIR}/${PN}-0.8-thunderbird-binaries.patch
+
+ # Fix debug statements for pidgin plugin
+ epatch ${FILESDIR}/${PN}-0.12-debug-statements.patch
+
+ # Fix plugin versioning for pidgin plugin
+ epatch ${FILESDIR}/${PN}-0.12-pidgin-plugin-versioning.patch
+
+ # Oh the joys of autotools
+ eautoreconf
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ if use pidgin ; then
+ elog "To enable SendTo support in pidgin, you must enable the plugin in pidgin"
+ elog "Check Tools -> Preferences -> Plugins in the pidgin menu."
+ fi
+}