summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-12-24 15:45:17 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-12-24 15:45:17 +0000
commit57c9aeed65d42b8d0e12dbc45bd0b15244cec477 (patch)
tree67fe46cb51999820a41db62a191fed69e44d6433 /gnome-extra/seahorse-nautilus
parentUpdate hardened/linux/uclibc/mips to reflect changes to virtual/udev (diff)
downloadgentoo-2-57c9aeed65d42b8d0e12dbc45bd0b15244cec477.tar.gz
gentoo-2-57c9aeed65d42b8d0e12dbc45bd0b15244cec477.tar.bz2
gentoo-2-57c9aeed65d42b8d0e12dbc45bd0b15244cec477.zip
Version bump for Gnome 3.6. Switch to EAPI=5.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'gnome-extra/seahorse-nautilus')
-rw-r--r--gnome-extra/seahorse-nautilus/ChangeLog8
-rw-r--r--gnome-extra/seahorse-nautilus/seahorse-nautilus-3.6.1.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/gnome-extra/seahorse-nautilus/ChangeLog b/gnome-extra/seahorse-nautilus/ChangeLog
index 314515f5c0e1..fed509bd0373 100644
--- a/gnome-extra/seahorse-nautilus/ChangeLog
+++ b/gnome-extra/seahorse-nautilus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/seahorse-nautilus
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/seahorse-nautilus/ChangeLog,v 1.1 2012/05/13 18:19:31 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/seahorse-nautilus/ChangeLog,v 1.2 2012/12/24 15:45:17 eva Exp $
+
+*seahorse-nautilus-3.6.1 (24 Dec 2012)
+
+ 24 Dec 2012; Gilles Dartiguelongue <eva@gentoo.org>
+ +seahorse-nautilus-3.6.1.ebuild:
+ Version bump for Gnome 3.6. Switch to EAPI=5.
*seahorse-nautilus-3.4.0 (13 May 2012)
diff --git a/gnome-extra/seahorse-nautilus/seahorse-nautilus-3.6.1.ebuild b/gnome-extra/seahorse-nautilus/seahorse-nautilus-3.6.1.ebuild
new file mode 100644
index 000000000000..9d2a6d003d2e
--- /dev/null
+++ b/gnome-extra/seahorse-nautilus/seahorse-nautilus-3.6.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/seahorse-nautilus/seahorse-nautilus-3.6.1.ebuild,v 1.1 2012/12/24 15:45:17 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no" # --disable-debug disables all assertions
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Nautilus extension for encrypting and decrypting files with GnuPG"
+HOMEPAGE="http://www.gnome.org/projects/seahorse/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ >=app-crypt/gpgme-1.0.0
+ >=app-crypt/gcr-3.4
+ >=dev-libs/dbus-glib-0.35
+ >=dev-libs/glib-2.28:2
+ gnome-base/gnome-keyring
+ >=gnome-base/nautilus-3
+ x11-libs/gtk+:3
+ x11-libs/libcryptui
+ >=x11-libs/libnotify-0.3:=
+ || (
+ =app-crypt/gnupg-1.4*
+ =app-crypt/gnupg-2.0* )"
+# seahorse-nautilus was formerly part of seahorse-plugins
+RDEPEND="${COMMON_DEPEND}
+ !app-crypt/seahorse-plugins[nautilus]"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ DOCS="AUTHORS NEWS README THANKS" # ChangeLog is not used
+ # No point in making libnotify optional - nautilus depends on it
+ G2CONF="${G2CONF}
+ --disable-gpg-check
+ --enable-libnotify"
+
+ # Do not let configure mangle CFLAGS
+ sed -e '/^[ \t]*CFLAGS="$CFLAGS \(-g\|-O0\)/d' -i configure.ac configure ||
+ die "sed failed"
+
+ gnome2_src_prepare
+}