summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2006-05-09 19:16:05 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2006-05-09 19:16:05 +0000
commit708e26ad59262eba66261cc48f64aad757873565 (patch)
tree6976c18f9f7e12ca50963f0d1905091ce42f8e9c /gnome-extra
parentfix build issue with older libIDL versions (diff)
downloadgentoo-2-708e26ad59262eba66261cc48f64aad757873565.tar.gz
gentoo-2-708e26ad59262eba66261cc48f64aad757873565.tar.bz2
gentoo-2-708e26ad59262eba66261cc48f64aad757873565.zip
Don't free memory on stack. Fixes bug #132019 in yelp
(Portage version: 2.1_pre10-r5)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/at-spi/ChangeLog8
-rw-r--r--gnome-extra/at-spi/at-spi-1.7.7-r1.ebuild53
-rw-r--r--gnome-extra/at-spi/files/at-spi-1.7.7-no-stack-free.patch12
-rw-r--r--gnome-extra/at-spi/files/digest-at-spi-1.7.7-r13
4 files changed, 75 insertions, 1 deletions
diff --git a/gnome-extra/at-spi/ChangeLog b/gnome-extra/at-spi/ChangeLog
index afca9184c993..1739de6b10a6 100644
--- a/gnome-extra/at-spi/ChangeLog
+++ b/gnome-extra/at-spi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/at-spi
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/ChangeLog,v 1.112 2006/05/01 17:48:13 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/ChangeLog,v 1.113 2006/05/09 19:16:05 dang Exp $
+
+*at-spi-1.7.7-r1 (09 May 2006)
+
+ 09 May 2006; Daniel Gryniewicz <dang@gentoo.org>
+ +files/at-spi-1.7.7-no-stack-free.patch, +at-spi-1.7.7-r1.ebuild:
+ Don't free memory on stack. Fixes bug #132019 in yelp
*at-spi-1.7.7 (01 May 2006)
diff --git a/gnome-extra/at-spi/at-spi-1.7.7-r1.ebuild b/gnome-extra/at-spi/at-spi-1.7.7-r1.ebuild
new file mode 100644
index 000000000000..263bd92c5835
--- /dev/null
+++ b/gnome-extra/at-spi/at-spi-1.7.7-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/at-spi-1.7.7-r1.ebuild,v 1.1 2006/05/09 19:16:05 dang Exp $
+
+inherit virtualx gnome2 eutils
+
+DESCRIPTION="The Gnome Accessibility Toolkit"
+HOMEPAGE="http://developer.gnome.org/projects/gap/"
+
+LICENSE="LGPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+# >=atk-1.11 required. See
+# http://mail.gnome.org/archives/gnome-accessibility-list/2006-February/msg00036.html
+RDEPEND=">=dev-libs/atk-1.11
+ >=gnome-base/libbonobo-1.107
+ >=gnome-base/gail-1.3
+ >=x11-libs/gtk+-2
+ >=gnome-base/orbit-2
+ dev-libs/popt
+ || ( (
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXtst )
+ virtual/x11 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.31
+ doc? ( >=dev-util/gtk-doc-1 )
+ || ( (
+ x11-libs/libXt
+ x11-proto/xextproto
+ x11-proto/inputproto
+ x11-proto/xproto )
+ virtual/x11 )"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+
+src_test() {
+ Xmake check || die "Testing phase failed"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ epatch ${FILESDIR}/${P}-no-stack-free.patch
+}
diff --git a/gnome-extra/at-spi/files/at-spi-1.7.7-no-stack-free.patch b/gnome-extra/at-spi/files/at-spi-1.7.7-no-stack-free.patch
new file mode 100644
index 000000000000..c564dff47774
--- /dev/null
+++ b/gnome-extra/at-spi/files/at-spi-1.7.7-no-stack-free.patch
@@ -0,0 +1,12 @@
+diff --exclude-from=/home/dang/.diffrc -u -ruN at-spi-1.7.7.orig/atk-bridge/bridge.c at-spi-1.7.7/atk-bridge/bridge.c
+--- at-spi-1.7.7.orig/atk-bridge/bridge.c 2006-02-27 17:21:03.000000000 -0500
++++ at-spi-1.7.7/atk-bridge/bridge.c 2006-05-09 15:06:35.000000000 -0400
+@@ -694,7 +694,7 @@
+
+ g_free (e.type);
+
+- if (e.any_data._release) CORBA_free (&e.any_data._value);
++ if (e.any_data._release) CORBA_free (e.any_data._value);
+
+ va_end (args);
+
diff --git a/gnome-extra/at-spi/files/digest-at-spi-1.7.7-r1 b/gnome-extra/at-spi/files/digest-at-spi-1.7.7-r1
new file mode 100644
index 000000000000..19867c958a7c
--- /dev/null
+++ b/gnome-extra/at-spi/files/digest-at-spi-1.7.7-r1
@@ -0,0 +1,3 @@
+MD5 2988cd21d9f292fd404a8c532fe2723d at-spi-1.7.7.tar.bz2 696704
+RMD160 e19c1d3f7696832add2c3bc2a2f965acf5d019f6 at-spi-1.7.7.tar.bz2 696704
+SHA256 8e5a5a9be3e3c26068b98fbcd37e44a6c377b1d8f97735339e8dd1215b506ad6 at-spi-1.7.7.tar.bz2 696704