summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2012-02-08 14:37:37 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2012-02-08 14:37:37 +0000
commit59f471f3b73316295f48623fa637f2699c96e3a9 (patch)
tree70e36f2cb41b6e90dfe99b3f5bf0dddfa93c4037 /gnustep-base/gnustep-make
parent[bump] dev-perl/PadWalker-1.930.0 (diff)
downloadgentoo-2-59f471f3b73316295f48623fa637f2699c96e3a9.tar.gz
gentoo-2-59f471f3b73316295f48623fa637f2699c96e3a9.tar.bz2
gentoo-2-59f471f3b73316295f48623fa637f2699c96e3a9.zip
Version bump, integrate libobjc2 support (USE-flag still masked for now)
(Portage version: 2.2.0_alpha85/cvs/Linux x86_64)
Diffstat (limited to 'gnustep-base/gnustep-make')
-rw-r--r--gnustep-base/gnustep-make/ChangeLog10
-rw-r--r--gnustep-base/gnustep-make/gnustep-make-2.6.2.ebuild (renamed from gnustep-base/gnustep-make/gnustep-make-2.6.1-r10.ebuild)31
-rw-r--r--gnustep-base/gnustep-make/metadata.xml2
3 files changed, 24 insertions, 19 deletions
diff --git a/gnustep-base/gnustep-make/ChangeLog b/gnustep-base/gnustep-make/ChangeLog
index 3e08d53e5697..23e4ad5aefad 100644
--- a/gnustep-base/gnustep-make/ChangeLog
+++ b/gnustep-base/gnustep-make/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnustep-base/gnustep-make
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/ChangeLog,v 1.102 2011/06/09 09:47:21 voyageur Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/ChangeLog,v 1.103 2012/02/08 14:37:37 voyageur Exp $
+
+*gnustep-make-2.6.2 (08 Feb 2012)
+
+ 08 Feb 2012; Bernard Cafarelli <voyageur@gentoo.org>
+ -gnustep-make-2.6.1-r10.ebuild, +gnustep-make-2.6.2.ebuild, metadata.xml:
+ Version bump, integrate libobjc2 support (USE-flag still masked for now)
*gnustep-make-2.6.1-r1 (09 Jun 2011)
diff --git a/gnustep-base/gnustep-make/gnustep-make-2.6.1-r10.ebuild b/gnustep-base/gnustep-make/gnustep-make-2.6.2.ebuild
index 09f701b30d32..689194fdaf7f 100644
--- a/gnustep-base/gnustep-make/gnustep-make-2.6.1-r10.ebuild
+++ b/gnustep-base/gnustep-make/gnustep-make-2.6.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/gnustep-make-2.6.1-r10.ebuild,v 1.2 2011/06/09 09:47:21 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/gnustep-make-2.6.2.ebuild,v 1.1 2012/02/08 14:37:37 voyageur Exp $
-EAPI="3"
+EAPI=4
inherit gnustep-base eutils prefix
@@ -16,21 +16,21 @@ SLOT="0"
LICENSE="GPL-2"
DEPEND="${GNUSTEP_CORE_DEPEND}
- >=sys-devel/gcc-3.3[objc]
>=sys-devel/make-3.75
libobjc2? ( gnustep-base/libobjc2
>=sys-devel/clang-2.9 )
- !libobjc2? ( !gnustep-base/libobjc2 )"
+ !libobjc2? ( !gnustep-base/libobjc2
+ >=sys-devel/gcc-3.3[objc] )"
RDEPEND="${DEPEND}"
pkg_setup() {
if ( use libobjc2 && ! has_version gnustep-base/gnustep-make[libobjc2] ) || \
( ! use libobjc2 && has_version gnustep-base/gnustep-make[libobjc2] ) || \
- ( use libobjc2 && has_version <=gnustep-base-2.6.1-r1 ) ; then
- ewarn "TOGGLED liobjc2 USE-FLAG WARNING:"
+ ( use libobjc2 && has_version <gnustep-base-2.6.2 ) ; then
+ ewarn "TOGGLED libobjc2 USE-FLAG WARNING:"
ewarn "You changed the libojbc2 use-flag"
ewarn "You must rebuild all gnustep packages installed."
- # Suggest gnustep-updater once updated to do the trick
+ # Suggest gnustep-updater once it can do the trick
fi
}
@@ -47,22 +47,23 @@ src_configure() {
export CC=clang
fi
- #--enable-objc-nonfragile-abi: problem with glibc unistd.h (__blocks)
+ #--enable-objc-nonfragile-abi: only working in clang for now
+ #--with-objc-lib-flag: TODO use to force libobjc2 or not
econf \
--with-layout=fhs-system \
--with-config-file="${EPREFIX}"/etc/GNUstep/GNUstep.conf \
- $(use_enable native-exceptions native-objc-exceptions) \
- || die "configure failed"
+ $(use_enable libobjc2 objc-nonfragile-abi) \
+ $(use_enable native-exceptions native-objc-exceptions)
}
src_compile() {
- emake || die "compilation failed"
+ emake
# Prepare doc here (needed when no gnustep-make is already installed)
if use doc ; then
# If a gnustep-1 environment is set
unset GNUSTEP_MAKEFILES
pushd Documentation &> /dev/null
- emake all install || die "doc make has failed"
+ emake all install
popd &> /dev/null
fi
}
@@ -75,7 +76,7 @@ src_install() {
use debug || make_eval="${make_eval} debug=no"
make_eval="${make_eval} verbose=yes"
- emake ${make_eval} DESTDIR="${D}" install || die "install has failed"
+ emake ${make_eval} DESTDIR="${D}" install
# Copy the documentation
if use doc ; then
@@ -100,6 +101,4 @@ pkg_postinst() {
ewarn "then remerge all packages still installed with the old layout"
ewarn "You can use gnustep-base/gnustep-updater for this task"
fi
-
- # TODO warn if libobjc2 flag changed
}
diff --git a/gnustep-base/gnustep-make/metadata.xml b/gnustep-base/gnustep-make/metadata.xml
index 816a08388d56..10f57cdec6a4 100644
--- a/gnustep-base/gnustep-make/metadata.xml
+++ b/gnustep-base/gnustep-make/metadata.xml
@@ -10,7 +10,7 @@ configuration, building, installation, and packaging. It also allows
the user to easily create cross-compiled binaries.
</longdescription>
<use>
- <flag name='libobjc2'>Enables use of the GNUstep Objective-C runtime (<pkg>gnustep-base/libobjc2</pkg>) with <pkg>sys-devel/clang</pkg> compiler</flag>
+ <flag name='libobjc2'>Enables use of the GNUstep Objective-C runtime (<pkg>gnustep-base/libobjc2</pkg>) with non-fragile ABI and <pkg>sys-devel/clang</pkg> compiler</flag>
<flag name='native-exceptions'>Enables use of the native Objective-C exception support (@try/@catch/@finally) built-in objective-c exceptions with compilers that support it </flag>
</use>
</pkgmetadata>