summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2009-05-11 10:57:28 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2009-05-11 10:57:28 +0000
commitddb0d62780c26228251b6fcedbbf381b3e1c54fb (patch)
treea934feb6c1852406d7c092346cffb18f02e02fee /gnustep-base
parentVersion bump (diff)
downloadgentoo-2-ddb0d62780c26228251b6fcedbbf381b3e1c54fb.tar.gz
gentoo-2-ddb0d62780c26228251b6fcedbbf381b3e1c54fb.tar.bz2
gentoo-2-ddb0d62780c26228251b6fcedbbf381b3e1c54fb.zip
Version bump, now with parallel make support!
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-make/ChangeLog10
-rw-r--r--gnustep-base/gnustep-make/gnustep-make-2.2.0.ebuild79
2 files changed, 87 insertions, 2 deletions
diff --git a/gnustep-base/gnustep-make/ChangeLog b/gnustep-base/gnustep-make/ChangeLog
index b34fad595822..58b33a355364 100644
--- a/gnustep-base/gnustep-make/ChangeLog
+++ b/gnustep-base/gnustep-make/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnustep-base/gnustep-make
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/ChangeLog,v 1.81 2009/03/27 10:11:51 voyageur Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/ChangeLog,v 1.82 2009/05/11 10:57:28 voyageur Exp $
+
+*gnustep-make-2.2.0 (11 May 2009)
+
+ 11 May 2009; Bernard Cafarelli <voyageur@gentoo.org>
+ +gnustep-make-2.2.0.ebuild:
+ Version bump, now with parallel make support!
27 Mar 2009; Bernard Cafarelli <voyageur@gentoo.org>
gnustep-make-2.0.8.ebuild:
diff --git a/gnustep-base/gnustep-make/gnustep-make-2.2.0.ebuild b/gnustep-base/gnustep-make/gnustep-make-2.2.0.ebuild
new file mode 100644
index 000000000000..166cd9c171f3
--- /dev/null
+++ b/gnustep-base/gnustep-make/gnustep-make-2.2.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/gnustep-make-2.2.0.ebuild,v 1.1 2009/05/11 10:57:28 voyageur Exp $
+
+EAPI=2
+
+inherit gnustep-base eutils
+
+DESCRIPTION="GNUstep Makefile Package"
+
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="native-exceptions"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="${GNUSTEP_CORE_DEPEND}
+ >=sys-devel/gcc-3.3[objc]
+ >=sys-devel/make-3.75"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.0.1-destdir.patch
+}
+
+src_configure() {
+ local myconf
+ myconf="--prefix=${GNUSTEP_PREFIX} --with-layout=gnustep"
+ myconf="$myconf --with-config-file=/etc/GNUstep/GNUstep.conf"
+ myconf="$myconf $(use_enable native-exceptions native-objc-exceptions)"
+ econf $myconf || die "configure failed"
+}
+
+src_compile() {
+ emake || die "compilation failed"
+ # Prepare doc here (needed when no gnustep-make is already installed)
+ if use doc ; then
+ # If a gnustep-1 environment is set
+ unset GNUSTEP_MAKEFILES
+ cd Documentation
+ emake all install || die "doc make has failed"
+ cd ..
+ fi
+}
+
+src_install() {
+ # Get GNUSTEP_* variables
+ . ./GNUstep.conf
+
+ local make_eval
+ use debug || make_eval="${make_eval} debug=no"
+ make_eval="${make_eval} verbose=yes"
+
+ emake ${make_eval} DESTDIR="${D}" install || die "install has failed"
+
+ # Copy the documentation
+ if use doc ; then
+ dodir ${GNUSTEP_SYSTEM_LIBRARY}
+ cp -r Documentation/tmp-installation/System/Library/Documentation \
+ "${D}"${GNUSTEP_SYSTEM_LIBRARY}
+ fi
+
+ dodoc FAQ README RELEASENOTES
+
+ exeinto /etc/profile.d
+ doexe "${FILESDIR}"/gnustep-2.sh
+ doexe "${FILESDIR}"/gnustep-2.csh
+
+ dodir /etc/env.d
+ cat <<- EOF > "${D}"/etc/env.d/99gnustep
+PATH=${GNUSTEP_SYSTEM_TOOLS}:${GNUSTEP_LOCAL_TOOLS}
+ROOTPATH=${GNUSTEP_SYSTEM_TOOLS}:${GNUSTEP_LOCAL_TOOLS}
+LDPATH=${GNUSTEP_SYSTEM_LIBRARIES}:${GNUSTEP_LOCAL_LIBRARIES}
+MANPATH=${GNUSTEP_SYSTEM_DOC_MAN}:${GNUSTEP_LOCAL_DOC_MAN}
+INFOPATH=${GNUSTEP_SYSTEM_DOC_INFO}:${GNUSTEP_LOCAL_DOC_INFO}
+INFODIR=${GNUSTEP_SYSTEM_DOC_INFO}:${GNUSTEP_LOCAL_DOC_INFO}
+EOF
+}